summaryrefslogtreecommitdiff
path: root/app-emacs/edit-list
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/edit-list
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/edit-list')
-rw-r--r--app-emacs/edit-list/Manifest4
-rw-r--r--app-emacs/edit-list/edit-list-0.3.ebuild17
-rw-r--r--app-emacs/edit-list/files/50edit-list-gentoo.el3
-rw-r--r--app-emacs/edit-list/metadata.xml15
4 files changed, 39 insertions, 0 deletions
diff --git a/app-emacs/edit-list/Manifest b/app-emacs/edit-list/Manifest
new file mode 100644
index 000000000000..612b86037bd6
--- /dev/null
+++ b/app-emacs/edit-list/Manifest
@@ -0,0 +1,4 @@
+AUX 50edit-list-gentoo.el 122 BLAKE2B ee35de192d38fa23b662045130afcfa84334e9143b70cd13d6279849667f6b4ebdfd428d0519071475d7db826933ceafd814bb1872cc5b76eb8e9892d6a836a2 SHA512 7f7404c402f4b5208ac1bc786b554629eb616d99dc97ed55256f22405f8e27815215f8c47e2c15f1b2d90f64da464df41f5a20905e76856eddbd2f9e414bed64
+DIST edit-list-0.3.el.bz2 2072 BLAKE2B f6e98b44a6ba73bc727d5725c58756d4dd70017831deb184ed1e7f40697fac37d3b7a7a78dbc51218b5b2cca924702032ba29f5d42b3c814edd6b4d64f31ecaf SHA512 f7441d42e95b46d0cefd5cc32af5c0738aa15b338b81e31dc89fa968fc34e6387b6bc927999f4e077632acf6c2edcbbac609eb066363db896099f5fa3e19c1e7
+EBUILD edit-list-0.3.ebuild 407 BLAKE2B cee6a86c10ee37e586635765883b0b5cfe09e84232b1c109f9194f3d5b4243931b992438574cb09fa48a77a9421421cdc9782e77f498085e7aa2d20ba905cb1a SHA512 e2efc21dfcd7595fd5ccf6a852b077362526cf661772d3e0b33473d7ce042ff5ec47a44fe0597be533137368b05c88c20e3536bfd76637aa7340ce99421a9a72
+MISC metadata.xml 585 BLAKE2B b4accf8c31a949e6efd60706ad95e3407be89fbb6c2ca8b6d5673fdb97d1fe7d299d8340d7688d0a6733ede719e5b74759adbc635d2119f46b431e83c12f5ede SHA512 967a12a75ad279a00131ad923315c3565189e93116500955bd45ec153f7d224e2d202d0e526e9a0496aaafa591a06875bd17adfed2dbe040c98551bf1f636b90
diff --git a/app-emacs/edit-list/edit-list-0.3.ebuild b/app-emacs/edit-list/edit-list-0.3.ebuild
new file mode 100644
index 000000000000..01ef68801bd6
--- /dev/null
+++ b/app-emacs/edit-list/edit-list-0.3.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Edit a single list"
+HOMEPAGE="http://mwolson.org/projects/"
+# taken from http://mwolson.org/static/dist/elisp/edit-list.el
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.el.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/edit-list/files/50edit-list-gentoo.el b/app-emacs/edit-list/files/50edit-list-gentoo.el
new file mode 100644
index 000000000000..ec4d1975e3bc
--- /dev/null
+++ b/app-emacs/edit-list/files/50edit-list-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'edit-list "edit-list"
+ "Edit a list called LIST-NAME interactively." t)
diff --git a/app-emacs/edit-list/metadata.xml b/app-emacs/edit-list/metadata.xml
new file mode 100644
index 000000000000..6513eb7668ac
--- /dev/null
+++ b/app-emacs/edit-list/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<longdescription>
+ So you've just added an incorrect entry to auto-mode-alist and want to fix
+ it quickly. `M-x edit-list RET auto-mode-alist RET' to the rescue. Make your
+ changes and hit either `C-x C-s' or `C-c C-c' when done. Or just kill the
+ buffer if you change your mind.
+</longdescription>
+<stabilize-allarches/>
+</pkgmetadata>