summaryrefslogtreecommitdiff
path: root/app-emacs/edit-list
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-emacs/edit-list
reinit the tree, so we can have metadata
Diffstat (limited to 'app-emacs/edit-list')
-rw-r--r--app-emacs/edit-list/Manifest6
-rw-r--r--app-emacs/edit-list/edit-list-0.3.ebuild17
-rw-r--r--app-emacs/edit-list/files/50edit-list-gentoo.el3
-rw-r--r--app-emacs/edit-list/metadata.xml14
4 files changed, 40 insertions, 0 deletions
diff --git a/app-emacs/edit-list/Manifest b/app-emacs/edit-list/Manifest
new file mode 100644
index 000000000000..1e40817a1d44
--- /dev/null
+++ b/app-emacs/edit-list/Manifest
@@ -0,0 +1,6 @@
+AUX 50edit-list-gentoo.el 122 SHA256 97f2e62e11eb6518c3197c365d3f0a4c640b3687075bbbac8e715df9e8b68c64 SHA512 7f7404c402f4b5208ac1bc786b554629eb616d99dc97ed55256f22405f8e27815215f8c47e2c15f1b2d90f64da464df41f5a20905e76856eddbd2f9e414bed64 WHIRLPOOL 5046d46fa21f8f3d2d10b3114b95fa342e974b2373a704d126420a2bf2036a6a237620d09ae427f07d6f6dfd5def855c6d8e7b38af2b8a94005fc945661ef8c1
+DIST edit-list-0.3.el.bz2 2072 SHA256 2ce1542d60938987f835ed0fb67d975bf7ac0b1ce1b732ccdda07e65b427c23c SHA512 f7441d42e95b46d0cefd5cc32af5c0738aa15b338b81e31dc89fa968fc34e6387b6bc927999f4e077632acf6c2edcbbac609eb066363db896099f5fa3e19c1e7 WHIRLPOOL 8ec7b7c269cc6dd5c3cc74c2829420e7fea4e3155e003df8869499d9c3daf61a0f193ce443ffcbae4533f208aae0abd2dc306b5ee8e52d7d16429579e6a785c9
+EBUILD edit-list-0.3.ebuild 407 SHA256 a0c6e9b6621d13717e759d8f7ac0fddf54906ef2662cd37d26edb5967ef058d5 SHA512 e2efc21dfcd7595fd5ccf6a852b077362526cf661772d3e0b33473d7ce042ff5ec47a44fe0597be533137368b05c88c20e3536bfd76637aa7340ce99421a9a72 WHIRLPOOL 0e19c4a469685e79486c32f52794fc0af2947d45a287e6d5274ea495819212e5455c7d60af9db7f7ffd5edefb3a0e59988cc71fcc173bd49cb2f3532336b22e2
+MISC ChangeLog 2371 SHA256 77457b1ed6f834a823d5ac803209971b617e59124a5e0331738f2700e91ece5a SHA512 c9b1f9ecf81c89ed75c8082d0f8cdaa2ce9cca5b6b87919638fe26b9f1553565ba225c092acdb28ae881be1a5c22454e4a6ff429879bfa680ed29c16a38d6f97 WHIRLPOOL aae17d72408e619506e3cd35e84708ce2be5e4c725908cddd3ac1d6900afb490f83f484e19f1cb0cad47386289d3a02bcb6c1380dc7ae8f0660fdbaca91f05a8
+MISC ChangeLog-2015 548 SHA256 c173c10eea8a8867199667bc6f18dfccf30ff2c045a8ad754d6b73f4cfd03198 SHA512 4df360b2cf071399393ac91f42955ea48e85c3ff2070246edceacc92a0fa1e9c484343da6f4ce907ff872b0a3f22c46043100cd5a7f306374f22e7bb027235c3 WHIRLPOOL cbc2f63707d95a0828895ac67ce63bc914f09f3e5a37781bbb4d8a390532e53e8d9c6a74dd20c4449ec1a26a71099efa0d4152905203402c38bfb76094835fdf
+MISC metadata.xml 562 SHA256 6310921bdf89ff9f41086a6bf07dd899c098b39a344a559e750aac2d610a2b6a SHA512 eed1505d6bf7ba28830b929daf8beb44ef314d65c628e1d04e11c2b099540362f44669aefef46385a9d41f211a7e7aee52034a14412464b813bdfb60ce3ce04d WHIRLPOOL e1b03abee3572b86dfe66285610a0415bd955bbf852e9cdd543cf71473ee60d27a7b238d0f5294e39015f2038ec6c74f556d5dbec2cf6d54c5a432631450be98
diff --git a/app-emacs/edit-list/edit-list-0.3.ebuild b/app-emacs/edit-list/edit-list-0.3.ebuild
new file mode 100644
index 000000000000..01ef68801bd6
--- /dev/null
+++ b/app-emacs/edit-list/edit-list-0.3.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Edit a single list"
+HOMEPAGE="http://mwolson.org/projects/"
+# taken from http://mwolson.org/static/dist/elisp/edit-list.el
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.el.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/edit-list/files/50edit-list-gentoo.el b/app-emacs/edit-list/files/50edit-list-gentoo.el
new file mode 100644
index 000000000000..ec4d1975e3bc
--- /dev/null
+++ b/app-emacs/edit-list/files/50edit-list-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'edit-list "edit-list"
+ "Edit a list called LIST-NAME interactively." t)
diff --git a/app-emacs/edit-list/metadata.xml b/app-emacs/edit-list/metadata.xml
new file mode 100644
index 000000000000..22ae043ed5c3
--- /dev/null
+++ b/app-emacs/edit-list/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<longdescription>
+ So you've just added an incorrect entry to auto-mode-alist and want to fix
+ it quickly. `M-x edit-list RET auto-mode-alist RET' to the rescue. Make your
+ changes and hit either `C-x C-s' or `C-c C-c' when done. Or just kill the
+ buffer if you change your mind.
+</longdescription>
+</pkgmetadata>