summaryrefslogtreecommitdiff
path: root/app-emacs/edit-indirect
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-21 20:55:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-21 20:55:01 +0100
commiteb509e1a15f595f667e8d177ddb73311084af6c0 (patch)
treefbc083f793d438d54b7fb4ec3a7e0286701b81bb /app-emacs/edit-indirect
parenteedf7b9dec39b69b43f7b581da418d37428db449 (diff)
gentoo auto-resync : 21:05:2023 - 20:55:01
Diffstat (limited to 'app-emacs/edit-indirect')
-rw-r--r--app-emacs/edit-indirect/Manifest4
-rw-r--r--app-emacs/edit-indirect/edit-indirect-0.1.10.ebuild23
-rw-r--r--app-emacs/edit-indirect/files/50edit-indirect-gentoo.el3
-rw-r--r--app-emacs/edit-indirect/metadata.xml18
4 files changed, 48 insertions, 0 deletions
diff --git a/app-emacs/edit-indirect/Manifest b/app-emacs/edit-indirect/Manifest
new file mode 100644
index 000000000000..9f78b86001ac
--- /dev/null
+++ b/app-emacs/edit-indirect/Manifest
@@ -0,0 +1,4 @@
+AUX 50edit-indirect-gentoo.el 140 BLAKE2B 944e2e6d5c58312838d64ff3849960f4a22589f4e682a2aac1c2f25de6acc6a1aa615b91e4de429d15ce4ac3cb6af6c77dc4a092841f38f48d9967bb71b429e4 SHA512 48298e0be07d56e30810134065e05460c4fb6ed18d9bddd752f20aa7eee174f17c3cdeb4c7ad2660a6b3931f39810e2f39aea0f79d0b15a279ffb1970e0916b5
+DIST edit-indirect-0.1.10.tar.gz 5270 BLAKE2B c54d6c47b67e257bde5cf4f075b3c28ea1711f2002d64389018eb088ee6a0084adf77d75a44661630b197326dc3d357694f7f43d3e2f87ebca3d5489fa169076 SHA512 5b1dc2b73bf61072e8687f0923a852cf9e49ae9817dd676d6a503361b86a906641716cb743b0cc9c30dddaaf772bdc30f63a87a58869e99139dab8a0f4c0a367
+EBUILD edit-indirect-0.1.10.ebuild 504 BLAKE2B cd6ee2fd9b4c145eac91049e3c1605c35559e825f969d5dc657ae3a7b41df02f8f6b24649998c74ccfb8a65e568a56a4cc8736f2a9300bd5ed7dab49948eab76 SHA512 2da6a2cdef69903a174490191d04bad70d810c55456cdbde90cd9f0d54c072258c6ca945ce6daaedd523f45b748b0a8f23d9d9d5762ce12456d3cbdccfacacb7
+MISC metadata.xml 647 BLAKE2B 2c100bcd2a2e4b0c89507902906ac8a03b656fe1b854bcc19c0f2868aca69a5365d9ebcf6ceeacd9fb5c7d78a35f081502b6e472a287864709fe7b008ee2c81c SHA512 ada96c5560eb10394b2945157a1fcc8c2c62e806f73265e29362213f3433641d91dd84bad72a3c8dc1bc72b12804286252b4cc3261fc253dd01c011a98ed7b79
diff --git a/app-emacs/edit-indirect/edit-indirect-0.1.10.ebuild b/app-emacs/edit-indirect/edit-indirect-0.1.10.ebuild
new file mode 100644
index 000000000000..ca35092609a1
--- /dev/null
+++ b/app-emacs/edit-indirect/edit-indirect-0.1.10.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Edit regions in separate Emacs buffers"
+HOMEPAGE="https://github.com/Fanael/edit-indirect/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Fanael/${PN}.git"
+else
+ SRC_URI="https://github.com/Fanael/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/edit-indirect/files/50edit-indirect-gentoo.el b/app-emacs/edit-indirect/files/50edit-indirect-gentoo.el
new file mode 100644
index 000000000000..3523a6574dd3
--- /dev/null
+++ b/app-emacs/edit-indirect/files/50edit-indirect-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'edit-indirect-region "edit-indirect"
+ "Edit the region BEG..END in a separate buffer." t)
diff --git a/app-emacs/edit-indirect/metadata.xml b/app-emacs/edit-indirect/metadata.xml
new file mode 100644
index 000000000000..06616bbdfe27
--- /dev/null
+++ b/app-emacs/edit-indirect/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ Edit buffer regions in separate Emacs buffers, like org-edit-src-code (from
+ the Org package) but for arbitrary regions. Used by markdown-mode.
+ </longdescription>
+ <stabilize-allarches />
+ <upstream>
+ <bugs-to>https://github.com/Fanael/edit-indirect/issues/</bugs-to>
+ <remote-id type="github">Fanael/edit-indirect</remote-id>
+ </upstream>
+</pkgmetadata>