summaryrefslogtreecommitdiff
path: root/app-emacs/edb/edb-1.34.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-21 14:44:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-21 14:44:25 +0100
commit2480f36bfb3d39469cc44843d1fe664bd40443a3 (patch)
tree1c57ba55297055b6b0a88830282439b6c6d58d0c /app-emacs/edb/edb-1.34.ebuild
parent3c54b2473c5fb6fe0fc543b15fc4678471922cb1 (diff)
gentoo auto-resync : 21:07:2022 - 14:44:25
Diffstat (limited to 'app-emacs/edb/edb-1.34.ebuild')
-rw-r--r--app-emacs/edb/edb-1.34.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-emacs/edb/edb-1.34.ebuild b/app-emacs/edb/edb-1.34.ebuild
new file mode 100644
index 000000000000..71e3a01fe172
--- /dev/null
+++ b/app-emacs/edb/edb-1.34.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="EDB, The Emacs Database"
+HOMEPAGE="https://www.gnuvola.org/software/edb/
+ https://www.emacswiki.org/emacs/EmacsDataBase"
+SRC_URI="https://www.gnuvola.org/software/edb/${P}.tar.gz"
+
+LICENSE="GPL-3+ Texinfo-manual"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_configure() {
+ default
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ emake -j1 \
+ sitelisp="${ED}${SITELISP}" \
+ infodir="${ED}/usr/share/info" \
+ install
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc AUTHORS BUGS ChangeLog HACKING NEWS README THANKS TODO doc/refcard.ps
+ dodoc -r examples
+}