summaryrefslogtreecommitdiff
path: root/app-emacs/ecb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/ecb
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/ecb')
-rw-r--r--app-emacs/ecb/Manifest5
-rw-r--r--app-emacs/ecb/ecb-2.41_pre20140215-r1.ebuild51
-rw-r--r--app-emacs/ecb/files/70ecb-gentoo.el2
-rw-r--r--app-emacs/ecb/files/ecb-2.32-gentoo.patch73
-rw-r--r--app-emacs/ecb/metadata.xml39
5 files changed, 170 insertions, 0 deletions
diff --git a/app-emacs/ecb/Manifest b/app-emacs/ecb/Manifest
new file mode 100644
index 000000000000..8a1d748bb17d
--- /dev/null
+++ b/app-emacs/ecb/Manifest
@@ -0,0 +1,5 @@
+AUX 70ecb-gentoo.el 63 BLAKE2B aafdd070c44a1f7f4aad23ee1d0ff39f1816bb46fa1e667ef12eb276d1877ca18a81c43ae66c285574b85a089255e6613c92dbe751d382280b42613976829cae SHA512 984cfbfa398bd60008dee83721a55f5c6cad0a71caf0d7cc194a84f0d7c061a9a99398e40e90f0a9cf79d2ff689e374c860612bea16e9fa0049d7a82edc56283
+AUX ecb-2.32-gentoo.patch 3430 BLAKE2B 8d373b5ebc1064d5b2fb713f6d3bc31ec34eddfeb9b9519e655bdaab0ced4e4c4aaca03b3013d0daeceaca20f9210625b84d76264be24d9ea99a5745336c0f06 SHA512 1902cec83e62c9b65a62a1fd4a7c8e2ae309b3bd2217b6f821a5a047cf3bdda24b9b5c68e672c1555196a7d28ce06c22398ef15c3c0e6b87bcce1e15d3c333fb
+DIST ecb-2.41_pre20140215.tar.xz 565404 BLAKE2B 135aa4a71bb41e78933604c5e549d8a163715061c7946e90a115cf802499f9a78884e554cbf4fd4edc9b5856b1f32b3189eb3e1e2537b16e5dd57cfe3ccd1ee3 SHA512 bf87bdd38e7ddaeec044fc56d56f7c456ef0a1922f50b962f932bf739895f046387bab7a934439e749fd7e838d9f742938408f4f9cb47079440abd8c1ba181b6
+EBUILD ecb-2.41_pre20140215-r1.ebuild 1226 BLAKE2B 1cdc2a77228d611fd8ffea0f7f7136d0fbe7a519a0ede55eb06e83a6fb1098ebf8314bc1aed6086bc129c9787bfa4f28654c1082fbe953b4e90a428da0f554d5 SHA512 9cf484eb1e4cd0a895eacd2730e0d991b62d6bb3187ba096583e2c6a091496efcfddd86db61368c8bc2e83acf7fe0716791dd6620ddfe3ea064fc93ca093bbaa
+MISC metadata.xml 1593 BLAKE2B 611c6e5a6f1bf4bcc78dcc3fd35e6e01067162d7fd4f6f0186f94011e9d4e154eb343189302713ec911fc70e00f603b08f2add5da2acf9272d5d3f90db1387e4 SHA512 613a3f9a08c5f467de2190b4de2a794c5f8cf8ff1fc3bca4328581be199799d01a312391176a6469643e4cfdf8aab757dce922115910f282931783993d81e392
diff --git a/app-emacs/ecb/ecb-2.41_pre20140215-r1.ebuild b/app-emacs/ecb/ecb-2.41_pre20140215-r1.ebuild
new file mode 100644
index 000000000000..1a427bfba276
--- /dev/null
+++ b/app-emacs/ecb/ecb-2.41_pre20140215-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit readme.gentoo elisp eutils
+
+DESCRIPTION="Source code browser for Emacs"
+HOMEPAGE="http://ecb.sourceforge.net/"
+# snapshot of https://github.com/alexott/ecb.git, created with "make distrib"
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="java"
+
+DEPEND="!!<app-emacs/cedet-2.0
+ java? ( app-emacs/jde )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-${PV%_*}"
+SITEFILE="70${PN}-gentoo.el"
+DOC_CONTENTS="ECB is autoloaded in site-gentoo.el. Add the line
+ \n\t(require 'ecb)
+ \nto your ~/.emacs file to enable all features on Emacs startup."
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.32-gentoo.patch"
+ sed -i -e "s:@PF@:${PF}:" ecb-help.el || die "sed failed"
+}
+
+src_compile() {
+ local loadpath="" sl=${EPREFIX}${SITELISP}
+ if use java; then
+ loadpath="${sl}/elib ${sl}/jde ${sl}/jde/lisp"
+ fi
+
+ emake LOADPATH="${loadpath}"
+}
+
+src_install() {
+ elisp_src_install
+
+ insinto "${SITEETC}/${PN}"
+ doins -r ecb-images
+
+ doinfo info-help/ecb.info*
+ dohtml html-help/*.html
+ dodoc NEWS README RELEASE_NOTES
+}
diff --git a/app-emacs/ecb/files/70ecb-gentoo.el b/app-emacs/ecb/files/70ecb-gentoo.el
new file mode 100644
index 000000000000..bc71f7c18e94
--- /dev/null
+++ b/app-emacs/ecb/files/70ecb-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(require 'ecb-autoloads)
diff --git a/app-emacs/ecb/files/ecb-2.32-gentoo.patch b/app-emacs/ecb/files/ecb-2.32-gentoo.patch
new file mode 100644
index 000000000000..09d3d86afdcd
--- /dev/null
+++ b/app-emacs/ecb/files/ecb-2.32-gentoo.patch
@@ -0,0 +1,73 @@
+Change default paths to Gentoo install locations.
+Allow for compressed Info files.
+
+--- ecb-2.32-orig/ecb-common-browser.el 2005-07-11 16:16:01.000000000 +0200
++++ ecb-2.32/ecb-common-browser.el 2009-03-03 09:42:51.000000000 +0100
+@@ -261,10 +261,7 @@
+ ;; additonal images are necessary - but currently i don't think we need
+ ;; special images for this analyse-stuff.
+ (defcustom ecb-tree-image-icons-directories
+- (let ((base (concat (if ecb-regular-xemacs-package-p
+- (format "%s" (locate-data-directory "ecb"))
+- ecb-ecb-dir)
+- "ecb-images/")))
++ (let ((base "/usr/share/emacs/etc/ecb/ecb-images/"))
+ (cons (concat base "default/height-17")
+ (mapcar (function (lambda (i)
+ (cons (car i) (concat base (cdr i)))))
+--- ecb-2.32-orig/ecb-help.el 2005-07-11 16:16:00.000000000 +0200
++++ ecb-2.32/ecb-help.el 2009-03-03 09:47:49.000000000 +0100
+@@ -81,16 +81,8 @@
+ (const :tag "Html" :value html)))
+
+
+-(defcustom ecb-help-info-path (concat
+- (if ecb-running-xemacs
+- (if (file-exists-p
+- (concat ecb-ecb-dir
+- ecb-help-info-subdir
+- ecb-help-info-start-file))
+- ecb-help-info-subdir
+- "../../info/")
+- ecb-help-info-subdir)
+- ecb-help-info-start-file)
++(defcustom ecb-help-info-path
++ (concat "/usr/share/info/" ecb-help-info-start-file)
+ "*Path where the ECB online help in info format resides.
+ This must be the location of the file \"ecb.info\" which comes with the ECB
+ distribution. If is installed by unpacking the archive available on the ECB
+@@ -107,24 +99,7 @@
+ :type 'file)
+
+ (defcustom ecb-help-html-path
+- (if (not ecb-running-xemacs)
+- (concat ecb-help-html-subdir ecb-help-html-start-file)
+- (cond ((file-exists-p
+- (concat ecb-ecb-dir
+- ecb-help-html-subdir
+- ecb-help-html-start-file))
+- (concat ecb-help-html-subdir ecb-help-html-start-file))
+- ((file-exists-p
+- (concat ecb-ecb-dir
+- "../../html/"
+- ecb-help-html-start-file))
+- (concat "../../html/" ecb-help-html-start-file))
+- ((file-exists-p
+- (concat ecb-ecb-dir
+- "../../html/ecb/index.html"))
+- "../../html/ecb/index.html")
+- (t
+- (concat "../../etc/ecb/html/" ecb-help-html-start-file))))
++ (concat "/usr/share/doc/@PF@/html/" ecb-help-html-start-file)
+ "*Path where the ECB online help in HTML format resides.
+ This must be the location of the file \"index.html\" which comes with the ECB
+ distribution. If is installed by unpacking the archive available on the ECB
+@@ -145,7 +120,7 @@
+ "Starts `info' with INFO-FILE. If INFO-FILE does not exists then nil is
+ returned otherwise true. If NO-FILE-NOT-EXIST-ERR is not nil then just nil is
+ returned if INFO-FILE does not exist otherwise an error is reported."
+- (if (file-exists-p info-file)
++ (if (file-expand-wildcards (concat info-file "*"))
+ (prog1 t
+ (info info-file))
+ (unless no-file-not-exist-err
diff --git a/app-emacs/ecb/metadata.xml b/app-emacs/ecb/metadata.xml
new file mode 100644
index 000000000000..842f361ee663
--- /dev/null
+++ b/app-emacs/ecb/metadata.xml
@@ -0,0 +1,39 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<longdescription>
+ ECB stands for "Emacs Code Browser". While Emacs already has good editing
+ support for many modes, its browsing support is somewhat lacking. That's
+ where ECB comes in: it displays a number of informational windows that allow
+ for easy source code navigation and overview.
+
+ The informational windows can contain:
+
+ * A directory tree,
+ * a list of source files in the current directory,
+ * a list of functions/classes/methods/... in the current file, (ECB uses
+ the Semantic Bovinator, or Imenu, or etags, for getting this list so all
+ languages supported by any of these tools are automatically supported by
+ ECB too),
+ * a history of recently visited files,
+ * the Speedbar and
+ * output from compilation (the compilation window) and other modes like
+ help, grep etc. or whatever a user defines to be displayed in this
+ window.
+
+ As an added bonus, ECB makes sure to keep these informational windows
+ visible, even when you use C-x 1 and similar commands.
+
+ It goes without saying that you can configure the layout, ie. which
+ informational windows should be displayed where. ECB comes with a number of
+ ready-made window layouts to choose from.
+</longdescription>
+<stabilize-allarches/>
+<upstream>
+ <remote-id type="sourceforge">ecb</remote-id>
+</upstream>
+</pkgmetadata>