summaryrefslogtreecommitdiff
path: root/app-emacs/dune-format/dune-format-0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /app-emacs/dune-format/dune-format-0.1.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'app-emacs/dune-format/dune-format-0.1.ebuild')
-rw-r--r--app-emacs/dune-format/dune-format-0.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-emacs/dune-format/dune-format-0.1.ebuild b/app-emacs/dune-format/dune-format-0.1.ebuild
new file mode 100644
index 000000000000..a2b2acf211da
--- /dev/null
+++ b/app-emacs/dune-format/dune-format-0.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.1
+
+inherit elisp
+
+DESCRIPTION="Reformat OCaml's dune files automatically"
+HOMEPAGE="https://github.com/purcell/emacs-dune-format/"
+SRC_URI="https://github.com/purcell/emacs-${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/emacs-${P}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="app-emacs/reformatter"
+RDEPEND="
+ ${BDEPEND}
+ dev-ml/dune
+"
+
+DOCS=( README.md )
+ELISP_REMOVE="Makefile" # Makefile downloads pkgs from net
+SITEFILE="50${PN}-gentoo.el"