summaryrefslogtreecommitdiff
path: root/app-emacs/dropdown-list
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/dropdown-list
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/dropdown-list')
-rw-r--r--app-emacs/dropdown-list/Manifest5
-rw-r--r--app-emacs/dropdown-list/dropdown-list-20120329.ebuild17
-rw-r--r--app-emacs/dropdown-list/files/50dropdown-list-gentoo.el2
-rw-r--r--app-emacs/dropdown-list/files/dropdown-list-20090814-selection-face.patch13
-rw-r--r--app-emacs/dropdown-list/metadata.xml9
5 files changed, 46 insertions, 0 deletions
diff --git a/app-emacs/dropdown-list/Manifest b/app-emacs/dropdown-list/Manifest
new file mode 100644
index 000000000000..b0161535797d
--- /dev/null
+++ b/app-emacs/dropdown-list/Manifest
@@ -0,0 +1,5 @@
+AUX 50dropdown-list-gentoo.el 80 BLAKE2B 1436cae45270d53081bdad97ccb4c013658e4d0464a99e2dd2a8a5d6a7aabaa9ab30e64cccf515980362db6355e1421629b018868d60f47164cb90462c0329ab SHA512 38187bab921b29bdcb2c9e585660f6fab519ab1ab286aa2e848b670e5087578d361d8edf81ac32391e98133583148cb830cd69f67dc7f1d1049cfdb636abb497
+AUX dropdown-list-20090814-selection-face.patch 382 BLAKE2B 9979e1246d15d07b9c10de7d2edde12d75af355519e419108560067276995c18534fafccaccb8c79f97ad7dae9b8975ccf996fbe0f5c33357b532fc6f9dad827 SHA512 197941c2aaf14862d1f6405836c577c9fb1aac32f7e6cd18b44aabbeaa0e84036f752fcd56c7324d922bfdd14684d355689d60d1b91140f758d080246acd6dcc
+DIST dropdown-list-20120329.el.xz 3104 BLAKE2B 37d240cad53bf2062b3877f4d6118c6f1fedd28da68f7e4d7ffb9d38492a5805f7e01c5d640770e40ab271fc007fd640fd9500d15c208f9c5af79c01c19b9330 SHA512 fac1139c1339cb94be6bfd2c0e6adddfd1851b55aaba6112e0c451e2666f22cc0fa9013d5cc03bb86c6adf3e4f076d90975ab8e59546956d753cd9613309919d
+EBUILD dropdown-list-20120329.ebuild 421 BLAKE2B 82cd66e33c04192b497276a38a0e15fa6123e9e2b4b8333082c5609542058eb2c93ddcb50a9c4a60a4131e3154f13d911a7ae6129c0f5e109db60fa0b43aeacd SHA512 64a535a27df11f2b4246abd11d3f9bdfffd930d518817191079adecab5be77eee8244b540af0836ed7ae09973e888dd6821cef6535ccfbf58c8013138ef90c8f
+MISC metadata.xml 282 BLAKE2B 432e60a3b04def9f566fde3852011e006c0d578c72c42115734d1af5c128440fcee68134c8f891baad437e64a8d61fbbac49e70a35ed4f6f85641e888d3a2547 SHA512 1838e22e1f5b849b816a05d1b25bd81333c8cf67ceb996177e05ba7a555b8e0e307e62cb53e6f1217f4216823e2fecf050e85437678503d60e10c6b2d5303072
diff --git a/app-emacs/dropdown-list/dropdown-list-20120329.ebuild b/app-emacs/dropdown-list/dropdown-list-20120329.ebuild
new file mode 100644
index 000000000000..0518265c4411
--- /dev/null
+++ b/app-emacs/dropdown-list/dropdown-list-20120329.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Drop-down menu interface"
+HOMEPAGE="https://www.emacswiki.org/emacs/dropdown-list.el"
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.el.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+ELISP_PATCHES="${PN}-20090814-selection-face.patch"
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/dropdown-list/files/50dropdown-list-gentoo.el b/app-emacs/dropdown-list/files/50dropdown-list-gentoo.el
new file mode 100644
index 000000000000..f6abfe2f993a
--- /dev/null
+++ b/app-emacs/dropdown-list/files/50dropdown-list-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'dropdown-list "dropdown-list")
diff --git a/app-emacs/dropdown-list/files/dropdown-list-20090814-selection-face.patch b/app-emacs/dropdown-list/files/dropdown-list-20090814-selection-face.patch
new file mode 100644
index 000000000000..7c8adc3bf653
--- /dev/null
+++ b/app-emacs/dropdown-list/files/dropdown-list-20090814-selection-face.patch
@@ -0,0 +1,13 @@
+http://code.google.com/p/yasnippet/issues/detail?id=23
+
+--- dropdown-list.el~
++++ dropdown-list.el
+@@ -69,7 +69,7 @@
+ "*Bla." :group 'dropdown-list)
+
+ (defface dropdown-list-selection-face
+- '((t :inherit dropdown-list :background "purple"))
++ '((t :inherit dropdown-list-face :background "purple"))
+ "*Bla." :group 'dropdown-list)
+
+ (defvar dropdown-list-overlays nil)
diff --git a/app-emacs/dropdown-list/metadata.xml b/app-emacs/dropdown-list/metadata.xml
new file mode 100644
index 000000000000..c918cdef9591
--- /dev/null
+++ b/app-emacs/dropdown-list/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<stabilize-allarches/>
+</pkgmetadata>