summaryrefslogtreecommitdiff
path: root/app-emacs/distel
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/distel
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/distel')
-rw-r--r--app-emacs/distel/Manifest4
-rw-r--r--app-emacs/distel/distel-4.0.6.ebuild38
-rw-r--r--app-emacs/distel/files/50distel-gentoo.el4
-rw-r--r--app-emacs/distel/metadata.xml12
4 files changed, 58 insertions, 0 deletions
diff --git a/app-emacs/distel/Manifest b/app-emacs/distel/Manifest
new file mode 100644
index 000000000000..6a5501baa73d
--- /dev/null
+++ b/app-emacs/distel/Manifest
@@ -0,0 +1,4 @@
+AUX 50distel-gentoo.el 197 BLAKE2B 4c58633362840f228ff45786c2ded8811504def269f978d79f853bf556c2c673b8235203ed72b2119cf27f252fb603643562e26cb3ca7c75a4550461b9b95267 SHA512 1ed45f84dde596713c8f14b0eed011d9e2f073196f55cf355f3ad8c4b540aac94d7d4a1780a0020719b74f4eb3a610094ab5ed4e1ad142604937fbdaf50d2b6b
+DIST distel-4.0.6.tar.gz 210257 BLAKE2B 615682bfc2b773a78ad85d4817135144dda787d1db57b2743ea2fca8ed672fc1e37f6bc23803c9cc2b6096e7376d318cd7c25c3133f7b9c1326dbd451273841b SHA512 510f82b6794379d89020d234462e09251e0db285ebc111eaf096e32a4e3619384650cb2b47ed68d38762a496504b58981c73ca5b930bd0eb1407aee9599c149f
+EBUILD distel-4.0.6.ebuild 922 BLAKE2B 3c604aae95aa29fd62f69d57750217fae6dd8a41636bf0d8affca05c79abc9fa0e670be9f30336c2291a0db4259995b19652efd456c083fab08e95f560fa5b45 SHA512 013f6fcbaa8baae4e291fa1649d238351e166ad727a4545f06be15fea7603b670356cdacc72df4e3448f132fa99035a6981f1518833077317f59825cadc42fef
+MISC metadata.xml 390 BLAKE2B 995ade09d45f16251665ffd7198d296959276bcc01ae085ecaba280022e47dbb3b9f6ebbbfcdd6d5038ef7dfe7779894a25fbc32feb5953c297e20f4321f6d7b SHA512 3652b1dc7101e291fbe1a9f4a1a54fb5692ce0e345fbd1164b6c32ae57e32af90dea1b22a648e7083d7b18f4730c6338da34e9cf3688a2e9ccee134f2dcda26c
diff --git a/app-emacs/distel/distel-4.0.6.ebuild b/app-emacs/distel/distel-4.0.6.ebuild
new file mode 100644
index 000000000000..b0cdc9f49d4a
--- /dev/null
+++ b/app-emacs/distel/distel-4.0.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Distributed Emacs Lisp for Erlang"
+HOMEPAGE="https://code.google.com/p/distel/
+ https://www.emacswiki.org/emacs/DistributedEmacsLisp"
+SRC_URI="https://github.com/massemanet/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+# "New BSD License" according to https://code.google.com/p/distel/
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND=">=dev-lang/erlang-11.2.5[emacs]"
+RDEPEND="${DEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ emake base info
+ cd elisp || die
+ elisp-compile *.el
+}
+
+src_install() {
+ emake prefix="${ED}"/usr \
+ ELISP_DIR="${ED}${SITELISP}/${PN}" install
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ doinfo doc/distel.info
+ dohtml doc/distel/*.html
+ dodoc AUTHORS ChangeLog NEWS README*
+ use doc && dodoc doc/gorrie02distel.pdf
+}
diff --git a/app-emacs/distel/files/50distel-gentoo.el b/app-emacs/distel/files/50distel-gentoo.el
new file mode 100644
index 000000000000..485b2dc27746
--- /dev/null
+++ b/app-emacs/distel/files/50distel-gentoo.el
@@ -0,0 +1,4 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'distel-erlang-mode-hook "distel" nil t)
+(add-hook 'erlang-mode-hook 'distel-erlang-mode-hook)
+(setq distel-ebin-directory "/usr/share/distel/ebin")
diff --git a/app-emacs/distel/metadata.xml b/app-emacs/distel/metadata.xml
new file mode 100644
index 000000000000..ee26b8d81751
--- /dev/null
+++ b/app-emacs/distel/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<upstream>
+ <remote-id type="google-code">distel</remote-id>
+ <remote-id type="github">massemanet/distel</remote-id>
+</upstream>
+</pkgmetadata>