summaryrefslogtreecommitdiff
path: root/app-emacs/dired-hacks
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-23 01:23:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-23 01:23:10 +0100
commit7828eef5de9e45f50282e2b1eaf348f1ac7af477 (patch)
treeea872a4f1afc4b28699120de310c5d87b75ea5d0 /app-emacs/dired-hacks
parentcd18653acd5ce929bb0ec77dde842439db6f060c (diff)
gentoo auto-resync : 23:06:2023 - 01:23:10
Diffstat (limited to 'app-emacs/dired-hacks')
-rw-r--r--app-emacs/dired-hacks/Manifest4
-rw-r--r--app-emacs/dired-hacks/dired-hacks-0.0.1_p20230621.ebuild48
-rw-r--r--app-emacs/dired-hacks/files/50dired-hacks-gentoo.el2
-rw-r--r--app-emacs/dired-hacks/metadata.xml13
4 files changed, 67 insertions, 0 deletions
diff --git a/app-emacs/dired-hacks/Manifest b/app-emacs/dired-hacks/Manifest
new file mode 100644
index 000000000000..f5e324a450aa
--- /dev/null
+++ b/app-emacs/dired-hacks/Manifest
@@ -0,0 +1,4 @@
+AUX 50dired-hacks-gentoo.el 75 BLAKE2B 04b58a3b91dcf4e14fa5aff5d8e8f57ef3e2677322713bf5521b066c6ec8a84e6edf3709e9487d729527f229a57bca39a090724f402e6f08e69e4cd26baffe16 SHA512 64018247a1f58d013b30a2ff5c4e79d2d5a0b59b7cc8605dcd4ad14c733eb931b203dae14169606938ba308c84d3b6b372b7b0d24c79bfb1989a662801cd71a8
+DIST dired-hacks-0.0.1_p20230621.tar.gz 70320 BLAKE2B 1f28f4f54c250b82c3897a42273337a0a1c1ccc2a0c46addcf55d30a2e5bc61211665860701a83379e9ae8252d389fde3c51b7cf8a8739e11b5aac2ff2447293 SHA512 c682149af031807fa3a9d64bbe7f78896af57a066d37809b6889a968162e5787e751520ebf975e7765f6b37f38a19a679b0c9123d8d0bb687086e18de803c848
+EBUILD dired-hacks-0.0.1_p20230621.ebuild 923 BLAKE2B bd5ed5c87e83d392f90599900d3884f138ea590a1fb52f7dee11da6d421db7feecfa3c602146ded9c1b4268efb0e0e4d9e49219ae122f5e3cfd21ac1a66cafd7 SHA512 d7aef9f45836d5b87a2b8d2fc2fc81e3326da58321dd4bc597b0cc2c1dc67aa08e3acd20986457aeb76b2e765aa0ac96105cfe88d309c2e5a4d6959235ecd4d9
+MISC metadata.xml 423 BLAKE2B 70733434dd985aad5572e1b3c32cef5c1bab5a858905290c077402f889495ad5ebcfd10c1f25c480e5279924907e806c3734245c31098f6ae75a9d663b74d466 SHA512 235901e1d2b9ab93130b4f4d374202104938e7c05a7af28dfe9885880bb4fd630c06b9fd41e264e0c22354b7b294aa455ab54ddb6603c213a2d86370f7f86b4b
diff --git a/app-emacs/dired-hacks/dired-hacks-0.0.1_p20230621.ebuild b/app-emacs/dired-hacks/dired-hacks-0.0.1_p20230621.ebuild
new file mode 100644
index 000000000000..412bdb2f86b3
--- /dev/null
+++ b/app-emacs/dired-hacks/dired-hacks-0.0.1_p20230621.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Collection of useful dired additions for GNU Emacs"
+HOMEPAGE="https://github.com/Fuco1/dired-hacks/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Fuco1/${PN}.git"
+else
+ [[ ${PV} == *_p20230621 ]] && COMMIT=874449d6fc98aee565e1715ec18acec3c1c2cafb
+ SRC_URI="https://github.com/Fuco1/${PN}/archive/${COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${COMMIT}
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+RESTRICT="test" # Tests fail.
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND="
+ app-emacs/dash
+ app-emacs/eimp
+ app-emacs/f
+ app-emacs/s
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ app-emacs/assess
+ app-emacs/shut-up
+ )
+"
+
+elisp-enable-tests buttercup tests
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}
diff --git a/app-emacs/dired-hacks/files/50dired-hacks-gentoo.el b/app-emacs/dired-hacks/files/50dired-hacks-gentoo.el
new file mode 100644
index 000000000000..3efac2fa37c8
--- /dev/null
+++ b/app-emacs/dired-hacks/files/50dired-hacks-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "dired-hacks-autoloads" nil t)
diff --git a/app-emacs/dired-hacks/metadata.xml b/app-emacs/dired-hacks/metadata.xml
new file mode 100644
index 000000000000..ed56e656fcb7
--- /dev/null
+++ b/app-emacs/dired-hacks/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/Fuco1/dired-hacks/issues/</bugs-to>
+ <remote-id type="github">Fuco1/dired-hacks</remote-id>
+ </upstream>
+</pkgmetadata>