summaryrefslogtreecommitdiff
path: root/app-emacs/diff-hl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /app-emacs/diff-hl
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'app-emacs/diff-hl')
-rw-r--r--app-emacs/diff-hl/Manifest4
-rw-r--r--app-emacs/diff-hl/diff-hl-1.8.8_p20220405.ebuild37
-rw-r--r--app-emacs/diff-hl/files/50diff-hl-gentoo.el33
-rw-r--r--app-emacs/diff-hl/metadata.xml13
4 files changed, 87 insertions, 0 deletions
diff --git a/app-emacs/diff-hl/Manifest b/app-emacs/diff-hl/Manifest
new file mode 100644
index 000000000000..866b0b3615c2
--- /dev/null
+++ b/app-emacs/diff-hl/Manifest
@@ -0,0 +1,4 @@
+AUX 50diff-hl-gentoo.el 1736 BLAKE2B c743490ef717dcc1ec72fc44a2c2a05792ff60cee702ac06b105a39d5fb088ee2816d23cf9a54d8686d3db5af6649f5793738273bd054e2f486da949eb3cf9c7 SHA512 ac3c8d3f1566515fe8be749619764febe3fdf24820d5e7a95f1eb9eff8329cb5e4fa7da848e867ece8772b5d7a1e75e159091da5194ec16bd2724febeacb6f8b
+DIST diff-hl-1.8.8_p20220405.tar.gz 241924 BLAKE2B 316326eaca5e37155665436e923b9c8fa2a05cee6cf37bdb4c8538dc2ca8575fa7eff736e125b063c92abc0365c42743907f01edcfb7df2837f58bb2cad2a62e SHA512 4055699146f4244863c2be05a2196db7c51de16c9403ddad926b93b6be87b704efba1b578c2570d25a6e4da2d73863f8298691e26d270513558200169da02e04
+EBUILD diff-hl-1.8.8_p20220405.ebuild 997 BLAKE2B 9ed0d40bb0754f35ff4fac74de99f7284801c61602786c562f5e85fc5180d3f155709efc2ef70916191d2a04163503fe037df25bc2487cffbd29d01bdaadcf89 SHA512 549923a536ea2cfed026b8f9b3e93ba0a44215f00289eeb9676dc83fbc87233f9f32b01f8fe2719bb381e089b90f84401d3eb2cb658e14fe412a15c1650dc395
+MISC metadata.xml 417 BLAKE2B 8008d30c29065e61bd3fe0188f6c882993cfcb3021ed3dc650f9a12e7ef625e1f743ab6e405ce63d7d29a49f54f2987b7dee73025cc936e5356b09a5e0fb7038 SHA512 eaccfd63d897f54a6d2426028eaa1eb47f80fd63136446b5344dcdb599727680a81a13faa917a07d4899ed92f233dd247a161bf8610a701e29270955d3975209
diff --git a/app-emacs/diff-hl/diff-hl-1.8.8_p20220405.ebuild b/app-emacs/diff-hl/diff-hl-1.8.8_p20220405.ebuild
new file mode 100644
index 000000000000..6c4bd522d0a7
--- /dev/null
+++ b/app-emacs/diff-hl/diff-hl-1.8.8_p20220405.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=9d5dc2ffa1e4c7b43734b03dccb5ae6a80800569
+NEED_EMACS=25.1
+
+inherit elisp
+
+DESCRIPTION="Highlight uncommitted changes, jump between and revert them selectively"
+HOMEPAGE="https://github.com/dgutov/diff-hl/"
+SRC_URI="https://github.com/dgutov/${PN}/archive/${H}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${H}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-vcs/git )"
+
+DOCS=( README.md screenshot.png screenshot-dired.png screenshot-margin.png )
+ELISP_REMOVE=( .dir-locals.el )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ebegin "Creating a git repository for tests"
+ git init "${S}" --initial-branch="master" &&
+ git add "${S}" &&
+ git config --local user.email "test@test" &&
+ git config --local user.name "test" &&
+ git commit --message "test" --quiet
+ eend $? || die
+ emake EMACS="${EMACS} ${EMACSFLAGS}" test
+}
diff --git a/app-emacs/diff-hl/files/50diff-hl-gentoo.el b/app-emacs/diff-hl/files/50diff-hl-gentoo.el
new file mode 100644
index 000000000000..3240f13a619b
--- /dev/null
+++ b/app-emacs/diff-hl/files/50diff-hl-gentoo.el
@@ -0,0 +1,33 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'diff-hl-mode "diff-hl"
+ "Toggle VC diff highlighting." t)
+(autoload 'diff-hl-set-reference-rev "diff-hl"
+ "Set the reference revision globally to REV." t)
+(autoload 'diff-hl-reset-reference-rev "diff-hl"
+ "Reset the reference revision globally to the most recent one." t)
+(autoload 'global-diff-hl-mode "diff-hl"
+ "Toggle Diff-Hl mode in all buffers." t)
+(autoload 'diff-hl-amend-mode "diff-hl-amend"
+ "Show changes against the second-last revision in `diff-hl-mode'." t)
+(autoload 'global-diff-hl-amend-mode "diff-hl-amend"
+ "Toggle Diff-Hl-Amend mode in all buffers." t)
+(autoload 'diff-hl-dired-mode "diff-hl-dired"
+ "Toggle VC diff highlighting on the side of a Dired window." t)
+(autoload 'diff-hl-flydiff-mode "diff-hl-flydiff"
+ "Perform highlighting on-the-fly." t)
+(autoload 'diff-hl-inline-popup-hide "diff-hl-inline-popup"
+ "Hide the current inline popup." t)
+(autoload 'diff-hl-margin-mode "diff-hl-margin"
+ "Toggle displaying `diff-hl-mode' highlights on the margin." t)
+(autoload 'diff-hl-margin-local-mode "diff-hl-margin"
+ "Toggle displaying `diff-hl-mode' highlights on the margin locally." t)
+(autoload 'diff-hl-show-hunk-previous "diff-hl-show-hunk"
+ "Go to previous hunk/change and show it." t)
+(autoload 'diff-hl-show-hunk-next "diff-hl-show-hunk"
+ "Go to next hunk/change and show it." t)
+(autoload 'diff-hl-show-hunk "diff-hl-show-hunk"
+ "Show the VC diff hunk at point." t)
+(autoload 'diff-hl-show-hunk-mouse-mode "diff-hl-show-hunk"
+ "Enables the margin and fringe to show a posframe/popup with vc diffs when clicked." t)
+(autoload 'global-diff-hl-show-hunk-mouse-mode "diff-hl-show-hunk"
+ "Toggle Diff-Hl-Show-Hunk-Mouse mode in all buffers." t)
diff --git a/app-emacs/diff-hl/metadata.xml b/app-emacs/diff-hl/metadata.xml
new file mode 100644
index 000000000000..1d385a07e76e
--- /dev/null
+++ b/app-emacs/diff-hl/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/dgutov/diff-hl/issues/</bugs-to>
+ <remote-id type="github">dgutov/diff-hl</remote-id>
+ </upstream>
+</pkgmetadata>