summaryrefslogtreecommitdiff
path: root/app-emacs/diff-hl/diff-hl-1.9.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-20 02:17:30 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-20 02:17:30 +0000
commit8dd17625671faf6a47abf31d4c96a1e20d764ba5 (patch)
tree6dd5062cd293d1c2fc5af1f89cd548c7b3a62f3c /app-emacs/diff-hl/diff-hl-1.9.2.ebuild
parentd4725f7e03f4d243d29d408f4b9de39459e00d4c (diff)
gentoo auto-resync : 20:02:2023 - 02:17:29
Diffstat (limited to 'app-emacs/diff-hl/diff-hl-1.9.2.ebuild')
-rw-r--r--app-emacs/diff-hl/diff-hl-1.9.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-emacs/diff-hl/diff-hl-1.9.2.ebuild b/app-emacs/diff-hl/diff-hl-1.9.2.ebuild
new file mode 100644
index 000000000000..dd39684a4320
--- /dev/null
+++ b/app-emacs/diff-hl/diff-hl-1.9.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=25.1
+
+inherit elisp
+
+DESCRIPTION="Highlight uncommitted changes, jump between and revert them selectively"
+HOMEPAGE="https://github.com/dgutov/diff-hl/"
+SRC_URI="https://github.com/dgutov/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-vcs/git )"
+
+DOCS=( README.md screenshot{,-dired,-margin}.png )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ebegin "Creating a git repository for tests"
+ git init "${S}" --initial-branch="master" &&
+ git add "${S}" &&
+ git config --local user.email "test@test" &&
+ git config --local user.name "test" &&
+ git commit --message "test" --quiet
+ eend "${?}" || die
+
+ emake EMACS="${EMACS} ${EMACSFLAGS}" test
+}