summaryrefslogtreecommitdiff
path: root/app-emacs/denote
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-08 23:11:34 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-08 23:11:34 +0000
commit1a74c5436dbcb832445250e8f3ed0a00f6c2fcef (patch)
tree894da263e3a728142059a616daf4c6a1925a0efa /app-emacs/denote
parent39cf9c5c49469d4a3168620ab74b1648c87e205e (diff)
gentoo auto-resync : 08:12:2023 - 23:11:34
Diffstat (limited to 'app-emacs/denote')
-rw-r--r--app-emacs/denote/Manifest4
-rw-r--r--app-emacs/denote/denote-2.1.0.ebuild39
-rw-r--r--app-emacs/denote/files/50denote-gentoo.el2
-rw-r--r--app-emacs/denote/metadata.xml20
4 files changed, 65 insertions, 0 deletions
diff --git a/app-emacs/denote/Manifest b/app-emacs/denote/Manifest
new file mode 100644
index 000000000000..67455254baf4
--- /dev/null
+++ b/app-emacs/denote/Manifest
@@ -0,0 +1,4 @@
+AUX 50denote-gentoo.el 70 BLAKE2B 2b6dbb3df79b83b23a7fdc94c07c8f1a73d2f8daf12b95977885126b256d54bd295bbf5e86963aa566881cd4bfb1aa2b5579640e8e3ff04653e7f78a84207b9e SHA512 3200da6cccf70cc0dcd8dfb1a1ba26c9b97728b0f6c2a5debf2d1e71dccec7a6b773ba2a92a515b3b967c0149119bfa3f02443c5107637ed12d1bb86ea29c8cd
+DIST denote-2.1.0.tar.gz 194241 BLAKE2B 2d3a279f99bbaa7d924c17b4df960f725fa548a5f809c51abea9f8c66c2e7bbba0cc3bfe1d71fb187542f5acc7f8272ea14f352b6122872bdbc41a7110660adc SHA512 5f36e7a2b6802fa9623226318762a06fc542589773a4441d19b02efe2e75c04753971726029150ddba8faf5a56c5030239f09c4942757ad7f7374c1ca587b390
+EBUILD denote-2.1.0.ebuild 868 BLAKE2B 225ef561ca4d299dc7551ea4a2dbaaf00784a086adc7351813b62e0e91f3519eec82acfb995f9df3280956abefdb1ec588a3adae8450808d52f6b5cf8d097ee9 SHA512 81a899fd06364cdbe25aa2ad67f80271869659390fa618775235f3de298d63b40d01a337a71e48ce6d60b81dc4ac24c796d10e287788263265e940f76313bdeb
+MISC metadata.xml 849 BLAKE2B e9f07889455e07d9fcb822913278e6d6211d58c1ff15403db3ec0eb71966f9338b62f2f57761f2e426f7d0d32c393d75b829190a3acc9131fc244b72063980ce SHA512 59b1594605678afd973c5abda6af69a7f97b8271c80a23a9ac9c740dd3ca7e6d1c2027279e94dc5a019bec0998558a6d3d6a5a94ecd61e42c3b1380105f8c390
diff --git a/app-emacs/denote/denote-2.1.0.ebuild b/app-emacs/denote/denote-2.1.0.ebuild
new file mode 100644
index 000000000000..244dcb96f2d8
--- /dev/null
+++ b/app-emacs/denote/denote-2.1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=28.1
+
+inherit elisp
+
+DESCRIPTION="Simple notes for Emacs with an efficient file-naming scheme"
+HOMEPAGE="https://protesilaos.com/emacs/denote/
+ https://github.com/protesilaos/denote/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/protesilaos/${PN}.git"
+else
+ SRC_URI="https://github.com/protesilaos/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+RESTRICT="test" # Some tests fail.
+
+DOCS=( CHANGELOG.org README.md )
+ELISP_TEXINFO="${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests ert tests
+
+src_compile() {
+ elisp-org-export-to texinfo README.org
+ elisp_src_compile
+ elisp-make-autoload-file
+}
diff --git a/app-emacs/denote/files/50denote-gentoo.el b/app-emacs/denote/files/50denote-gentoo.el
new file mode 100644
index 000000000000..a11724713f3f
--- /dev/null
+++ b/app-emacs/denote/files/50denote-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "denote-autoloads" nil t)
diff --git a/app-emacs/denote/metadata.xml b/app-emacs/denote/metadata.xml
new file mode 100644
index 000000000000..d564aa6e7d59
--- /dev/null
+++ b/app-emacs/denote/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ Denote is a simple note-taking tool for Emacs. It is based on the idea that
+ notes should follow a predictable and descriptive file-naming scheme. The
+ file name must offer a clear indication of what the note is about, without
+ reference to any other metadata. Denote basically streamlines the creation
+ of such files while providing facilities to link between them.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/protesilaos/denote/issues/</bugs-to>
+ <remote-id type="github">protesilaos/denote</remote-id>
+ </upstream>
+</pkgmetadata>