summaryrefslogtreecommitdiff
path: root/app-emacs/dap-mode
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /app-emacs/dap-mode
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'app-emacs/dap-mode')
-rw-r--r--app-emacs/dap-mode/Manifest5
-rw-r--r--app-emacs/dap-mode/dap-mode-0.7.ebuild54
-rw-r--r--app-emacs/dap-mode/files/50dap-mode-gentoo.el1
-rw-r--r--app-emacs/dap-mode/files/dap-mode-dap-ui-images-root-dir.patch12
-rw-r--r--app-emacs/dap-mode/metadata.xml14
5 files changed, 86 insertions, 0 deletions
diff --git a/app-emacs/dap-mode/Manifest b/app-emacs/dap-mode/Manifest
new file mode 100644
index 000000000000..e8257fa9817d
--- /dev/null
+++ b/app-emacs/dap-mode/Manifest
@@ -0,0 +1,5 @@
+AUX 50dap-mode-gentoo.el 38 BLAKE2B e96c6cf48d1522d89450e11d339c76210c672377208b56951791b83c6ef22b2c872d313084e199dd5d7b533a99106a87dbc7f15b5ee6126f71bf5f2e84165ffa SHA512 5c00bcabe2d7cc03013dc7a54b2c653940c08098ca5646d7c73624cb1ca04376ae9dcf88a7166b1925c69f0c5d192d90f6bd790fdef8ed8c3b0f9d163c987da5
+AUX dap-mode-dap-ui-images-root-dir.patch 474 BLAKE2B 5431f14e767d1328249eb4904efb989d7a0e762489749049d95f4ecb4334a86f5821bdb54e602694e83718f14f2f789474075b0d3c59c676d753ae3afd4a7725 SHA512 7ccc2c9abea28103da7f9f4f4b2f42af6b92465269513784bc290e14e309df81cc826a5f19e5c246d2b173d33137db73170817455abe749ff4bf7366b057abd2
+DIST dap-mode-0.7.tar.gz 6147924 BLAKE2B 300a058134e58e5ae5f94fd62251c1c621478b3148e7453ef5acd062a2c6088f0036e3ac2588ce22138d39b77221396c3f310177914b08a2bbc177cfbc14efce SHA512 ba8d8e2b3e9b699b27226b13624b24a6f78ea884fe9e8e7667537e06285354bf996f7f5d621e2576ad34bbf02ede316bf001444b8b5c67fa604aa5dc5d9416ff
+EBUILD dap-mode-0.7.ebuild 980 BLAKE2B 412893db0272a548685834d675265f737a28d3d8073a57500a78dbd687981bce40f96cbfaa26d896fa740de0f08ea234769833b0e56f940fd32713d4936e8d8f SHA512 bd756a815d4b9d648a0f14c067036faddc47c34b89379cc6e7b9f2f9ce3a03e5cc8aa6f9de4d23e358e5f3564c1c286589acbbfcc886da916aef7f5a08cbec95
+MISC metadata.xml 526 BLAKE2B 1f55ae3dda8c23869f85a281117c57c42078957e710018b146df8d8293e159bdae9297fee626538b55182153eef95206f700da8c0744cc4e3b0a73932afdec9e SHA512 635327c51267e271d0a458c8a12f40cb3ee573180f1d0ccfaf1718cd641fabb9fcd4237a755f1710d569a926d953482da3d3dcf591ab893f74a01895b336c549
diff --git a/app-emacs/dap-mode/dap-mode-0.7.ebuild b/app-emacs/dap-mode/dap-mode-0.7.ebuild
new file mode 100644
index 000000000000..38928cefa99b
--- /dev/null
+++ b/app-emacs/dap-mode/dap-mode-0.7.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26.1
+
+inherit elisp
+
+DESCRIPTION="Debug Adapter Protocol mode"
+HOMEPAGE="https://github.com/emacs-lsp/dap-mode/"
+SRC_URI="https://github.com/emacs-lsp/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-emacs/bui
+ app-emacs/dash
+ app-emacs/f
+ app-emacs/ht
+ app-emacs/lsp-mode
+ app-emacs/lsp-treemacs
+ app-emacs/posframe
+ app-emacs/s
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( app-emacs/ert-runner )
+"
+
+DOCS=( CHANGELOG.org README.org )
+PATCHES=( "${FILESDIR}"/${PN}-dap-ui-images-root-dir.patch )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ elisp_src_prepare
+
+ sed "s|@SITEETC@|${SITEETC}/${PN}|" -i dap-ui.el || die
+}
+
+src_test() {
+ ert-runner -L . -L test --reporter ert+duration || die
+}
+
+src_install() {
+ elisp_src_install
+
+ insinto ${SITEETC}/${PN}
+ doins -r icons
+}
diff --git a/app-emacs/dap-mode/files/50dap-mode-gentoo.el b/app-emacs/dap-mode/files/50dap-mode-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/dap-mode/files/50dap-mode-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/dap-mode/files/dap-mode-dap-ui-images-root-dir.patch b/app-emacs/dap-mode/files/dap-mode-dap-ui-images-root-dir.patch
new file mode 100644
index 000000000000..53bbb2ad13b2
--- /dev/null
+++ b/app-emacs/dap-mode/files/dap-mode-dap-ui-images-root-dir.patch
@@ -0,0 +1,12 @@
+index ba02fee..56be79f 100644
+--- a/dap-ui.el
++++ b/dap-ui.el
+@@ -486,7 +486,7 @@ DEBUG-SESSION is the debug session triggering the event."
+
+
+ ;; dap-ui posframe stuff
+-(defvar dap-ui--control-images-root-dir (f-join (f-dirname (file-truename (or load-file-name buffer-file-name))) "icons/vscode"))
++(defvar dap-ui--control-images-root-dir "@SITEETC@/icons/vscode")
+ (defvar dap-ui--control-buffer " *dap-ui*")
+
+ (defun dap-ui--create-command (image command hover-text)
diff --git a/app-emacs/dap-mode/metadata.xml b/app-emacs/dap-mode/metadata.xml
new file mode 100644
index 000000000000..c5f3eebffb11
--- /dev/null
+++ b/app-emacs/dap-mode/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <changelog>https://raw.githubusercontent.com/emacs-lsp/dap-mode/master/CHANGELOG.org</changelog>
+ <bugs-to>https://github.com/emacs-lsp/dap-mode/issues/</bugs-to>
+ <remote-id type="github">emacs-lsp/dap-mode</remote-id>
+ </upstream>
+</pkgmetadata>