summaryrefslogtreecommitdiff
path: root/app-emacs/css-mode
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/css-mode
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/css-mode')
-rw-r--r--app-emacs/css-mode/Manifest5
-rw-r--r--app-emacs/css-mode/css-mode-0.11-r1.ebuild28
-rw-r--r--app-emacs/css-mode/files/50css-mode-gentoo.el3
-rw-r--r--app-emacs/css-mode/files/css-mode-0.11-no-compat-kbd.patch24
-rw-r--r--app-emacs/css-mode/metadata.xml9
5 files changed, 69 insertions, 0 deletions
diff --git a/app-emacs/css-mode/Manifest b/app-emacs/css-mode/Manifest
new file mode 100644
index 000000000000..1bb3fe3b19f4
--- /dev/null
+++ b/app-emacs/css-mode/Manifest
@@ -0,0 +1,5 @@
+AUX 50css-mode-gentoo.el 171 BLAKE2B 031ee725bb003a73a9aa98d35b4f8fd0fdc853e81c23f93ae69ba64ab24590e6ce22df442ac6ad4e1651f5a543b5885b0d661c47b7b11514df4fc2b8f355f7c6 SHA512 18713c42439aa4d076b7154035ba369060bfc8a0e98e845b7140e137b05ed0aacc2a25ec93612e950fe930c5605d6ea909d5d1ed79433d1472f357bc272ce96e
+AUX css-mode-0.11-no-compat-kbd.patch 875 BLAKE2B 587f49af1b892522d94ed10d41ad2555f078c41d02d4ad0fce0c1643b5449ce49a2dffed8181f8e60949e36a481a7fd5795fff7c9b63aec8330e5db6baa6bc8b SHA512 27f298f89cc15c2104fe27712f0a02676074fcdd8417ec8cc515ab461e27aec63d6325fdfe4c269c4212fa4c2e12975dcfe7d7eb345b2f31a4d12dc0189c523b
+DIST css-mode-0.11.tar.bz2 6848 BLAKE2B f5110cb5e1db9cddd47372dd8ba180892b9d9a5999643832227fb710089c08526eb077393350440ac30d2860a84dd821368323a528ce2056ca82a890399302ed SHA512 b93574fde8bb24ffc4dac6ddda20db3ec3c1834c1201f250f24805d31c7972edc2ffc157e7717327e7baac5c71a1d943a9d80bc7bec96be99c44cd2ab16e0e03
+EBUILD css-mode-0.11-r1.ebuild 653 BLAKE2B eab51857c0a3d22abdb30c0b8ff6c7689da3d3a5c8ce4d355e80d9c2c118c41dffb20785c537555c08267f14b71947ae0f5ec4ec4ae4db154c92fcf7c04a9cba SHA512 e9ac0302ff44318e44a3ea22df34d08371ca8920151ebec9681d4341a93bdbc1cb4327437bdfafa28b6eb4c97318cc934cdf189b60c592e2e8a0940154051519
+MISC metadata.xml 282 BLAKE2B 432e60a3b04def9f566fde3852011e006c0d578c72c42115734d1af5c128440fcee68134c8f891baad437e64a8d61fbbac49e70a35ed4f6f85641e888d3a2547 SHA512 1838e22e1f5b849b816a05d1b25bd81333c8cf67ceb996177e05ba7a555b8e0e307e62cb53e6f1217f4216823e2fecf050e85437678503d60e10c6b2d5303072
diff --git a/app-emacs/css-mode/css-mode-0.11-r1.ebuild b/app-emacs/css-mode/css-mode-0.11-r1.ebuild
new file mode 100644
index 000000000000..25c3581915e4
--- /dev/null
+++ b/app-emacs/css-mode/css-mode-0.11-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="A major mode for editing Cascading Style Sheets (CSS)"
+HOMEPAGE="http://www.garshol.priv.no/download/software/css-mode/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd"
+
+ELISP_PATCHES="${P}-no-compat-kbd.patch"
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ elisp_src_prepare
+ # Fix documentation
+ sed -i -e 's,HREF="/visuals/standard.css",HREF="standard.css",' doco.html
+}
+
+src_install() {
+ elisp_src_install
+ dohtml -A css doco.html standard.css
+}
diff --git a/app-emacs/css-mode/files/50css-mode-gentoo.el b/app-emacs/css-mode/files/50css-mode-gentoo.el
new file mode 100644
index 000000000000..8559be036db5
--- /dev/null
+++ b/app-emacs/css-mode/files/50css-mode-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(add-to-list 'auto-mode-alist '("\\.css\\'" . css-mode))
+(autoload 'css-mode "css-mode" "Mode for editing Cascading Style Sheets" t)
diff --git a/app-emacs/css-mode/files/css-mode-0.11-no-compat-kbd.patch b/app-emacs/css-mode/files/css-mode-0.11-no-compat-kbd.patch
new file mode 100644
index 000000000000..858cb238bf3c
--- /dev/null
+++ b/app-emacs/css-mode/files/css-mode-0.11-no-compat-kbd.patch
@@ -0,0 +1,24 @@
+Function "apropos-macrop" apparently no longer exists in Emacs 24.4.
+Simply remove the code using it, since it was only needed for backwards
+compatibility with Emacs 19 (the "kbd" macro appeared in Emacs 20.1).
+https://bugs.gentoo.org/532358
+
+--- css-mode-0.11-orig/css-mode.el
++++ css-mode-0.11/css-mode.el
+@@ -166,16 +166,6 @@
+ (define-key cssm-mode-map (read-kbd-macro "}") 'cssm-insert-right-brace-and-indent)
+ (define-key cssm-mode-map (read-kbd-macro "M-TAB") 'cssm-complete-property))
+
+-;;; Cross-version compatibility layer
+-
+-(when (not (or (apropos-macrop 'kbd)
+- (fboundp 'kbd)))
+- (defmacro kbd (keys)
+- "Convert KEYS to the internal Emacs key representation.
+-KEYS should be a string constant in the format used for
+-saving keyboard macros (see `insert-kbd-macro')."
+- (read-kbd-macro keys)))
+-
+ ;;; Auto-indentation support
+
+ ; internal
diff --git a/app-emacs/css-mode/metadata.xml b/app-emacs/css-mode/metadata.xml
new file mode 100644
index 000000000000..c918cdef9591
--- /dev/null
+++ b/app-emacs/css-mode/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<stabilize-allarches/>
+</pkgmetadata>