summaryrefslogtreecommitdiff
path: root/app-emacs/csharp-mode
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/csharp-mode
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/csharp-mode')
-rw-r--r--app-emacs/csharp-mode/Manifest7
-rw-r--r--app-emacs/csharp-mode/csharp-mode-0.7.0-r1.ebuild17
-rw-r--r--app-emacs/csharp-mode/csharp-mode-0.9.0.ebuild22
-rw-r--r--app-emacs/csharp-mode/files/50csharp-mode-gentoo.el3
-rw-r--r--app-emacs/csharp-mode/files/csharp-mode-0.7.0-emacs-24.4.patch14
-rw-r--r--app-emacs/csharp-mode/metadata.xml12
6 files changed, 75 insertions, 0 deletions
diff --git a/app-emacs/csharp-mode/Manifest b/app-emacs/csharp-mode/Manifest
new file mode 100644
index 000000000000..96d6c3f5ecb1
--- /dev/null
+++ b/app-emacs/csharp-mode/Manifest
@@ -0,0 +1,7 @@
+AUX 50csharp-mode-gentoo.el 171 BLAKE2B 6fa14f46d3ea4fba310ad4cb59a037ed5a4f123cc5b9243db715e08d3301bad7f24abb4cf1aa3ec178ad9c8e859d5225f49a3c8b87a302ac50c7a30eb56a34a1 SHA512 e0c9a5dc17c849ce9619a75ee46a0eb7415c0c04cb71cef326845ec9fdd79f57abf397590ba85bb0b901103ba0815cd6c873e9e12670cfb97d796b1f2cef087a
+AUX csharp-mode-0.7.0-emacs-24.4.patch 393 BLAKE2B 7eb176fa02441f9b5d42fd6ff68c3079d1fc047b6d84419725693b545402963a2fb14447be9843bc705026a06f65e104d582ed4bacec0d64b52ef06bef03f8b8 SHA512 b7b0a337a1b0d615f92b86ad27c09274ec63e87795629778b9091307fa6fa7bdaea2efe01cacadff2b47ccafd43ee0445f883f2f8a0b8f225fb727488c5752e3
+DIST csharp-mode-0.7.0.tar.bz2 6254 BLAKE2B 259d3ab7a6005428043398d44068dd8accc222c50581b7a760c740af96275a5877efc186d2582dccdc73442b9549bc8f5e1ff7f95e69effa7c90bbffc46fe461 SHA512 b6cbf2899853c29f44d19f37a01984a03c61f7bde144880f6f32e2a890d3b90a546ff69ad328d157e5494191aed37836373f49ddbafac49d8b9bd1cea3e22de9
+DIST csharp-mode-0.9.0.tar.gz 50453 BLAKE2B ed4b6ba56a9283687db332749510dcb63cc4bfc35687979cabae48b76d9e36598c88ff43f2920ca5272b56833d5cadd6602b47be21d88a7cd25d6ecb0e748493 SHA512 81661d98acdf03e01caf3b9388da8571e78402b8914755b223a38a723457a988201adcaf7b5b825c4e0126ad5e7628063f85dd4e60ee272102a5f1509f9446ef
+EBUILD csharp-mode-0.7.0-r1.ebuild 426 BLAKE2B 726cd422b98165f0eb2f4da36391a9360676919c152194521ca7f7df8e21eeaac6313bdee28c01a2faab3fde504ddf6e61653e475f1c1bac49630cb91c8130f2 SHA512 5d4eb1347e3f6d6c4d4c25a54c2c1f08bea882296cdb8af907a315cae6dbe03d76536ba3fb6d563218ba26ded56850bae1465506aeedd9b8b79bb41552d2f63d
+EBUILD csharp-mode-0.9.0.ebuild 543 BLAKE2B c5ae548cd6b28a0e081a487f65f1e5942c9cb87e4a7bf13634c83d861009a80750907c0889ac7a8f90c8ad1f1ae7e9d307fd3a4e8220c8bba936e68572feb340 SHA512 21fd7b3183af0ec291b2406384050b7c07d07bcde4e2d0e2a6129357f1d5352000d2a0278a3b258ce75d8db4508498bf4991b99d56ae08b99872cdc202cd7ca4
+MISC metadata.xml 381 BLAKE2B 24f06d9590b0aefd84fe951957813fdcbd1821fa8ee7878a6f34e0aacd51c603a93ca0e91da14bbe58ab6239c8c38e59c0a17d8162ca478ea5ad832536b22ffa SHA512 4c03424612532509c84b60d2058272ca830b6532dfcc6a179324236b30f9edd2e7924cebdf1803f4fb7d7adbe94ff59c065d605534c375c2bf4c0919356303e0
diff --git a/app-emacs/csharp-mode/csharp-mode-0.7.0-r1.ebuild b/app-emacs/csharp-mode/csharp-mode-0.7.0-r1.ebuild
new file mode 100644
index 000000000000..6346e99d8da1
--- /dev/null
+++ b/app-emacs/csharp-mode/csharp-mode-0.7.0-r1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="A derived Emacs mode implementing most of the C# rules"
+HOMEPAGE="http://mfgames.com/csharp-mode/start"
+SRC_URI="http://mfgames.com/releases/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+
+ELISP_PATCHES="${P}-emacs-24.4.patch"
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/csharp-mode/csharp-mode-0.9.0.ebuild b/app-emacs/csharp-mode/csharp-mode-0.9.0.ebuild
new file mode 100644
index 000000000000..e73197cf3cc8
--- /dev/null
+++ b/app-emacs/csharp-mode/csharp-mode-0.9.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit elisp
+
+DESCRIPTION="A derived Emacs mode implementing most of the C# rules"
+HOMEPAGE="https://github.com/josteink/csharp-mode"
+SRC_URI="https://github.com/josteink/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp-install ${PN} csharp-mode.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc README.org
+}
diff --git a/app-emacs/csharp-mode/files/50csharp-mode-gentoo.el b/app-emacs/csharp-mode/files/50csharp-mode-gentoo.el
new file mode 100644
index 000000000000..ea2056b6a29d
--- /dev/null
+++ b/app-emacs/csharp-mode/files/50csharp-mode-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'csharp-mode "csharp-mode" "Major mode for editing C# code." t)
+(add-to-list 'auto-mode-alist '("\\.cs\\'" . csharp-mode))
diff --git a/app-emacs/csharp-mode/files/csharp-mode-0.7.0-emacs-24.4.patch b/app-emacs/csharp-mode/files/csharp-mode-0.7.0-emacs-24.4.patch
new file mode 100644
index 000000000000..c3f73201cbae
--- /dev/null
+++ b/app-emacs/csharp-mode/files/csharp-mode-0.7.0-emacs-24.4.patch
@@ -0,0 +1,14 @@
+https://bugs.gentoo.org/528374
+
+--- a/csharp-mode.el
++++ b/csharp-mode.el
+@@ -125,6 +125,9 @@
+ (stringp byte-compile-dest-file))
+ (cons (file-name-directory byte-compile-dest-file) load-path)
+ load-path)))
++ (and (= emacs-major-version 24)
++ (>= emacs-minor-version 4)
++ (require 'cl))
+ (load "cc-mode" nil t)
+ (load "cc-fonts" nil t)
+ (load "cc-langs" nil t)))
diff --git a/app-emacs/csharp-mode/metadata.xml b/app-emacs/csharp-mode/metadata.xml
new file mode 100644
index 000000000000..a4bcf30f6751
--- /dev/null
+++ b/app-emacs/csharp-mode/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">josteink/csharp-mode</remote-id>
+ </upstream>
+</pkgmetadata>