summaryrefslogtreecommitdiff
path: root/app-emacs/counsel
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /app-emacs/counsel
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'app-emacs/counsel')
-rw-r--r--app-emacs/counsel/Manifest4
-rw-r--r--app-emacs/counsel/counsel-0.13.4.ebuild36
-rw-r--r--app-emacs/counsel/files/50counsel-gentoo.el3
-rw-r--r--app-emacs/counsel/metadata.xml15
4 files changed, 58 insertions, 0 deletions
diff --git a/app-emacs/counsel/Manifest b/app-emacs/counsel/Manifest
new file mode 100644
index 000000000000..53be3b6007ea
--- /dev/null
+++ b/app-emacs/counsel/Manifest
@@ -0,0 +1,4 @@
+AUX 50counsel-gentoo.el 110 BLAKE2B 223dc0b9991156d3494e9e954624ec060515231f5ca979345864dad802ccaaaff02eb43e13a7af5eed581e4189005493bbda3d849ef8c7b9b877993f9e096a78 SHA512 be21f737978b64065af31df15320ddb06f255a258d05d75227f4762a35a6eb86b0012561a40f7f72f154af58c0ce240c50958a8020d3a0dc5054c6b5834b80c8
+DIST swiper-0.13.4.tar.gz 245190 BLAKE2B c4da021b92fcedfec39cc60f670c97e4a421b8d4aef8183f50c4872bed835db79884cff113f58cf21dfa7ce33158218aa0cf25d72fc0081dc1c24a3b4376c60e SHA512 bf096a13f675f87af6ea68c974455896b64921ca4d7880c9ccc444aa3cea7c7e04c61be5deb2fd57d0568ff4d86f96ffcf94494b55d84d7a9f647f49b69aec9a
+EBUILD counsel-0.13.4.ebuild 787 BLAKE2B fcee8cf90e3384599d3a90aab8ec69cffb5e638a16b7853fc095b1900ef7c419bdc1eeb6cab1e96ae514787a9ad2d426e7ad96ae0c5c0ec4a14697a7b5be1468 SHA512 bd748ff39182ee9e9c6ad954d9c1a3a0db9e445d27766d03feaf36f48abe29e4f4e9806fab143d399fe73543912ac8a997488e338f274ecf2fd6be707f20c81b
+MISC metadata.xml 571 BLAKE2B 26ca5a5dfb1bc67ad37086ddc2c2e5976d1b4c763789a27ee83fb08c4a106a21c33b4c9632a3f2858a6b6249c8c49da3e2eafa7efc5267b655c0c9b2066598e2 SHA512 1879881be5eaeb2a6bac023fd06476a2ccbd25909f7c2f722b4af3680db44b4d3a959e1ac864e86580813a0bc68a2120d936f1c2efd67a6738ee8d83a5adb6f4
diff --git a/app-emacs/counsel/counsel-0.13.4.ebuild b/app-emacs/counsel/counsel-0.13.4.ebuild
new file mode 100644
index 000000000000..fe5b3a0a93e8
--- /dev/null
+++ b/app-emacs/counsel/counsel-0.13.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.5
+
+inherit elisp
+
+DESCRIPTION="Versions of common Emacs commands customized to make the best use of ivy"
+HOMEPAGE="https://github.com/abo-abo/swiper/"
+SRC_URI="https://github.com/abo-abo/swiper/archive/${PV}.tar.gz
+ -> swiper-${PV}.tar.gz"
+S="${WORKDIR}"/swiper-${PV}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test" # Ivy, Swiper and Counsel tests are performed in app-emacs/ivy
+
+RDEPEND="
+ >=app-emacs/ivy-${PV}
+ >=app-emacs/swiper-${PV}
+"
+BDEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile ${PN}.el
+}
+
+src_install() {
+ elisp-install ${PN} ${PN}.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}
diff --git a/app-emacs/counsel/files/50counsel-gentoo.el b/app-emacs/counsel/files/50counsel-gentoo.el
new file mode 100644
index 000000000000..1da49244a09f
--- /dev/null
+++ b/app-emacs/counsel/files/50counsel-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'counsel-mode "counsel"
+ "Toggle Counsel mode on or off." t)
diff --git a/app-emacs/counsel/metadata.xml b/app-emacs/counsel/metadata.xml
new file mode 100644
index 000000000000..37581bba4db7
--- /dev/null
+++ b/app-emacs/counsel/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <changelog>https://raw.githubusercontent.com/abo-abo/swiper/master/doc/Changelog.org</changelog>
+ <bugs-to>https://github.com/abo-abo/swiper/issues/</bugs-to>
+ <remote-id type="github">abo-abo/swiper</remote-id>
+ <doc lang="en">https://oremacs.com/swiper/</doc>
+ </upstream>
+</pkgmetadata>