summaryrefslogtreecommitdiff
path: root/app-emacs/compat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-21 01:00:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-21 01:00:11 +0000
commitee93fbc2bb111cf895ae00cc1877c68f0eafaf2a (patch)
treef4cdf4b4814dfa35e701a066e3bc3c50f6afd7cf /app-emacs/compat
parentdbd6eaafcce6a59fa9b3323124c38fa17aa88e26 (diff)
gentoo auto-resync : 21:03:2024 - 01:00:11
Diffstat (limited to 'app-emacs/compat')
-rw-r--r--app-emacs/compat/Manifest2
-rw-r--r--app-emacs/compat/compat-29.1.4.5.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/app-emacs/compat/Manifest b/app-emacs/compat/Manifest
index 4771ad32fa88..c73a30134fc0 100644
--- a/app-emacs/compat/Manifest
+++ b/app-emacs/compat/Manifest
@@ -1,3 +1,5 @@
DIST compat-29.1.4.4.tar.gz 129900 BLAKE2B 460aa851cbb341290cef250e70bf501a30cd174cd135ea429f7a3aa71597804c802c4225424072b49b4b7726b6e31c0ba36e6c0a4e154a2048075697656c2d31 SHA512 b6ecfde494dc5b1e96ed6d6cb450b3b647761c30128859a03d0d054e633227dd0714dd4ee8d39cf9eb4d702e9f08feaba41c39d91e6871724c458173e16d9e89
+DIST compat-29.1.4.5.tar.gz 130079 BLAKE2B 84b3293bec535d7f653d0aa3fac069e230c030ccf809d0a606b068d9d663e078274d15d57ca56fc180208de69ae4fee554fbc3d5e8c78394789ee756665e980f SHA512 9682224a1ab5238c7f584121652c55df257fd050279e8356632b2aafef4045dc89b2dfd20cf8f5030dda1d96db40c993cdc3ac0efd0263d23beee8310def0849
EBUILD compat-29.1.4.4.ebuild 985 BLAKE2B 32c6b4e2eb38c18cf32c4b379ec61c499e3974d72aeafece632b86966daa4fffd1af14f95997224ff6800b68bdab73be4a88607c576380d308f533478dbdaad7 SHA512 1b9d7ddd9e4ceac02c6d16c1d140a26cb4a63c5e24e2923873e2bb5cffefcaa3434c9180d15f463f391e92a0e75c7544845bd82dfc3c555809796aca5987be77
+EBUILD compat-29.1.4.5.ebuild 1117 BLAKE2B ba1e4a97514f042981d9807f41d8b1f8bd6711a5683cd034f76c7f1002547093bc7513640cd06bed6bf0431f2b7bc161366f6dde9d4fb1b61ea4d6d19fabc448 SHA512 19cde0352962224fee026244aea48d26ea36c11466bc0edf962ead5f3cfe40e7b91f0a620e0fb812363889be0fd5ce8d58b9b90dd2d71229bfe8507938a33f0e
MISC metadata.xml 510 BLAKE2B 6d189301e592c47ca50f1e1a54b4b8ec6fe8f8883761137562eb1c0c2e898bf9d09c520d4ac4d2edcc851e29ad6896950d412aefb80320913405ee3b0c2b6b9d SHA512 85329976678ef5733a30ffa89fb41a4b8ccbeb8b977b9525c0dbd1b099c5afe12fa40b3c71b403893efdb7a31790ae9a46d01224f949f85ceecc94dcb5ef4fbb
diff --git a/app-emacs/compat/compat-29.1.4.5.ebuild b/app-emacs/compat/compat-29.1.4.5.ebuild
new file mode 100644
index 000000000000..0de9f6e50e90
--- /dev/null
+++ b/app-emacs/compat/compat-29.1.4.5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Compatibility libraries for Emacs"
+HOMEPAGE="https://github.com/emacs-compat/compat/
+ https://git.sr.ht/~pkal/compat/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/emacs-compat/${PN}.git"
+else
+ SRC_URI="https://github.com/emacs-compat/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+BDEPEND="
+ sys-apps/texinfo
+"
+
+ELISP_TEXINFO="${PN}.texi"
+
+src_compile() {
+ emake compile "${PN}.info"
+}
+
+src_test() {
+ local has_json="$("${EMACS}" ${EMACSFLAGS} --eval "(princ (fboundp 'json-parse-string))")"
+ if [[ "${has_json}" != t ]] ; then
+ local line
+ while read line ; do
+ ewarn "${line}"
+ done <<-EOF
+ Your current Emacs version does not support native JSON parsing,
+ which is required for running tests of ${CATEGORY}/${PN}.
+ Emerge >=app-editors/emacs-27 with USE="json" and use "eselect emacs"
+ to select that version.
+ EOF
+ else
+ emake test
+ fi
+}