summaryrefslogtreecommitdiff
path: root/app-emacs/compat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-13 16:26:20 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-13 16:26:20 +0000
commit554b3dc27cef6db59f8a612c1e2e3c653f70e392 (patch)
tree2f238e8a8225b27e61bb11ffcdef9acf4920b246 /app-emacs/compat
parentaafdd1dcd9a66da0b1bcdfadbca62add48751897 (diff)
gentoo auto-resync : 13:11:2023 - 16:26:20
Diffstat (limited to 'app-emacs/compat')
-rw-r--r--app-emacs/compat/Manifest2
-rw-r--r--app-emacs/compat/compat-29.1.4.4.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/app-emacs/compat/Manifest b/app-emacs/compat/Manifest
index 71d4bc1796fb..d728ebc6278e 100644
--- a/app-emacs/compat/Manifest
+++ b/app-emacs/compat/Manifest
@@ -1,3 +1,5 @@
DIST compat-29.1.4.2.tar.gz 128695 BLAKE2B e02d431c307b08d07888362a20fb597cfcb275b645522229a116169eff7f875ff3dbf23bb1344249fa8ac2b25cf7ade20752ce9e97188a49d851ba5ae1dfa8cb SHA512 a31fb1564b1bad20f0f7a0a400e9834e88c2e21b8c022ce4696e27cddc351b7c882765235accde0b3f4a417680699bc5bb69f7485436c8e64d799e8a5ac9e390
+DIST compat-29.1.4.4.tar.gz 129900 BLAKE2B 460aa851cbb341290cef250e70bf501a30cd174cd135ea429f7a3aa71597804c802c4225424072b49b4b7726b6e31c0ba36e6c0a4e154a2048075697656c2d31 SHA512 b6ecfde494dc5b1e96ed6d6cb450b3b647761c30128859a03d0d054e633227dd0714dd4ee8d39cf9eb4d702e9f08feaba41c39d91e6871724c458173e16d9e89
EBUILD compat-29.1.4.2.ebuild 986 BLAKE2B 33e8a0a7e846187a687ce936641e7df6543a5b0918cfb4dadacae5d1467d19ce516920ccdfd35315dd22767b8bcadf056859025c16aaaee96ce13535a142a719 SHA512 a294148912bb8cb6cbaa3641d77a75a48a7e5276d4dd663d9d8d3fb43055381ea593c13d547dece2534363024cb3c4452898e44115852ddfacbd2f6789fc4702
+EBUILD compat-29.1.4.4.ebuild 989 BLAKE2B bd66b64ee66e764fb388ee357c756470ee73d4c7d8623e81108eb1c0fbb5f6c294910c91b96c77452435dd2d96a637745404ed3d3e4d55257a04f32700e1a0e6 SHA512 53a984c58c7d5b426b35ffb0a9cf659da022385ba3ba19a09207eeead473b9e6ee545143c45b63aed355622bb1080f159f6ce9beb7a8b06d03cf1dce7bab25a1
MISC metadata.xml 510 BLAKE2B 6d189301e592c47ca50f1e1a54b4b8ec6fe8f8883761137562eb1c0c2e898bf9d09c520d4ac4d2edcc851e29ad6896950d412aefb80320913405ee3b0c2b6b9d SHA512 85329976678ef5733a30ffa89fb41a4b8ccbeb8b977b9525c0dbd1b099c5afe12fa40b3c71b403893efdb7a31790ae9a46d01224f949f85ceecc94dcb5ef4fbb
diff --git a/app-emacs/compat/compat-29.1.4.4.ebuild b/app-emacs/compat/compat-29.1.4.4.ebuild
new file mode 100644
index 000000000000..4c6643fbd200
--- /dev/null
+++ b/app-emacs/compat/compat-29.1.4.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Compatibility libraries for Emacs"
+HOMEPAGE="https://github.com/emacs-compat/compat/
+ https://git.sr.ht/~pkal/compat/"
+SRC_URI="https://github.com/emacs-compat/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+BDEPEND="sys-apps/texinfo"
+
+ELISP_TEXINFO="${PN}.texi"
+
+src_compile() {
+ emake compile ${PN}.info
+}
+
+src_test() {
+ local has_json="$("${EMACS}" ${EMACSFLAGS} --eval "(princ (fboundp 'json-parse-string))")"
+ if [[ "${has_json}" != t ]] ; then
+ local line
+ while read line ; do
+ ewarn "${line}"
+ done <<-EOF
+ Your current Emacs version does not support native JSON parsing,
+ which is required for running tests of ${CATEGORY}/${PN}.
+ Emerge >=app-editors/emacs-27 with USE="json" and use "eselect emacs"
+ to select that version.
+ EOF
+ else
+ emake test
+ fi
+}