summaryrefslogtreecommitdiff
path: root/app-emacs/compat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /app-emacs/compat
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'app-emacs/compat')
-rw-r--r--app-emacs/compat/Manifest5
-rw-r--r--app-emacs/compat/compat-28.1.1.1-r1.ebuild24
-rw-r--r--app-emacs/compat/compat-28.1.1.3.ebuild43
-rw-r--r--app-emacs/compat/metadata.xml9
4 files changed, 81 insertions, 0 deletions
diff --git a/app-emacs/compat/Manifest b/app-emacs/compat/Manifest
new file mode 100644
index 000000000000..c070f92af833
--- /dev/null
+++ b/app-emacs/compat/Manifest
@@ -0,0 +1,5 @@
+DIST compat-28.1.1.1.tar.gz 71771 BLAKE2B 48feaada7e32f07b425048f8b993b2936450dbed8ba20e0f6319d4b098bcc8007323416bf300221a00fb13ff152698c2beaeea6e743d46b1d32b9c0a016a895c SHA512 e733836934671cb373f70a92a20084622e160f2731c5e5c6ce9df348820261db399da0e78d6b95293d9b6992469e96298e9fe83e331a4caaa377fc6ce61f7040
+DIST compat-28.1.1.3.tar.gz 72597 BLAKE2B 82186713370fed7f97eb057cb330d77c1d758224ad37c0b7fbbd21221b0d2ffd68be805483f3e9577866f02079c83a5686918c87a1ed7c67c9acdd64aa3a560b SHA512 d65e5ce666607cd6d26cf771d6878caeb6641aff0fc924ec901955c1a03b6fe42e3527220448fa92a8d6c3f5bd65e6f915ed4ada1be01a29d7919f916826e48f
+EBUILD compat-28.1.1.1-r1.ebuild 480 BLAKE2B e0577d26c6c6724d8a7b631ef2856903ac2459657152fed6855eb769bb41834c948227a8a9ac8f0db2ce8911731817683646aae44ba9512fbd7ec520a0f0937b SHA512 718c6a0290929acf3487b6b824d59609fc3f7f4c9b5bd6d25c99f957a2de0412a73d47d86f483e09fae7ccb5486b3e0a287b999ee8fabceb892042ddab9c336b
+EBUILD compat-28.1.1.3.ebuild 996 BLAKE2B 659a6059db70cab8bd9e29255fe7b8ed207dd31e9e1d4858374dc0152f61bb318732d2bd4446dfa7ed25b126ef0b02b3e32c3c70438b86ca06ba8b88d88d0c06 SHA512 a7e0c0d0e24438e548d46cfb7f34f76772afe8dd41dbf4997db5d0026ba5ffd27cf097cd0e7901e80d730860e61afb55f14b17264cc5de41ab04a90bc8643dfa
+MISC metadata.xml 293 BLAKE2B 07085bc46a57a9592b46c4442f0ca6995a5d1857ce51bb85384d389114b3385b71f3977cfed5d7180fd574cc4211824a327c98f5f690a9d959320f9d960af88a SHA512 c3af1c6afe14f621f3d1689ea4fda1b7215c3dd9e3c578e45edda24cc4eae1ec11dc29d42d87c762f3c6decf9f9bdf356b109736d47951c9eaefcca8d9111d56
diff --git a/app-emacs/compat/compat-28.1.1.1-r1.ebuild b/app-emacs/compat/compat-28.1.1.1-r1.ebuild
new file mode 100644
index 000000000000..8964a682162d
--- /dev/null
+++ b/app-emacs/compat/compat-28.1.1.1-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="Compatibility libraries for Emacs"
+HOMEPAGE="https://git.sr.ht/~pkal/compat"
+SRC_URI="https://git.sr.ht/~pkal/compat/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="sys-apps/texinfo"
+
+ELISP_TEXINFO="compat.texi"
+
+src_prepare() {
+ default
+ rm Makefile compat-tests.el || die
+}
diff --git a/app-emacs/compat/compat-28.1.1.3.ebuild b/app-emacs/compat/compat-28.1.1.3.ebuild
new file mode 100644
index 000000000000..8a61c3a356a2
--- /dev/null
+++ b/app-emacs/compat/compat-28.1.1.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=2c3233c0e09ef34176787b6e3da4319751ad91e7
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="Compatibility libraries for Emacs"
+HOMEPAGE="https://git.sr.ht/~pkal/compat/"
+SRC_URI="https://git.sr.ht/~pkal/${PN}/archive/${H}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${H}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="sys-apps/texinfo"
+
+ELISP_TEXINFO="${PN}.texi"
+
+src_compile() {
+ emake compile ${PN}.info
+}
+
+src_test() {
+ local has_json="$("${EMACS}" ${EMACSFLAGS} --eval "(princ (fboundp 'json-parse-string))")"
+ if [[ "${has_json}" != t ]] ; then
+ local line
+ while read line ; do
+ ewarn "${line}"
+ done <<-EOF
+ Your current Emacs version does not support native JSON parsing,
+ which is required for running tests of ${CATEGORY}/${PN}.
+ Emerge >=app-editors/emacs-27 with USE="json" and use "eselect emacs"
+ to select that version.
+ EOF
+ else
+ emake test
+ fi
+}
diff --git a/app-emacs/compat/metadata.xml b/app-emacs/compat/metadata.xml
new file mode 100644
index 000000000000..3264e3c57176
--- /dev/null
+++ b/app-emacs/compat/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <stabilize-allarches/>
+</pkgmetadata>