summaryrefslogtreecommitdiff
path: root/app-emacs/company-quickhelp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /app-emacs/company-quickhelp
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'app-emacs/company-quickhelp')
-rw-r--r--app-emacs/company-quickhelp/Manifest4
-rw-r--r--app-emacs/company-quickhelp/company-quickhelp-2.3.0.ebuild26
-rw-r--r--app-emacs/company-quickhelp/files/50company-quickhelp-gentoo.el5
-rw-r--r--app-emacs/company-quickhelp/metadata.xml14
4 files changed, 49 insertions, 0 deletions
diff --git a/app-emacs/company-quickhelp/Manifest b/app-emacs/company-quickhelp/Manifest
new file mode 100644
index 000000000000..fd3be45248e6
--- /dev/null
+++ b/app-emacs/company-quickhelp/Manifest
@@ -0,0 +1,4 @@
+AUX 50company-quickhelp-gentoo.el 278 BLAKE2B a15fdeb2362a2b07e6029603b0c7e62615dea9bcbd3645f28183317334fbe143b21cf35736dfe83cf6e21df51ac86d70c22ef092cbbc66cea954da2418fe5b6c SHA512 edf783572be6f115878afe93ab347043287830963c0c598c21f52c5ec8192a8a5e2866a4697d311c740baca32475d21b3b7224e25b5fb9fa0cf7304c7a5ded24
+DIST company-quickhelp-2.3.0.tar.gz 64663 BLAKE2B 2ca72d4ecea574790bd796217da32c1dbaf0d637deb52ed20978d62bc4eaea07efda5f4e7163212943b19a1de74a6df06e56a5b835f00a23b0c74dd121451018 SHA512 c1df2c58ac6a089c1a1efe44251112a2c1e8591e168c1d94a2107eeaec02cfbe6ec6232e357eb6f94a799b03fb99da087f69ed6d4e1a315fc9ad268e08d785bd
+EBUILD company-quickhelp-2.3.0.ebuild 574 BLAKE2B 1dae12d2c6a8efc14abbec26c32d549e4c4e7f0c58e96ca039cd78354e4a7254a585f33cba3306bf90807158339c7ef94647da4b8caaf9318165ee7550bcf5c8 SHA512 c6ca488aa4c4bb8f904e08fe5f8a227cee542cece7f5fec269c5d522d581ada51ff709f5b23649b0b8c14f22339929476580ae51df927fbce7f9ab016295afe7
+MISC metadata.xml 561 BLAKE2B c0b55818fb46a3fe36264e160079683d3ecc22315d1bf2adf985cf581ef87814a94f9338ab550ebd130cf8101416698012a149cedad373e02b0df094ff978068 SHA512 886c9bc9df3d708cc63553ebac394a3b847ec956ad6243653f15a8596420c21fc382891103360ee67467fdca38208db5715780d2802e5058abb7f058bbb874bd
diff --git a/app-emacs/company-quickhelp/company-quickhelp-2.3.0.ebuild b/app-emacs/company-quickhelp/company-quickhelp-2.3.0.ebuild
new file mode 100644
index 000000000000..2e874826d7ea
--- /dev/null
+++ b/app-emacs/company-quickhelp/company-quickhelp-2.3.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.4
+
+inherit elisp
+
+DESCRIPTION="Company documentation popups for completion candidates"
+HOMEPAGE="https://github.com/company-mode/company-quickhelp/"
+SRC_URI="https://github.com/company-mode/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-emacs/company-mode
+ app-emacs/pos-tip
+"
+BDEPEND="${RDEPEND}"
+
+DOCS=( CHANGELOG.md README.md company-quickhelp.png )
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/company-quickhelp/files/50company-quickhelp-gentoo.el b/app-emacs/company-quickhelp/files/50company-quickhelp-gentoo.el
new file mode 100644
index 000000000000..c974134302a0
--- /dev/null
+++ b/app-emacs/company-quickhelp/files/50company-quickhelp-gentoo.el
@@ -0,0 +1,5 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'company-quickhelp-local-mode "company-quickhelp"
+ "Provides documentation popups for `company-mode' using `pos-tip'." t)
+(autoload 'company-quickhelp-mode "company-quickhelp"
+ "Toggle Company-Quickhelp mode in all buffers." t)
diff --git a/app-emacs/company-quickhelp/metadata.xml b/app-emacs/company-quickhelp/metadata.xml
new file mode 100644
index 000000000000..1d03dc85b5e9
--- /dev/null
+++ b/app-emacs/company-quickhelp/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <changelog>https://raw.githubusercontent.com/company-mode/company-quickhelp/master/CHANGELOG.md</changelog>
+ <bugs-to>https://github.com/company-mode/company-quickhelp/issues/</bugs-to>
+ <remote-id type="github">company-mode/company-quickhelp</remote-id>
+ </upstream>
+</pkgmetadata>