summaryrefslogtreecommitdiff
path: root/app-emacs/company-mode
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/company-mode
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/company-mode')
-rw-r--r--app-emacs/company-mode/Manifest6
-rw-r--r--app-emacs/company-mode/company-mode-0.6.14.ebuild38
-rw-r--r--app-emacs/company-mode/company-mode-0.7.ebuild38
-rw-r--r--app-emacs/company-mode/files/50company-mode-gentoo.el2
-rw-r--r--app-emacs/company-mode/metadata.xml16
5 files changed, 100 insertions, 0 deletions
diff --git a/app-emacs/company-mode/Manifest b/app-emacs/company-mode/Manifest
new file mode 100644
index 000000000000..d947103e5326
--- /dev/null
+++ b/app-emacs/company-mode/Manifest
@@ -0,0 +1,6 @@
+AUX 50company-mode-gentoo.el 79 BLAKE2B c9b00690d98498b53fa329adf5279ee341c03c73cfd12b70e1474189cc9c9de07bca276ef9fad35f346825c4daab0212e8965069a2a0706cec690350df24fbf7 SHA512 8c3c1d4a50bfd4729f8a06f33bf9d754b5865814cf15eee1f3c84c6726734f8ff26c21547f1453f7417a0b9d008fe7804104ee6e30f13c54625d2b4b6faa7e99
+DIST company-mode-0.6.14.tar.gz 51776 BLAKE2B 2e5a651b13d959d964847a307814106b5db95092d764e1d6889c94412d0aa1995d2a34182786493afc426b6c6ae4f229498f58b7556d1dc264c71ec57dcb8b6f SHA512 7b8c0b70dc9c010214e8671fd7393faa9d1dd0839f41d532eb93eda91c77b4c93f2145ad2d688011976bfbb45282f35b937f195499f29cda79147ec2815e94d9
+DIST company-mode-0.7.tar.gz 54670 BLAKE2B 4b56182d6d37e1c0dd827babf3e5c17c49a2e86959c99aa4dc6832f5003a9c1baf0019c610cf9bd46e6db5f1d68e72381ae22f71afb636873552440c48b218c0 SHA512 375c8541a0c5b34fba37ea136c8549e6ec916c238bee8115f036d88f273d6bcb0c0f436a6193d3b4be6528945d8f85c605de8d340e903a9764f5ace664f8cf61
+EBUILD company-mode-0.6.14.ebuild 1000 BLAKE2B 51b71a2a2d7988421156b6b415b935bfe153fd076d83904f6762cd02aed3c7b1318b228b0c960160cf4c640f37d51c5334877f24e4d5ef0fe49f2d36dd355416 SHA512 62fced23f0b40ab4d4b93c2102202c00e7dc85d4541cdbbea9bd78d65d71b07d301700fa944d2729d0e59f2537e10fece36509daf0666179158acb0293c10804
+EBUILD company-mode-0.7.ebuild 1000 BLAKE2B 51b71a2a2d7988421156b6b415b935bfe153fd076d83904f6762cd02aed3c7b1318b228b0c960160cf4c640f37d51c5334877f24e4d5ef0fe49f2d36dd355416 SHA512 62fced23f0b40ab4d4b93c2102202c00e7dc85d4541cdbbea9bd78d65d71b07d301700fa944d2729d0e59f2537e10fece36509daf0666179158acb0293c10804
+MISC metadata.xml 469 BLAKE2B 08b950e54425d9c6fd0f2a58eea8aced42d9d7c0f657e34e950b3fd618af534900970356be21750adf7886e7fba34a041f5445e60f247dab4c763dc59d0c8f86 SHA512 e5da67fd1ae2089c6ba90c7bdc223c11e3e6e4eaf548dee77198a5ecadcd288aa2f91dccbda9bcfcbc347909d77f5a1acd77ce22b45efaab8f9c62729407713b
diff --git a/app-emacs/company-mode/company-mode-0.6.14.ebuild b/app-emacs/company-mode/company-mode-0.6.14.ebuild
new file mode 100644
index 000000000000..7b2e2231f50f
--- /dev/null
+++ b/app-emacs/company-mode/company-mode-0.6.14.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="In-buffer completion front-end"
+HOMEPAGE="https://company-mode.github.com/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ropemacs"
+RESTRICT="test"
+
+# Note: company-mode supports many backends, and we refrain from including
+# them all in RDEPEND. Only depend on things that are needed at build time.
+DEPEND="ropemacs? ( app-emacs/pymacs )"
+RDEPEND="${DEPEND}
+ ropemacs? ( dev-python/ropemacs )"
+
+SITEFILE="50${PN}-gentoo.el"
+DOCS="README.md NEWS.md"
+
+src_prepare() {
+ # Disable backends that require extra dependencies, unless they are
+ # selected by the respective USE flag
+
+ elog "Removing pysmell backend"
+ rm company-pysmell.el || die
+
+ if ! use ropemacs; then
+ elog "Removing ropemacs backend, as requested by USE=-ropemacs"
+ rm company-ropemacs.el || die
+ fi
+}
diff --git a/app-emacs/company-mode/company-mode-0.7.ebuild b/app-emacs/company-mode/company-mode-0.7.ebuild
new file mode 100644
index 000000000000..7b2e2231f50f
--- /dev/null
+++ b/app-emacs/company-mode/company-mode-0.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="In-buffer completion front-end"
+HOMEPAGE="https://company-mode.github.com/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ropemacs"
+RESTRICT="test"
+
+# Note: company-mode supports many backends, and we refrain from including
+# them all in RDEPEND. Only depend on things that are needed at build time.
+DEPEND="ropemacs? ( app-emacs/pymacs )"
+RDEPEND="${DEPEND}
+ ropemacs? ( dev-python/ropemacs )"
+
+SITEFILE="50${PN}-gentoo.el"
+DOCS="README.md NEWS.md"
+
+src_prepare() {
+ # Disable backends that require extra dependencies, unless they are
+ # selected by the respective USE flag
+
+ elog "Removing pysmell backend"
+ rm company-pysmell.el || die
+
+ if ! use ropemacs; then
+ elog "Removing ropemacs backend, as requested by USE=-ropemacs"
+ rm company-ropemacs.el || die
+ fi
+}
diff --git a/app-emacs/company-mode/files/50company-mode-gentoo.el b/app-emacs/company-mode/files/50company-mode-gentoo.el
new file mode 100644
index 000000000000..cd85457fe91e
--- /dev/null
+++ b/app-emacs/company-mode/files/50company-mode-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'company-mode "company" nil t)
diff --git a/app-emacs/company-mode/metadata.xml b/app-emacs/company-mode/metadata.xml
new file mode 100644
index 000000000000..166418c6cfac
--- /dev/null
+++ b/app-emacs/company-mode/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<stabilize-allarches/>
+<use>
+ <flag name="ropemacs">Install backend for
+ <pkg>dev-python/ropemacs</pkg></flag>
+</use>
+<upstream>
+ <remote-id type="github">company-mode/company-mode</remote-id>
+</upstream>
+</pkgmetadata>