summaryrefslogtreecommitdiff
path: root/app-emacs/color-theme
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/color-theme
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/color-theme')
-rw-r--r--app-emacs/color-theme/Manifest5
-rw-r--r--app-emacs/color-theme/color-theme-6.6.0-r1.ebuild33
-rw-r--r--app-emacs/color-theme/files/50color-theme-gentoo.el109
-rw-r--r--app-emacs/color-theme/files/color-theme-6.6.0-replace-in-string.patch30
-rw-r--r--app-emacs/color-theme/metadata.xml9
5 files changed, 186 insertions, 0 deletions
diff --git a/app-emacs/color-theme/Manifest b/app-emacs/color-theme/Manifest
new file mode 100644
index 000000000000..567e893b25e1
--- /dev/null
+++ b/app-emacs/color-theme/Manifest
@@ -0,0 +1,5 @@
+AUX 50color-theme-gentoo.el 4375 BLAKE2B 0a17afad7fd9290dde1992e813711d9bed4b36ec9f2a3d41ab5775dc55e125f7f3cb9b74d1230f1202ee3083b68c29782c3cba955444c04a42b31f3f66b39b89 SHA512 318354c71e75b343eaf90b3be2f94c0b6b93c776afe3289a5c18a5b837478291ce6a8d554a6357c13f14cbe568bf10c5d7ed9690ee8c382ec3cc4aeeac70412a
+AUX color-theme-6.6.0-replace-in-string.patch 1173 BLAKE2B 4e27361d5212afd78e6b94b7b20c3e2512715a280a98fcecaef3b3202ca376b5749c37c3dfb3f1d27673a3421d12de6fc0d7b6c2ee07f1720a32d737558f1e2b SHA512 bdf1ebb03c1fc70bf78adf4886b005780d1c540ac59730e644111f5a3a925b6b05d2e910520b67ec768815f0fecca3a5e617472ca9e415900daf890ca77bc6d1
+DIST color-theme-6.6.0.tar.gz 124858 BLAKE2B b98e97b6c02fa9bac30c5eaefaa1724f751e1176b99fcf10e5d44507ada0c82e2cc2df8352c6d605d097a0c3697b071c2cf9bfe32b4a8cbf67cf00dd5c1545e4 SHA512 4faa22900f6ad4a1dd57452470e23b57827d3f02bf2b9e3c4eed6f5693432d6478aa5008e67f219a95412a63fe52dbcad15b0ac7a3b4d39f1d28ceda75e5e76c
+EBUILD color-theme-6.6.0-r1.ebuild 980 BLAKE2B 77f58c6866305b87ae21e2ddead5ecf7968ef2012d961ff80a56ce4ceae65c4fb6434a91594b40299d08e7fe82b5084866b9099aa5b8b96670ff94aabb9c63be SHA512 58fb0e52f726753ebf743a464ce12bbadf8a81c32bb50247b1797fd9d60b3e5a4b64b71b8c9be6b6ec87ba0540ac7edce161445229b59386a71ccd41c59b3d13
+MISC metadata.xml 282 BLAKE2B 432e60a3b04def9f566fde3852011e006c0d578c72c42115734d1af5c128440fcee68134c8f891baad437e64a8d61fbbac49e70a35ed4f6f85641e888d3a2547 SHA512 1838e22e1f5b849b816a05d1b25bd81333c8cf67ceb996177e05ba7a555b8e0e307e62cb53e6f1217f4216823e2fecf050e85437678503d60e10c6b2d5303072
diff --git a/app-emacs/color-theme/color-theme-6.6.0-r1.ebuild b/app-emacs/color-theme/color-theme-6.6.0-r1.ebuild
new file mode 100644
index 000000000000..c3182eaae203
--- /dev/null
+++ b/app-emacs/color-theme/color-theme-6.6.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit readme.gentoo elisp
+
+DESCRIPTION="Install color themes (includes many themes)"
+HOMEPAGE="http://www.nongnu.org/color-theme/"
+SRC_URI="http://download.savannah.gnu.org/releases-noredirect/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+
+ELISP_PATCHES="${P}-replace-in-string.patch"
+ELISP_REMOVE="color-theme-autoloads.*"
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-install ${PN}/themes themes/*.el
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc AUTHORS BUGS ChangeLog README
+
+ DOC_CONTENTS="To use color-theme non-interactively, initialise it
+ in your ~/.emacs file as in the following example (which is
+ for the \"Blue Sea\" theme):
+ \n
+ \n(color-theme-initialize)
+ \n(color-theme-blue-sea)"
+ readme.gentoo_create_doc
+}
diff --git a/app-emacs/color-theme/files/50color-theme-gentoo.el b/app-emacs/color-theme/files/50color-theme-gentoo.el
new file mode 100644
index 000000000000..9d43c350fffd
--- /dev/null
+++ b/app-emacs/color-theme/files/50color-theme-gentoo.el
@@ -0,0 +1,109 @@
+(add-to-list 'load-path "@SITELISP@")
+
+(autoload (quote color-theme-select) "color-theme" "\
+Displays a special buffer for selecting and installing a color theme.
+With optional prefix ARG, this buffer will include color theme libraries
+as well. A color theme library is in itself not complete, it must be
+used as part of another color theme to be useful. Thus, color theme
+libraries are mainly useful for color theme authors." t nil)
+
+(autoload (quote color-theme-describe) "color-theme" "\
+Describe color theme listed at point.
+This shows the documentation of the value of text-property color-theme
+at point. The text-property color-theme should be a color theme
+function. See `color-themes'." t nil)
+
+(autoload (quote color-theme-install-at-mouse) "color-theme" "\
+Install color theme clicked upon using the mouse.
+First argument EVENT is used to set point. Then
+`color-theme-install-at-point' is called." t nil)
+
+(autoload (quote color-theme-install-at-point-for-current-frame) "color-theme" "\
+Install color theme at point for current frame only.
+Binds `color-theme-is-global' to nil and calls
+`color-theme-install-at-point'." t nil)
+
+(autoload (quote color-theme-print) "color-theme" "\
+Print the current color theme function.
+
+You can contribute this function to <URL:news:gnu.emacs.sources> or
+paste it into your .emacs file and call it. That should recreate all
+the settings necessary for your color theme.
+
+Example:
+
+ (require 'color-theme)
+ (defun my-color-theme ()
+ \"Color theme by Alex Schroeder, created 2000-05-17.\"
+ (interactive)
+ (color-theme-install
+ '(...
+ ...
+ ...)))
+ (my-color-theme)
+
+If you want to use a specific color theme function, you can call the
+color theme function in your .emacs directly.
+
+Example:
+
+ (require 'color-theme)
+ (color-theme-gnome2)" t nil)
+
+(autoload (quote color-theme-analyze-defun) "color-theme" "\
+Once you have a color-theme printed, check for missing faces.
+This is used by maintainers who receive a color-theme submission
+and want to make sure it follows the guidelines by the color-theme
+author." t nil)
+
+(autoload (quote color-theme-make-snapshot) "color-theme" "\
+Return the definition of the current color-theme.
+The function returned will recreate the color-theme in use at the moment." nil nil)
+
+(autoload (quote color-theme-compare) "color-theme" "\
+Compare two color themes.
+This will print the differences between installing THEME-A and
+installing THEME-B. Note that the order is important: If a face is
+defined in THEME-A and not in THEME-B, then this will not show up as a
+difference, because there is no reset before installing THEME-B. If a
+face is defined in THEME-B and not in THEME-A, then this will show up as
+a difference." t nil)
+
+(autoload (quote color-theme-install) "color-theme" "\
+Install a color theme defined by frame parameters, variables and faces.
+
+The theme is installed for all present and future frames; any missing
+faces are created. See `color-theme-install-faces'.
+
+THEME is a color theme definition. See below for more information.
+
+If you want to install a color theme from your .emacs, use the output
+generated by `color-theme-print'. This produces color theme function
+which you can copy to your .emacs.
+
+A color theme definition is a list:
+\([FUNCTION] FRAME-PARAMETERS VARIABLE-SETTINGS FACE-DEFINITIONS)
+
+FUNCTION is the color theme function which called `color-theme-install'.
+This is no longer used. There was a time when this package supported
+automatic factoring of color themes. This has been abandoned.
+
+FRAME-PARAMETERS is an alist of frame parameters. These are installed
+with `color-theme-install-frame-params'. These are installed last such
+that any changes to the default face can be changed by the frame
+parameters.
+
+VARIABLE-DEFINITIONS is an alist of variable settings. These are
+installed with `color-theme-install-variables'.
+
+FACE-DEFINITIONS is an alist of face definitions. These are installed
+with `color-theme-install-faces'.
+
+If `color-theme-is-cumulative' is nil, a color theme will undo face and
+frame-parameter settings of previous color themes." nil nil)
+
+(autoload (quote color-theme-submit) "color-theme" "\
+Submit your color-theme to the maintainer." t nil)
+
+(autoload (quote color-theme-initialize) "color-theme" "\
+Initialize the color theme package by loading color-theme-libraries." t nil)
diff --git a/app-emacs/color-theme/files/color-theme-6.6.0-replace-in-string.patch b/app-emacs/color-theme/files/color-theme-6.6.0-replace-in-string.patch
new file mode 100644
index 000000000000..bfd6bedd8983
--- /dev/null
+++ b/app-emacs/color-theme/files/color-theme-6.6.0-replace-in-string.patch
@@ -0,0 +1,30 @@
+http://bugs.gentoo.org/280293
+
+--- color-theme-6.6.0-orig/color-theme.el 2006-05-28 15:07:29.000000000 +0200
++++ color-theme-6.6.0/color-theme.el 2009-08-10 10:17:00.000000000 +0200
+@@ -72,11 +72,6 @@
+ (string-match "XEmacs" emacs-version))
+ "Non-nil if running XEmacs.")
+
+-;; Add this since it appears to miss in emacs-2x
+-(or (fboundp 'replace-in-string)
+- (defun replace-in-string (target old new)
+- (replace-regexp-in-string old new target)))
+-
+ ;; face-attr-construct has a problem in Emacs 20.7 and older when
+ ;; dealing with inverse-video faces. Here is a short test to check
+ ;; wether you are affected.
+@@ -1626,9 +1621,10 @@
+ (add-to-list 'color-themes
+ (list ',n
+ (upcase-initials
+- (replace-in-string
+- (replace-in-string
+- (symbol-name ',n) "^color-theme-" "") "-" " "))
++ (replace-regexp-in-string
++ "-" " "
++ (replace-regexp-in-string
++ "^color-theme-" "" (symbol-name ',n))))
+ ,author))
+ (defun ,n ()
+ ,description
diff --git a/app-emacs/color-theme/metadata.xml b/app-emacs/color-theme/metadata.xml
new file mode 100644
index 000000000000..c918cdef9591
--- /dev/null
+++ b/app-emacs/color-theme/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<stabilize-allarches/>
+</pkgmetadata>