summaryrefslogtreecommitdiff
path: root/app-emacs/cmake-font-lock
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /app-emacs/cmake-font-lock
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'app-emacs/cmake-font-lock')
-rw-r--r--app-emacs/cmake-font-lock/Manifest4
-rw-r--r--app-emacs/cmake-font-lock/cmake-font-lock-0.1.12.ebuild31
-rw-r--r--app-emacs/cmake-font-lock/files/50cmake-font-lock-gentoo.el2
-rw-r--r--app-emacs/cmake-font-lock/metadata.xml12
4 files changed, 49 insertions, 0 deletions
diff --git a/app-emacs/cmake-font-lock/Manifest b/app-emacs/cmake-font-lock/Manifest
new file mode 100644
index 000000000000..09c9cdfbe0f8
--- /dev/null
+++ b/app-emacs/cmake-font-lock/Manifest
@@ -0,0 +1,4 @@
+AUX 50cmake-font-lock-gentoo.el 90 BLAKE2B bc36c8a6e0cb106aba4e04d460cd9f369c6efcabcf124000683c1ed4b8dbf353603ba880b9640e58c729e982002a2a6265093337dbacaa8371e73e87334fddbf SHA512 be55435fe782ed521e6a3ab62aca248babf871b7a1417225a02d2af2dd6661d5c5346d0291071d17bd0f75e06f7135efbc84f8cf9b29bc830ad61a0493373edd
+DIST cmake-font-lock-0.1.12.tar.gz 225598 BLAKE2B f3bf11a804d58a92cc09c7e657a66a4f8b56c072b6cfa23184124e931e7a1f238818ac238c6f5d7fd368879bef155c12623837a2b40eb87ae28e7ad5c7bf8d44 SHA512 8ad4d03bfabb0aa9077fc5e8b1444b862934c0df49e4edd673e9f3c1fff702245e796f02e26850ac26fc5ae9134a0522a2648d1d8b5c844316905a3bdcfa2fa7
+EBUILD cmake-font-lock-0.1.12.ebuild 766 BLAKE2B 4239704f4fa794b8d6213dad7f94eae5610beacb781f9c4e19722cdec896bbffbf51480c5438eb57c2fc23bfdb86fbc97c47e078269b30e957d9b8e759a042dc SHA512 5f858d731e985c3ff43bf25dc77b4fea9e0c2dd87767701f0834d726235e9fa86dfdf80cdc72b5b5e2d7840eb5791b0bc9ffe0de4e41b42a85d3e85eac3b55d0
+MISC metadata.xml 373 BLAKE2B 0a89821742aa5830e38a83df07fe1957cbed3aee76de8aa6123327ba9f74af0923ecee7fc0af5987eace2917bee7f2c662c2b1740bec1943deb5b8512be0ed1c SHA512 5faf9e71eb403d44bc2c39bdffe4fd0eaca13aabf6c470d5804e96d8eab7655b917b2524ff1512d26f3bdf9177da8465dfacf29150e7ae63583a2fc5ed91f0e2
diff --git a/app-emacs/cmake-font-lock/cmake-font-lock-0.1.12.ebuild b/app-emacs/cmake-font-lock/cmake-font-lock-0.1.12.ebuild
new file mode 100644
index 000000000000..091bbf2cc75f
--- /dev/null
+++ b/app-emacs/cmake-font-lock/cmake-font-lock-0.1.12.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+NEED_EMACS=26
+
+# The upstream does not create git tags for releases.
+# This commit hash corresponds to a bump to 0.1.12 and was published to
+# MELPA.
+MY_HASH=0d6111b36a66013aa9b452e664c93308df3b07e1
+
+inherit elisp
+
+DESCRIPTION="Advanced, type aware, highlight support for CMake"
+HOMEPAGE="https://github.com/Lindydancer/cmake-font-lock"
+SRC_URI="https://github.com/Lindydancer/${PN}/archive/${MY_HASH}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${MY_HASH}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND="dev-util/cmake[emacs]"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}
diff --git a/app-emacs/cmake-font-lock/files/50cmake-font-lock-gentoo.el b/app-emacs/cmake-font-lock/files/50cmake-font-lock-gentoo.el
new file mode 100644
index 000000000000..636bf931f80a
--- /dev/null
+++ b/app-emacs/cmake-font-lock/files/50cmake-font-lock-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "@SITELISP@/cmake-font-lock-autoloads" nil t)
diff --git a/app-emacs/cmake-font-lock/metadata.xml b/app-emacs/cmake-font-lock/metadata.xml
new file mode 100644
index 000000000000..51b04c0ae888
--- /dev/null
+++ b/app-emacs/cmake-font-lock/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<upstream>
+ <remote-id type="github">Lindydancer/cmake-font-lock</remote-id>
+</upstream>
+<stabilize-allarches/>
+</pkgmetadata>