summaryrefslogtreecommitdiff
path: root/app-emacs/cldoc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/cldoc
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/cldoc')
-rw-r--r--app-emacs/cldoc/Manifest4
-rw-r--r--app-emacs/cldoc/cldoc-1.16.ebuild19
-rw-r--r--app-emacs/cldoc/files/50cldoc-gentoo.el13
-rw-r--r--app-emacs/cldoc/metadata.xml21
4 files changed, 57 insertions, 0 deletions
diff --git a/app-emacs/cldoc/Manifest b/app-emacs/cldoc/Manifest
new file mode 100644
index 000000000000..0c55198d2f86
--- /dev/null
+++ b/app-emacs/cldoc/Manifest
@@ -0,0 +1,4 @@
+AUX 50cldoc-gentoo.el 438 BLAKE2B a1997b6a7e5d63b5889aff5baa21d53cdb811914de505eb84864e6e76f6cdaabe722c5f8eee3569fd6bd6ca6bc4e47b794896e6e0addd63b1cffc2ba144d7234 SHA512 8b102bfb58219c061b9512a0449f2c65b92accd76d852bc5cebcd73dc55f5561cc86e690dbd4a55e244c398bdc30e9c3dade20f44201168203db9b5cfccf9844
+DIST cldoc-1.16.el.bz2 16869 BLAKE2B 5ddcb96e77be37c00cf4c2e897d3b8c7ef71aaa236258a9aacd015eca36b91708e8a174113b7b3bccdc755825817fec429c57a6294049e1fc161632a2849ad98 SHA512 6b53418252e6c139cca24768b502d58cb9d316fd5778b541306b5e7806e9ddac1d7662e099e7dd90c98932555adaeb8a7481b0a72669d5231c803818133cbacc
+EBUILD cldoc-1.16.ebuild 510 BLAKE2B f9d5c42cdaf87e25018ff5eb9bea579286a0f78d9cc30c0b37dce2375dbf44420bfe8cdac2b6ea552a40380ec70779f5ebcec8001aaad41c84733999a8cdb4b2 SHA512 bc2d9ccd0da905ffed2a934ef9c60e3b4b1b9551b7cffc8fe7575db678f82975242d42c9945b5774f5b5457657e80d11a89a7c135aa07759efff8c188e89273e
+MISC metadata.xml 830 BLAKE2B 41f5553ea0c2e9a474996402ffca352d596e49ff25b9998de64c659513290ba1b6ac6226af147b113b1878ee0515751591954a7a67eccafbc8d1f9ebfc8207a0 SHA512 386b5b7c1cf52d27508ba2c423979e8b156fad6c4478bd80d2faa9da1715d11fc6cb919219eba29ae8148bbe7d8deb1c517ffba6405321f3fd88f0b826adf3f2
diff --git a/app-emacs/cldoc/cldoc-1.16.ebuild b/app-emacs/cldoc/cldoc-1.16.ebuild
new file mode 100644
index 000000000000..10fbf9fbc056
--- /dev/null
+++ b/app-emacs/cldoc/cldoc-1.16.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Show Common Lisp operators and variables information in echo area"
+HOMEPAGE="http://homepage1.nifty.com/bmonkey/lisp/index-en.html"
+# taken from http://homepage1.nifty.com/bmonkey/emacs/elisp/cldoc.el
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.el.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="app-emacs/slime"
+
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/cldoc/files/50cldoc-gentoo.el b/app-emacs/cldoc/files/50cldoc-gentoo.el
new file mode 100644
index 000000000000..79e11ea0e710
--- /dev/null
+++ b/app-emacs/cldoc/files/50cldoc-gentoo.el
@@ -0,0 +1,13 @@
+(add-to-list 'load-path "@SITELISP@")
+
+(autoload 'cldoc-mode "cldoc" nil t)
+(autoload 'turn-on-cldoc-mode "cldoc" nil t)
+(add-hook 'lisp-mode-hook 'turn-on-cldoc-mode)
+
+(add-hook 'slime-repl-mode-hook
+ #'(lambda ()
+ (turn-on-cldoc-mode)
+ (define-key slime-repl-mode-map " " nil)))
+(add-hook 'slime-mode-hook
+ #'(lambda () (define-key slime-mode-map " " nil)))
+(setq slime-use-autodoc-mode nil)
diff --git a/app-emacs/cldoc/metadata.xml b/app-emacs/cldoc/metadata.xml
new file mode 100644
index 000000000000..fa3a3cfbb4a6
--- /dev/null
+++ b/app-emacs/cldoc/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<maintainer type="project">
+ <email>common-lisp@gentoo.org</email>
+ <name>Gentoo Common Lisp Project</name>
+</maintainer>
+<longdescription>
+ Show Common Lisp operators and variables information in echo area.
+ cldoc.el has a database of parameters and results of Common Lisp's
+ standard functions, and syntax rules of standard macros and special
+ operators. cldoc.el automatically uses SLIME's autodoc facility if
+ available to display parameters of user defined functions and macros,
+ and the values of global variables.
+</longdescription>
+<stabilize-allarches/>
+</pkgmetadata>