summaryrefslogtreecommitdiff
path: root/app-emacs/citeproc-el
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-05 08:03:20 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-05 08:03:20 +0000
commit1ddcee0bd115d2f843f82061cb0d1741bf90151d (patch)
tree20e516fd0fd41ce7f9f04e7ea8e7d8d3139af3f4 /app-emacs/citeproc-el
parentc1c9e565a5696c10e991d8b5372f781ba5f13d5c (diff)
gentoo auto-resync : 05:01:2024 - 08:03:20
Diffstat (limited to 'app-emacs/citeproc-el')
-rw-r--r--app-emacs/citeproc-el/Manifest2
-rw-r--r--app-emacs/citeproc-el/citeproc-el-0.9.4.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/app-emacs/citeproc-el/Manifest b/app-emacs/citeproc-el/Manifest
index 3a399dcb4554..50402a9f1aac 100644
--- a/app-emacs/citeproc-el/Manifest
+++ b/app-emacs/citeproc-el/Manifest
@@ -1,3 +1,5 @@
DIST citeproc-el-0.9.3.tar.gz 109131 BLAKE2B f6975cd587f61f5f05bfc3734e70ec686a3e26caa4b7905b5b4377c4ce6c8eae5199ea097de9abb10dd1a649587cf016c5fe0db4a6fd4012867655702f5004d8 SHA512 98275ef7ba0a7fc5d866ee010b5f4c8ecf75b12857c6355da07345957783815d9012f8aa86fd7462b8a08e4e3f3192853e1b4a0d5a0088acdb89476011375083
+DIST citeproc-el-0.9.4.tar.gz 109594 BLAKE2B f13c1c93110666d897127c31da39eee392161fada18aa5cee940dfe4968b565d45a397536aa3d8c902625be6c3b27d4a19fca4aeab83233fb549c3f35169adcd SHA512 6772fea40203221e7016a5a0a5c2522b72889202f89eef4603dcbdb8c3c8c0050c5aabee8d56d5e56148e100fac33cd24489d3e03f2caa85964796b7d89ae019
EBUILD citeproc-el-0.9.3.ebuild 908 BLAKE2B f1f33cab1f2dc15882a44ade474cd8dcafa69f813777ea6013037470ca28d3296c991305f2fe9aaf2444a0dfcea5ef8dbb4060573cac3fd1a52cfcc168f1b735 SHA512 4d3cb341ae6108909e2ea92b2b876845ba2d4257834cc676b617665bef4bff2450cba1513459f6223f9de1e1980b66a0b130b02495f69107e20c842d9607e8b9
+EBUILD citeproc-el-0.9.4.ebuild 909 BLAKE2B 3798b5075e4e074883bf270769be02bab2bf138ae2aebb8ee777f7ddc111ce5dc4ab6d658d19ee7d8f0f2e69601131d5909b55692f5a658557b282636dafd325 SHA512 fdad746f1e31577d6a6ac418910e461297ca5a778f70e98f2df0d1ba8a9bf2bb75e495533397f65d696acec98789dac629522f90ff4538431b60edd3c4f4634b
MISC metadata.xml 1335 BLAKE2B 100bfe27f5d296a91fa300faa044dd80ba7762e53468b9f4c62c1ffaf23cfbcea7c611451f1ec82385d29d8a0400812ac536c302ae6f4b615bf25583d98c8b8b SHA512 2e9ce67c3e10f25113fe65a9307139b1e493ecb2b6cf15c34c5b4659279361fba04b5830cc20fb7a2818a290067236811754ca92607c8d991ea505657dad7570
diff --git a/app-emacs/citeproc-el/citeproc-el-0.9.4.ebuild b/app-emacs/citeproc-el/citeproc-el-0.9.4.ebuild
new file mode 100644
index 000000000000..15506aca0ab1
--- /dev/null
+++ b/app-emacs/citeproc-el/citeproc-el-0.9.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26
+
+inherit elisp
+
+DESCRIPTION="CSL 1.0.2 Citation Processor for Emacs"
+HOMEPAGE="https://github.com/andras-simonyi/citeproc-el"
+SRC_URI="https://github.com/andras-simonyi/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=app-editors/emacs-26:*[libxml2]
+ app-emacs/dash
+ app-emacs/f
+ app-emacs/parsebib
+ app-emacs/queue
+ app-emacs/s
+ app-emacs/string-inflection
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ app-emacs/ht
+ app-emacs/yaml
+ )
+"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . -L test \
+ -l citeproc-test-human.el \
+ -l test/citeproc-test-int-biblatex.el \
+ -l test/citeproc-test-int-formatters.el \
+ -f ert-run-tests-batch-and-exit || die
+}