summaryrefslogtreecommitdiff
path: root/app-emacs/citar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-17 08:06:58 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-17 08:06:58 +0000
commit29394d0921808a94a409f01eff49f681651de5d5 (patch)
tree93d18027cb4ea68a3c967602c5793af032180bab /app-emacs/citar
parent5987fa693ef880163ebde423615a177cb5bda20e (diff)
gentoo auto-resync : 17:02:2023 - 08:06:58
Diffstat (limited to 'app-emacs/citar')
-rw-r--r--app-emacs/citar/Manifest2
-rw-r--r--app-emacs/citar/citar-1.1.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/app-emacs/citar/Manifest b/app-emacs/citar/Manifest
index 49ff9b18b3ba..4fceb32912d4 100644
--- a/app-emacs/citar/Manifest
+++ b/app-emacs/citar/Manifest
@@ -1,4 +1,6 @@
AUX 50citar-gentoo.el 69 BLAKE2B 4852ed7422e341e92f938dceedc3d6f0d0fdf8f955ef93021286d9d10e7c3a5d726175e2e79d34ca67f6815d7d6e0445ca2c9a80a2a6690daf4bda49d9972f96 SHA512 0afe62329cd2dc6ea548bbc28aa3c7fea86fb2a20febc91528ba994c77edf08fd72dcf1a0c417dcd4db75b4a6b8e237ade2257130ff3887499377b8f77fefc46
DIST citar-1.0.tar.gz 1339812 BLAKE2B 2093cc820199219ec70f99a746c630f2b8e6b4d464b1457d7b7db1c5c953138e7dd5ac55e21b13e7417dd0a764b6f1caaf400af353ecce9fb7e1bc578f570b0d SHA512 7f02a4e41a927c2c7c625189fa38caea8f0fc5616dd3487a93f71a373d1e4a124dd1cc520778a1ff2fa6dd7c3b619b539e3b0e47cb9caf7edd16e27e9d739585
+DIST citar-1.1.tar.gz 1340039 BLAKE2B b2090a35a582918300f5e4bb2188d463630988830305aa4bb5e1e27f45ff8c96ca35458e610e13658b2120af497f9b877054a6fbebda48e0a4d87824ef48e9c8 SHA512 2b1924ef1a05a170eea31f844055b914410cd35613eda6604f08164818a8fc5480fc5a6d6f055ba95331b517305e51a6e671214cc88fccbda2430ae9b06dda49
EBUILD citar-1.0.ebuild 979 BLAKE2B 8b40e7b2c88ea5b739db50ffd588be12720330a89c84a11c2e0092fab7c08bc8c411e04e476df97867a7fd0ba59bee8829519a99fc2856c70ecbca7da8c2a29a SHA512 192a72c0a645dde0fabd681769f1dfa1eb9cf5f2cc91a996c7f52f837ef014543b2d2f299b35dcf3ee5c696da66f3fa63fc84caa64692d599293f95b67424bf0
+EBUILD citar-1.1.ebuild 979 BLAKE2B 8243cd6b70792fcf30ba71450389a1475cb4c5a66b794824feb4861cde560f34fc9b8fc09cb56b9ebd88baf322f9f9b296daeb8e294ee6a15ccefbb3db298774 SHA512 23566dbc5ff4ad70d61e382fbe4107295e0b1c36946d957434c92e04e8662585fe3b3f89eb09637acaea6725ad6a411a46cd3b657e66256caecbddb6356d766b
MISC metadata.xml 1034 BLAKE2B 10d658566f58e3a91deab1c4d2035bcd25ee216777aa105b1e8c8853ab103add779f0f439e706496b2468a3fcb8490320ccb454d90c2e70b5b8bbe9f218773e4 SHA512 4b81115dfccc471987c63876c0b282875fe95c5738f69dfdf7a6300c37998102f2fdda829d14938871bd857fbb5d145e6c62b5b4be40b532f46245256d0be259
diff --git a/app-emacs/citar/citar-1.1.ebuild b/app-emacs/citar/citar-1.1.ebuild
new file mode 100644
index 000000000000..9c62e000f5a7
--- /dev/null
+++ b/app-emacs/citar/citar-1.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Emacs package to quickly find and act on bibliographic references"
+HOMEPAGE="https://github.com/emacs-citar/citar/"
+SRC_URI="https://github.com/emacs-citar/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-emacs/citeproc-el
+ app-emacs/parsebib
+"
+BDEPEND="${RDEPEND}"
+
+# Embark integration has it's own package on MELPA, and it is probably better
+# to split them. https://melpa.org/#/citar-embark
+ELISP_REMOVE="citar-embark.el"
+
+DOCS=( CHANGELOG.org CONTRIBUTING.org README.org images )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . -L test \
+ -l test/citar-file-test.el \
+ -l test/citar-format-test.el \
+ -l test/citar-test.el \
+ -f ert-run-tests-batch-and-exit || die
+}