summaryrefslogtreecommitdiff
path: root/app-emacs/circe
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/circe
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/circe')
-rw-r--r--app-emacs/circe/Manifest6
-rw-r--r--app-emacs/circe/circe-1.3.ebuild19
-rw-r--r--app-emacs/circe/circe-2.7.ebuild20
-rw-r--r--app-emacs/circe/files/50circe-gentoo.el2
-rw-r--r--app-emacs/circe/metadata.xml12
5 files changed, 59 insertions, 0 deletions
diff --git a/app-emacs/circe/Manifest b/app-emacs/circe/Manifest
new file mode 100644
index 000000000000..1d8d4123ff34
--- /dev/null
+++ b/app-emacs/circe/Manifest
@@ -0,0 +1,6 @@
+AUX 50circe-gentoo.el 84 BLAKE2B 256e2b96a42e5662222eeadfb0fe7277a09eec8119903ea6e3e9a1dfac3157e238d383051b0738b1a8d555250181db67546da50743221314a0ba1353474ad81a SHA512 3f3c92f02e0a6ee760e83b83c4685a6b7f3268d0cb99abc9be56bdee8dd794d177f865582e45e90f895d1a2d9bbdc2ce39a3a60c7fc4eb973021eab66d8dbe47
+DIST circe-1.3.tar.gz 118776 BLAKE2B 61ffc7df022be50beaba29a4025fde6d7cbde5cab28d0661e2e3388f712281f8d9370b92e8c56b4eb49984573d5a2f7edff308a7d1fe74ff630620f0867b1441 SHA512 60bbd752c73e875f2306877591ad8de324db0a7446bbfebf460e44ef19c0c28d40d08c8ed9e0caa4062859b07545d310d86380377a479eb6bc38c72decfaa213
+DIST circe-2.7.tar.gz 237375 BLAKE2B d9978cc3e0c6431dace919efbd323f90e36ce40debb6e03c955b8cdfbed60ac0bbe27c68dcebfe2df9aabd2e7198d2d6da993c2ad41b5ede0b5d1b142217ec8f SHA512 6f4e0925381ad051e4680b5413eed000a6796d2e9bef35a052464a07968f67edb19d99f74be93620359e061c044a910e35afd1f88608453d264bf37826e10af3
+EBUILD circe-1.3.ebuild 474 BLAKE2B 466b3f47e0e6124ee5d2484dbfdfa189b895cab597253066521075278fc93f29738fda684b2b2ae7dc801598845e80a731f7abff3a0bf16ab7e9d64c293cd70e SHA512 5310ba832a4652166b39247d3f7f581fb2deb99832d55e52c746dc7ff2ea183ada09b03ccfa6c0c55c81d816a412dc5681efc70e3601b975c14ebdfe6c322e07
+EBUILD circe-2.7.ebuild 537 BLAKE2B 9ea555c3500da4eda553396eed1a2b019f7e345214573c343bdb725a6427809aa2460a3fa3de3360274cf7d6ea3cec89f136a6226ae6b0285e412f87cb8193fe SHA512 3f8f4ff558f50958c3dc475fed1aa621e4d24912d325c07fde80562a332f928af64e3c9d2119c1297010b9162c2a25e6f92ee229982d71555162599e9c6db973
+MISC metadata.xml 365 BLAKE2B b725f9635d4c4b98167ccb4145c0e7c9fa32b39cf18e79e7f86e583897bb2a79bdb0aa6fc070c53ee0fd03b41685ffdb9f7636c10ff6bfc1c7244f81e4b417a1 SHA512 9e3191129263a25e6ecbf4f7252b326a1addcb110a324d9a4c277ce7a152c086f361796454174e01696be6ad3f9404628b4c9264e3bb7ac2644eb2f72c8e3657
diff --git a/app-emacs/circe/circe-1.3.ebuild b/app-emacs/circe/circe-1.3.ebuild
new file mode 100644
index 000000000000..cc6e6d9515dc
--- /dev/null
+++ b/app-emacs/circe/circe-1.3.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="A great IRC client for Emacs"
+HOMEPAGE="https://github.com/jorgenschaefer/circe
+ https://www.emacswiki.org/emacs/Circe"
+SRC_URI="https://github.com/jorgenschaefer/${PN}/archive/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 ~ppc sparc x86"
+
+S="${WORKDIR}/${PN}-${P}/lisp"
+SITEFILE="50${PN}-gentoo.el"
+DOCS="../README.md"
diff --git a/app-emacs/circe/circe-2.7.ebuild b/app-emacs/circe/circe-2.7.ebuild
new file mode 100644
index 000000000000..8367f297cab8
--- /dev/null
+++ b/app-emacs/circe/circe-2.7.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="A great IRC client for Emacs"
+HOMEPAGE="https://github.com/jorgenschaefer/circe
+ https://www.emacswiki.org/emacs/Circe"
+SRC_URI="https://github.com/jorgenschaefer/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+ELISP_REMOVE="circe-pkg.el"
+SITEFILE="50${PN}-gentoo.el"
+DOCS="AUTHORS.md CONTRIBUTING.md NEWS.md README.md"
diff --git a/app-emacs/circe/files/50circe-gentoo.el b/app-emacs/circe/files/50circe-gentoo.el
new file mode 100644
index 000000000000..4c0f194ca2cf
--- /dev/null
+++ b/app-emacs/circe/files/50circe-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'circe "circe" "Connect to IRC." t)
diff --git a/app-emacs/circe/metadata.xml b/app-emacs/circe/metadata.xml
new file mode 100644
index 000000000000..750ed04302ad
--- /dev/null
+++ b/app-emacs/circe/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<stabilize-allarches/>
+<upstream>
+ <remote-id type="github">jorgenschaefer/circe</remote-id>
+</upstream>
+</pkgmetadata>