summaryrefslogtreecommitdiff
path: root/app-emacs/cape
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-12 20:20:47 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-12 20:20:47 +0100
commit3d952d0bfe7b386699eb32d1431deb0c538f044d (patch)
tree45d2492f5c659cbb01120d4192c9be34841362bd /app-emacs/cape
parent522b6bf7e1f6133c288b94a77fc5e3d8eef2c179 (diff)
gentoo auto-resync : 12:06:2023 - 20:20:47
Diffstat (limited to 'app-emacs/cape')
-rw-r--r--app-emacs/cape/Manifest5
-rw-r--r--app-emacs/cape/cape-0.15.ebuild39
-rw-r--r--app-emacs/cape/cape-9999.ebuild39
-rw-r--r--app-emacs/cape/files/50cape-gentoo.el3
-rw-r--r--app-emacs/cape/metadata.xml15
5 files changed, 101 insertions, 0 deletions
diff --git a/app-emacs/cape/Manifest b/app-emacs/cape/Manifest
new file mode 100644
index 000000000000..03b2715825d2
--- /dev/null
+++ b/app-emacs/cape/Manifest
@@ -0,0 +1,5 @@
+AUX 50cape-gentoo.el 149 BLAKE2B a0b1a06c1236d3469cb87a2289e111fcf906093d9301d44d66732aa42d26e66c5a99f5c33ea893943d76d4478e30331680bc60365675529a0bc21bf9ffeec4c5 SHA512 79f9cba6529c5749ee1c72beda4ee40396d9bd3decc8fe332ad821127f385bc46b13befd9f7cc458812d08ef784daf04464fc29fa65bf3d86795b33d39c22fce
+DIST cape-0.15.tar.xz 25848 BLAKE2B 44d72cd8de7597dad6f92c225995a5e1c02f42daf7a839c98e2b3d3ec0ff66dba5da64fc87d64b4913c5f9598cb00e3b46e22eaf98f65a759f4c04c9b373a3b2 SHA512 a2ea009f1f28868ac7c58f23e9212568545434588d89a2f15e5b1a0f4dba09a27a5620a9b9ac79cb88da3a9e83174f13a6122425581dd0aa43e25d12f1766396
+EBUILD cape-0.15.ebuild 695 BLAKE2B 20eb9a63d07fced7b8594e908aa980c9566a57d56e06666fe4a4d87e1d155808a3007a1328a4b9abaece3e584fd02ced35e0707b8dba4169369e486a727b2cec SHA512 f12b64a189b059d19b18c9f0f338016d04a84cd456bd59db255888ee3321ea711c07e2336d8b679e02ffa6d174a66cb8cedad5807fea683d73c8df7154c4e538
+EBUILD cape-9999.ebuild 695 BLAKE2B 20eb9a63d07fced7b8594e908aa980c9566a57d56e06666fe4a4d87e1d155808a3007a1328a4b9abaece3e584fd02ced35e0707b8dba4169369e486a727b2cec SHA512 f12b64a189b059d19b18c9f0f338016d04a84cd456bd59db255888ee3321ea711c07e2336d8b679e02ffa6d174a66cb8cedad5807fea683d73c8df7154c4e538
+MISC metadata.xml 476 BLAKE2B 684b40897141a0211cf5bf3e67ed5e6cd85223e27e296270c085b394b7ec322235c5e5e8ee5140e5cba1c245997e9662f8d93cefa8b951e9f50071a29563288c SHA512 58087f440a5745173aa1c05cc0393e9470763c5f38bc1fcf80e59c9b2c9dacebfd420d422a71ac3279346e9233dc39ec88de4413ee2a19dd331d322616c3244e
diff --git a/app-emacs/cape/cape-0.15.ebuild b/app-emacs/cape/cape-0.15.ebuild
new file mode 100644
index 000000000000..f7f6e19f558b
--- /dev/null
+++ b/app-emacs/cape/cape-0.15.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+inherit elisp
+
+DESCRIPTION="Completion At Point Extensions"
+HOMEPAGE="https://github.com/minad/cape"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/minad/cape.git"
+else
+ # Recompressed from ELPA.
+ SRC_URI="https://dev.gentoo.org/~arsen/${P}.tar.xz"
+ KEYWORDS="~amd64"
+ ELISP_REMOVE="${PN}-pkg.el"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=app-emacs/compat-29.1.4.0
+"
+DEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp-make-autoload-file
+ elisp_src_install
+
+ if [[ ${PV} != 9999 ]]; then
+ doinfo cape.info
+ fi
+}
diff --git a/app-emacs/cape/cape-9999.ebuild b/app-emacs/cape/cape-9999.ebuild
new file mode 100644
index 000000000000..f7f6e19f558b
--- /dev/null
+++ b/app-emacs/cape/cape-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+inherit elisp
+
+DESCRIPTION="Completion At Point Extensions"
+HOMEPAGE="https://github.com/minad/cape"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/minad/cape.git"
+else
+ # Recompressed from ELPA.
+ SRC_URI="https://dev.gentoo.org/~arsen/${P}.tar.xz"
+ KEYWORDS="~amd64"
+ ELISP_REMOVE="${PN}-pkg.el"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=app-emacs/compat-29.1.4.0
+"
+DEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp-make-autoload-file
+ elisp_src_install
+
+ if [[ ${PV} != 9999 ]]; then
+ doinfo cape.info
+ fi
+}
diff --git a/app-emacs/cape/files/50cape-gentoo.el b/app-emacs/cape/files/50cape-gentoo.el
new file mode 100644
index 000000000000..84d436d35cd5
--- /dev/null
+++ b/app-emacs/cape/files/50cape-gentoo.el
@@ -0,0 +1,3 @@
+;;; app-emacs/cape site configuration -*- lexical-binding: t; -*-
+(add-to-list 'load-path "@SITELISP@")
+(load "@SITELISP@/cape-autoloads.el" nil t)
diff --git a/app-emacs/cape/metadata.xml b/app-emacs/cape/metadata.xml
new file mode 100644
index 000000000000..704398b0a728
--- /dev/null
+++ b/app-emacs/cape/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>arsen@gentoo.org</email>
+ <description>Arsen Arsenović</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">minad/cape</remote-id>
+ </upstream>
+</pkgmetadata>