summaryrefslogtreecommitdiff
path: root/app-emacs/boxquote
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-emacs/boxquote
reinit the tree, so we can have metadata
Diffstat (limited to 'app-emacs/boxquote')
-rw-r--r--app-emacs/boxquote/Manifest6
-rw-r--r--app-emacs/boxquote/boxquote-1.23.ebuild22
-rw-r--r--app-emacs/boxquote/files/50boxquote-gentoo.el2
-rw-r--r--app-emacs/boxquote/metadata.xml22
4 files changed, 52 insertions, 0 deletions
diff --git a/app-emacs/boxquote/Manifest b/app-emacs/boxquote/Manifest
new file mode 100644
index 000000000000..a2e901cfb45f
--- /dev/null
+++ b/app-emacs/boxquote/Manifest
@@ -0,0 +1,6 @@
+AUX 50boxquote-gentoo.el 72 SHA256 0edae5927e6679c83eadf739e4cc99bafbdd482a257bfc06dc885f0c91df1992 SHA512 d11e537a8e60f4dfc3eccae94709e382414d76cf470c5dae673d6b3b5ab34e88fa9716b58a5a2ca1d0a5673c926fc04c293484e9e53d0861520303f0a98d4b87 WHIRLPOOL 816925130a21c03422a421950198ad49d435e673d25889602f44379dc4ac7f85242cccb17b95d651ba4daad6d8bd49bc1a5aa9e83dea960add8b1b1e1ff0f16d
+DIST boxquote-1.23.el.bz2 4957 SHA256 59ad204c4eb787bbc69a82d16737829bf6c6b44ddda1c5137d42245d0dcc6825 SHA512 776835e6a21ede6e7ba82a57f381f0c9c3c740994b4d463b76d1f8a328fdf7b1b996cf6c593c3300a68fa773f1dd21b7c1a8ccc38536d5f1874973541181646d WHIRLPOOL 9793910877ac827167b96023e033577b412d4eacbf6ebd40632ea5d5bd2e2897ae53f02c282d4ea5eb05cba08b9a138956f2bea4e4e515149bb647242c7ac309
+EBUILD boxquote-1.23.ebuild 480 SHA256 f42ba22c8c597c9c71908ac3d950182f05548bb8bc73a46d5225e51c8c66cdd3 SHA512 861a1c21b61a5f429d0eaf49457928f4bb62a84c583e4589bb3e0e162c8c563d667e8f7a3786334881789d11d560e1aa776a3b4cc3f06de8a02b7f449915a672 WHIRLPOOL fe959af08ca0af6c812307775a50fa7ba8b6426a0659ec8545ae53f4f07ced8ba48d33b9d6a87d4d29ad299e6d212064430a30c055b7404de40a2693d923d96c
+MISC ChangeLog 2345 SHA256 d937960087b67d441347e7ffce8429c3fe9ba18998b56c153eade52f6eff2d7f SHA512 11244f6f7f03ffaab22f4521a01d0976314767c0ca595b5ecbd3eaba4ddff0037cf9d9e733bf324d4aeacb677dd7b2b34fef1e5895ef2add3feed4eafc938d0f WHIRLPOOL 7b090e3ddb147ec27631a178a63739a21175fbb9ab1da6696eb2a5d7a8fcc1372ebd5229a987288e7dd0c21fb019c67a3936beaf88a1513fa1111cf7686c761c
+MISC ChangeLog-2015 3124 SHA256 7acaee375a49b068c900b15b4b4f340df5b9636901f0400379f5535032679d33 SHA512 7b3eb7442e9f8d524dbad0390d0429847629995189d74080e068343821c06b9a310168b63673eafcb62bda4cdd33ff711e9181bc4834405d7f1496ab8f2b5b17 WHIRLPOOL 267735b16de5f9c49eab4e7ec5a7a7c1947e797986e5bea818c3de54281cd06079c314084742fd1538f0a25b9347a18eb9e52aa6ade061fe4537f6517eeed01c
+MISC metadata.xml 831 SHA256 0a5335fd5d4f98879aa5d30513567327c6603176767fcc8731221715052440c2 SHA512 5117fd73bf7143fb7f80bf1ea9b4b352ff4624343be94303f7381c3fa26eccf483c1f16626a9056b749a89293a2882352dc0d612b2788e2ae52c599db547a11c WHIRLPOOL 237a02747d27a2475f4edb5f9fefcd3d76db2976184946433bb745f479bb3062a949f6b36e7ed16e3676fd5d2166bf0d230794bd0afe781e7c64331da3e6b122
diff --git a/app-emacs/boxquote/boxquote-1.23.ebuild b/app-emacs/boxquote/boxquote-1.23.ebuild
new file mode 100644
index 000000000000..c043cc42b678
--- /dev/null
+++ b/app-emacs/boxquote/boxquote-1.23.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit elisp
+
+DESCRIPTION="Quote text with a semi-box"
+HOMEPAGE="http://www.davep.org/emacs/"
+SRC_URI="mirror://gentoo/${P}.el.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE=""
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile *.el || die "elisp-compile failed"
+ elisp-make-autoload-file || die "elisp-make-autoload-file failed"
+}
diff --git a/app-emacs/boxquote/files/50boxquote-gentoo.el b/app-emacs/boxquote/files/50boxquote-gentoo.el
new file mode 100644
index 000000000000..b971ce73148a
--- /dev/null
+++ b/app-emacs/boxquote/files/50boxquote-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "boxquote-autoloads" nil t)
diff --git a/app-emacs/boxquote/metadata.xml b/app-emacs/boxquote/metadata.xml
new file mode 100644
index 000000000000..2aea8e67022b
--- /dev/null
+++ b/app-emacs/boxquote/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<longdescription>
+ Boxquote provides a set of functions for using a text quoting style that
+ partially boxes in the left hand side of an area of text, such a marking
+ style might be used to show externally included text or example code.
+
+ ,----
+ | The default style looks like this.
+ `----
+
+ A number of functions are provided for quoting a region, a buffer, a
+ paragraph and a defun. There are also functions for quoting text while
+ pulling it in, either by inserting the contents of another file or by
+ yanking text into the current buffer.
+</longdescription>
+</pkgmetadata>