summaryrefslogtreecommitdiff
path: root/app-emacs/blogmax
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/blogmax
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/blogmax')
-rw-r--r--app-emacs/blogmax/Manifest5
-rw-r--r--app-emacs/blogmax/blogmax-20110305.ebuild43
-rw-r--r--app-emacs/blogmax/files/50blogmax-gentoo.el4
-rw-r--r--app-emacs/blogmax/files/README.Gentoo8
-rw-r--r--app-emacs/blogmax/metadata.xml12
5 files changed, 72 insertions, 0 deletions
diff --git a/app-emacs/blogmax/Manifest b/app-emacs/blogmax/Manifest
new file mode 100644
index 000000000000..1046ea561d62
--- /dev/null
+++ b/app-emacs/blogmax/Manifest
@@ -0,0 +1,5 @@
+AUX 50blogmax-gentoo.el 203 BLAKE2B 13d5f7436a13426fc3b33f9d84f45c011386d3b062acf4297c81f48d2cfc02fcd24c80292fb66152b9b0e4c968423648a99ddd6ef0bf9a4d5164e3ee5bfb330f SHA512 33bfaa0a6861bf4dcd402e3f24e999f5206235d69a9e7674c43d408e85438fd450810522a2e3bc42f5457ded290d67700e71a512603f62d64ecab82d4d2fd78c
+AUX README.Gentoo 246 BLAKE2B 51cb9a5d3b6043baa30655e90b2bec57620a0d5dfdea2f718b9f519a2d89619a3bfc3702915948c6bfb6d145c798f13f089582af7db8ea1754f5e50ebb95d4b8 SHA512 38559a4b05509061ed5026f1e7b4936da8d90d965fa8db3e5e087d7eeedc8a33a96eee4c6e6a8b76f6fc224062ee78f252dc17bb918248c2df313a258d1b2dc0
+DIST blogmax-20110305.zip 194956 BLAKE2B b5f90254a218fc45b65faa8d5cdc53ec55f092716286a5757f483eed621d2142aeda398449b1c1b9c3acad67575025ce6bf9b9dce42f1d97d35227d13a0aa65e SHA512 dc0529c5d61ea9beaecf9dfdfe0631ae31fb9737845aa81f2ac7c19df7aa30eb7392f73ea96a00b678cd441f0815129bb04d521e697ce2cb3938d8699483d19b
+EBUILD blogmax-20110305.ebuild 987 BLAKE2B 8be3b8ad56bafc12bf4ab2dd72c67f8d400cd3ebf6ed607c70d47bf8fe027f6235f8ede6a90f19574dd90acda381e5cfdf45a546055a35ace8be76f27fc8716b SHA512 c80b0c0bd9e3d84e1f53d579c9f6a6f027ae6c7a967c628cc591d27c1c479c207dbc11c548fede045764c866d7c06f6d14809415bf10816fc2e2a4a8432ddda7
+MISC metadata.xml 388 BLAKE2B 14e7039960527342a1837a45bc3d4a5da96f924573067aab0066b053dc24b26197d6bd4c113c87526c3c2f50bdf152df43bbbc25885e7d76c9cd5f846094e899 SHA512 b794dbcab7f297bb941a561495b2d4b7863476f7204c7d240bbb99391c99441ff8e482b88f9664ad75a96f1cb4bf77a2e709301d4897d836297adf551aa519c2
diff --git a/app-emacs/blogmax/blogmax-20110305.ebuild b/app-emacs/blogmax/blogmax-20110305.ebuild
new file mode 100644
index 000000000000..07505c200b1f
--- /dev/null
+++ b/app-emacs/blogmax/blogmax-20110305.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils readme.gentoo elisp
+
+DESCRIPTION="Blogging in Emacs"
+HOMEPAGE="http://billstclair.com/blogmax/index.html"
+# taken from http://billstclair.com/blogmax.zip
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.zip"
+
+LICENSE="GPL-1+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${PN}"
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ rm *.elc gpl.txt || die
+ edos2unix *.{el,html,inc,ini,tmpl,txt,xml} docs/*.{html,txt}
+}
+
+src_compile() {
+ elisp-compile blogmax.el
+}
+
+src_install() {
+ elisp-install ${PN} blogmax.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ DOC_CONTENTS="To get started with BlogMax, use the example site file
+ from /usr/share/doc/${PF}/example as a template for your own blog."
+ readme.gentoo_create_doc
+
+ dodoc README
+ dodoc -r docs
+ docinto example
+ dodoc *.{html,inc,ini,png,tmpl,txt,xml}
+}
diff --git a/app-emacs/blogmax/files/50blogmax-gentoo.el b/app-emacs/blogmax/files/50blogmax-gentoo.el
new file mode 100644
index 000000000000..fc110114b3a6
--- /dev/null
+++ b/app-emacs/blogmax/files/50blogmax-gentoo.el
@@ -0,0 +1,4 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'weblog-mode "blogmax" "Weblog" t)
+(autoload 'weblog-set-buffer-mode "blogmax"
+ "Set the mode to weblog-mode for text files in the *weblog-directory*" t)
diff --git a/app-emacs/blogmax/files/README.Gentoo b/app-emacs/blogmax/files/README.Gentoo
new file mode 100644
index 000000000000..a737d0f9c9ac
--- /dev/null
+++ b/app-emacs/blogmax/files/README.Gentoo
@@ -0,0 +1,8 @@
+ -*-outline-*-
+* Getting Started With BlogMax
+
+Use the example site file from /usr/share/doc/blogmax-*/example as a
+template for your own blog.
+
+--
+Matthew Kennedy <mkennedy@gentoo.org>
diff --git a/app-emacs/blogmax/metadata.xml b/app-emacs/blogmax/metadata.xml
new file mode 100644
index 000000000000..18aa34682d6d
--- /dev/null
+++ b/app-emacs/blogmax/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<longdescription>
+ BlogMax is an Emacs package that aids in the creation of a weblog.
+</longdescription>
+<stabilize-allarches/>
+</pkgmetadata>