summaryrefslogtreecommitdiff
path: root/app-emacs/biblio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /app-emacs/biblio
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'app-emacs/biblio')
-rw-r--r--app-emacs/biblio/Manifest5
-rw-r--r--app-emacs/biblio/biblio-0.2_p20210418-r1.ebuild48
-rw-r--r--app-emacs/biblio/files/50biblio-gentoo.el2
-rw-r--r--app-emacs/biblio/files/biblio-0.2-tests.patch43
-rw-r--r--app-emacs/biblio/metadata.xml18
5 files changed, 116 insertions, 0 deletions
diff --git a/app-emacs/biblio/Manifest b/app-emacs/biblio/Manifest
new file mode 100644
index 000000000000..658b389fcb1f
--- /dev/null
+++ b/app-emacs/biblio/Manifest
@@ -0,0 +1,5 @@
+AUX 50biblio-gentoo.el 81 BLAKE2B 16a0d5099e2e7ee01db6072a462a90d523b32da123837123c01ff429bfa633b7bd7f6672d99a4df5a922c03bfe18bb3b47cc62f25b58df157ff6cd711a338a09 SHA512 035b49cd150dbb799a14dbcded10c7e5e029a75cfecac5b117644d914f7bb0014e539f4b194a3bbdfe27bb30a519496851831e0ceb36f4c6112027f60e8afd35
+AUX biblio-0.2-tests.patch 2517 BLAKE2B da75066679c09a93f190de90dad09433fc5c4956ef378f534e6022a7e8cbeed43fbc5a7ca8c11dc4879bd314c38c7084a63e4f1cb02736bd8842e267a3b6a33b SHA512 b9ba2774e65ca431dddfe64136d0d64796723b3f6dbc56e21730d3a7d5da307d33a5ba9de9b3a6c638f082ba21273a38975c7eb02dab41ca7e7e9d9d406b6aac
+DIST biblio-0.2_p20210418.tar.gz 205374 BLAKE2B f649cd5130ce79fae346e7121e1be87d2b596a66ca23f27ccb33f0b2fce9bddfbbeda2a41c79084c91f359235dd3806befa1e2e86c6015df132657c24eb1f6b6 SHA512 5245386cd95c2334a49a139c93ec6107378ebd4154d0263f5b982d0a027c8cf116bf8f89d25348e0d82b540f6672889b3325df4fff3573f2262da493431f2a10
+EBUILD biblio-0.2_p20210418-r1.ebuild 973 BLAKE2B fae80d731582ccb3a66cfb62ec2b3ec27dd3ef755302cfe36fb77408951556cf54a186c483181b446a241c9a800d395eafb00f2d63dd1ad28249ca32a86a6e92 SHA512 72e795df4b7d441edd5dc50088764a3488ae6af5242e59ef22a45e9f78ec7ddac825eba5abb25f66bb2a97c35e7336aac19a9a254c91f1cdd43bc815596e36fa
+MISC metadata.xml 705 BLAKE2B f7615e5e1e03a4f79a25c8fc1713eaa25fd1e3b0b8d78a1ce47137529232dc9433cf0a78328356da4e814de71e9b76acbfe1b6895db4ad87254137ffea6b44ca SHA512 ad932d5f0d70207b43b126d17ce7552805734c591581f6ac490b79fff936a3daa65b33e4596ea06a72e05f1b2186099946d38f74b99a096c1e3c9518bbde3c8e
diff --git a/app-emacs/biblio/biblio-0.2_p20210418-r1.ebuild b/app-emacs/biblio/biblio-0.2_p20210418-r1.ebuild
new file mode 100644
index 000000000000..af3f87de6b95
--- /dev/null
+++ b/app-emacs/biblio/biblio-0.2_p20210418-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NOTICE: This package contains libraries: biblio-core and biblio
+
+EAPI=8
+
+H=517ec18f00f91b61481214b178f7ae0b8fbc499b
+NEED_EMACS=24.4
+
+inherit elisp
+
+DESCRIPTION="Browse and import bibliographic references with Emacs"
+HOMEPAGE="https://github.com/cpitclaudel/biblio.el/"
+SRC_URI="https://github.com/cpitclaudel/${PN}.el/archive/${H}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}.el-${H}
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="app-emacs/dash"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ app-emacs/buttercup
+ app-emacs/noflet
+ app-emacs/undercover
+ )
+"
+
+DOCS=( README.md etc )
+PATCHES=( "${FILESDIR}"/${PN}-0.2-tests.patch )
+
+ELISP_REMOVE="${PN}-pkg.el"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}
+
+src_test() {
+ buttercup -L . -L tests --traceback full tests || die
+}
diff --git a/app-emacs/biblio/files/50biblio-gentoo.el b/app-emacs/biblio/files/50biblio-gentoo.el
new file mode 100644
index 000000000000..c107edfe34b6
--- /dev/null
+++ b/app-emacs/biblio/files/50biblio-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "@SITELISP@/biblio-autoloads" nil t)
diff --git a/app-emacs/biblio/files/biblio-0.2-tests.patch b/app-emacs/biblio/files/biblio-0.2-tests.patch
new file mode 100644
index 000000000000..eab6e9b50581
--- /dev/null
+++ b/app-emacs/biblio/files/biblio-0.2-tests.patch
@@ -0,0 +1,43 @@
+index d393c1a..866815a 100644
+--- a/tests/biblio-tests.el
++++ b/tests/biblio-tests.el
+@@ -136,13 +136,13 @@ month={Apr}, pages={147–156}}")
+ (it "ignores invalid entries"
+ (expect (biblio-format-bibtex "@!!") :to-equal "@!!")
+ (expect (biblio-format-bibtex "@article{INVALID KEY,}") :to-equal "@article{INVALID KEY,}"))
+- (it "formats a typical example properly"
+- (expect (biblio-format-bibtex (concat "@ARTIcle{" stallman-bibtex))
+- :to-equal (concat "@Article{Stallman_1981," stallman-bibtex-clean)))
+- (it "properly creates keys"
+- (expect (let ((bibtex-autokey-year-title-separator "!"))
+- (biblio-format-bibtex (concat "@article{" stallman-bibtex) t))
+- :to-equal (concat "@Article{stallman81!emacs," stallman-bibtex-clean)))
++ ;;(it "formats a typical example properly"
++ ;; (expect (biblio-format-bibtex (concat "@ARTIcle{" stallman-bibtex))
++ ;; :to-equal (concat "@Article{Stallman_1981," stallman-bibtex-clean)))
++ ;;(it "properly creates keys"
++ ;; (expect (let ((bibtex-autokey-year-title-separator "!"))
++ ;; (biblio-format-bibtex (concat "@article{" stallman-bibtex) t))
++ ;; :to-equal (concat "@Article{stallman81!emacs," stallman-bibtex-clean)))
+ (it "replaces the “@data{” header"
+ (expect (biblio-format-bibtex (concat "@data{" stallman-bibtex))
+ :to-match "\\`@misc{"))
+@@ -153,12 +153,12 @@ month={Apr}, pages={147–156}}")
+ (let ((biblio-cleanup-bibtex-function nil))
+ (expect (biblio-format-bibtex (concat "@techreport{" stallman-bibtex))
+ :to-equal (concat "@techreport{" stallman-bibtex))))
+- (it "doesn't set the BibTeX dialect globally"
+- (with-temp-buffer
+- (bibtex-mode)
+- (let ((bibtex-dialect 'aaa))
+- (biblio-format-bibtex (concat "@techreport{" stallman-bibtex))
+- (expect bibtex-dialect :to-equal 'aaa))))
++ ;;(it "doesn't set the BibTeX dialect globally"
++ ;; (with-temp-buffer
++ ;; (bibtex-mode)
++ ;; (let ((bibtex-dialect 'aaa))
++ ;; (biblio-format-bibtex (concat "@techreport{" stallman-bibtex))
++ ;; (expect bibtex-dialect :to-equal 'aaa))))
+ (it "uses font-lock-ensure when available"
+ (unless (functionp #'font-lock-ensure)
+ (let ((called-p t))
diff --git a/app-emacs/biblio/metadata.xml b/app-emacs/biblio/metadata.xml
new file mode 100644
index 000000000000..d53736a0d6a5
--- /dev/null
+++ b/app-emacs/biblio/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ biblio.el makes it easy to browse and gather bibliographic references and
+ publications from various sources, by keywords or by DOI. References are
+ automatically fetched from well-curated sources, and formatted as BibTeX.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/cpitclaudel/biblio.el/issues/</bugs-to>
+ <remote-id type="github">cpitclaudel/biblio.el</remote-id>
+ </upstream>
+</pkgmetadata>