summaryrefslogtreecommitdiff
path: root/app-emacs/atomic-chrome
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/atomic-chrome
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/atomic-chrome')
-rw-r--r--app-emacs/atomic-chrome/Manifest4
-rw-r--r--app-emacs/atomic-chrome/atomic-chrome-2.0.0.ebuild21
-rw-r--r--app-emacs/atomic-chrome/files/50atomic-chrome-gentoo.el5
-rw-r--r--app-emacs/atomic-chrome/metadata.xml20
4 files changed, 50 insertions, 0 deletions
diff --git a/app-emacs/atomic-chrome/Manifest b/app-emacs/atomic-chrome/Manifest
new file mode 100644
index 000000000000..2c9278f67f22
--- /dev/null
+++ b/app-emacs/atomic-chrome/Manifest
@@ -0,0 +1,4 @@
+AUX 50atomic-chrome-gentoo.el 242 BLAKE2B 9a9bbcb4c774ec38f8cbdf322e398ea7b95af3bd31e3e05bac3c928f6714bf995cb86f762831c080cffc28c6e9cbb6dbc1c59d366e700451f2190ef5bc65b0e2 SHA512 67c0f0159e9ab77adde7961cbcf2f87ab5297af472865dc0ea7a6cab5e5c9c1a4af10e40dada3fe2535b5e79248414423724dd3db13cbf7fae5b0ddc6f2a339d
+DIST atomic-chrome-2.0.0.tar.gz 218286 BLAKE2B db75055df1d337d6f5adfb1dcbef0f9976da38d50bcff96dd5e94993cca84c837d05432c27cab7b3b7bfc14c8a960d667e7c852eda4732f9209f8b72c9a3a191 SHA512 702c8e80246f47dd46f4c864412e47c7cb74a13737754ccf81053a5054b97c4f48c4ca7613d1734dbf7251fbcd1d15269e2a605c36b3e7b631613506bb3a49bc
+EBUILD atomic-chrome-2.0.0.ebuild 498 BLAKE2B 264aa0c308137b5fb93c80ff7cce87f27e58c4a41f5076a36a7cf85266070bd672f76290ae2d198147cefa045a7280550a4d43457fdd0499304ccfc01fc2f3fe SHA512 735fe443394c4a391f59cb9e0243a482d21cc394d5409ede37d466dece2d1b5ecd901836e7cb947c6eb9e2063d8dac0ef20f8b11d38ac7b7710c2f842579027a
+MISC metadata.xml 771 BLAKE2B d5f62dba0ee9e826601ce476015f846818ce3a4131310ce64e823b15a859b3e10fa7d34b1c904ec304e474c2ab818affb4726140e5dec72765aca88bf5993a2c SHA512 f073b3284ac6de2416fbdd822d6727c5844dc7a4b09475ebbbcc0435c719673150e0420204f9ee5fc7b4b58f272a1549f8c89a406fba4d00b8058bceaf657dfe
diff --git a/app-emacs/atomic-chrome/atomic-chrome-2.0.0.ebuild b/app-emacs/atomic-chrome/atomic-chrome-2.0.0.ebuild
new file mode 100644
index 000000000000..7bcf414202fa
--- /dev/null
+++ b/app-emacs/atomic-chrome/atomic-chrome-2.0.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+NEED_EMACS=25
+
+inherit elisp
+
+DESCRIPTION="Edit text area on Chrome with Emacs using Atomic Chrome"
+HOMEPAGE="https://github.com/alpha22jp/atomic-chrome"
+SRC_URI="https://github.com/alpha22jp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-emacs/websocket"
+RDEPEND="${DEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+DOCS="README.md"
diff --git a/app-emacs/atomic-chrome/files/50atomic-chrome-gentoo.el b/app-emacs/atomic-chrome/files/50atomic-chrome-gentoo.el
new file mode 100644
index 000000000000..82777a793c51
--- /dev/null
+++ b/app-emacs/atomic-chrome/files/50atomic-chrome-gentoo.el
@@ -0,0 +1,5 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'atomic-chrome-start-server "atomic-chrome"
+ "Start websocket server for atomic-chrome." t)
+(autoload 'atomic-chrome-stop-server "atomic-chrome"
+ "Stop websocket server for atomic-chrome." t)
diff --git a/app-emacs/atomic-chrome/metadata.xml b/app-emacs/atomic-chrome/metadata.xml
new file mode 100644
index 000000000000..b4c726410afd
--- /dev/null
+++ b/app-emacs/atomic-chrome/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<longdescription>
+ This is the Emacs version of Atomic Chrome which is an extension
+ for the Google Chrome browser that allows you to edit text areas
+ of the browser in Emacs. The input on Emacs is reflected to the
+ browser instantly and continuously. You can use both the browser
+ and Emacs at the same time. They are updated to the same content
+ bi-directionally.
+
+ Atomic Chrome for Emacs is also compatible with Firefox via the
+ GhostText browser extension.
+</longdescription>
+<stabilize-allarches/>
+</pkgmetadata>