summaryrefslogtreecommitdiff
path: root/app-emacs/atomic-chrome
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-11-20 18:45:28 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-11-20 18:45:28 +0000
commit796cae72cf9ed18ba01256ac1f83a686a2a76036 (patch)
tree5ca737a2562d8c0a09fcfacd81d1f9004df37b00 /app-emacs/atomic-chrome
parent20d8e9cfb95a9f054d654ab6405e848807186aa0 (diff)
gentoo resync : 20.11.2017
Diffstat (limited to 'app-emacs/atomic-chrome')
-rw-r--r--app-emacs/atomic-chrome/Manifest4
-rw-r--r--app-emacs/atomic-chrome/atomic-chrome-2.0.0.ebuild21
-rw-r--r--app-emacs/atomic-chrome/files/50atomic-chrome-gentoo.el5
-rw-r--r--app-emacs/atomic-chrome/metadata.xml19
4 files changed, 49 insertions, 0 deletions
diff --git a/app-emacs/atomic-chrome/Manifest b/app-emacs/atomic-chrome/Manifest
new file mode 100644
index 000000000000..14cee2f2756e
--- /dev/null
+++ b/app-emacs/atomic-chrome/Manifest
@@ -0,0 +1,4 @@
+AUX 50atomic-chrome-gentoo.el 242 SHA256 adc125167fa2fcfc5d3e85407aba40fd06e3ec8c86637225f4a067edcde2ed3c SHA512 67c0f0159e9ab77adde7961cbcf2f87ab5297af472865dc0ea7a6cab5e5c9c1a4af10e40dada3fe2535b5e79248414423724dd3db13cbf7fae5b0ddc6f2a339d WHIRLPOOL ffda69b5febcfb0d0b084bf4a0d4d01ed6d82899034b4ce4a2434b3d6e253dbfbfc2aa98de1754fbd9db7beddec30edf4a7a2b066252f616d761ef6b4db5b984
+DIST atomic-chrome-2.0.0.tar.gz 218286 SHA256 f239fabd2438df8d947b333453534e6ab76f946c8879df2e3f1151baf76dac97 SHA512 702c8e80246f47dd46f4c864412e47c7cb74a13737754ccf81053a5054b97c4f48c4ca7613d1734dbf7251fbcd1d15269e2a605c36b3e7b631613506bb3a49bc WHIRLPOOL b6167c4299f0de6c56a1e68c2dfa7389d7c40dbc2e7820830c16eb02c29038e3eca7ed4aae6d2701e7fa41f02ebe88fda3948b4effbfbc6d89c779cce67d1613
+EBUILD atomic-chrome-2.0.0.ebuild 498 SHA256 537b1eb1bf1d154e14ff9bb1c00d6bfc4d97f68d467dc379cb195342da669e9e SHA512 735fe443394c4a391f59cb9e0243a482d21cc394d5409ede37d466dece2d1b5ecd901836e7cb947c6eb9e2063d8dac0ef20f8b11d38ac7b7710c2f842579027a WHIRLPOOL 66bbbe2c5bd6f4b3727b52adadeb131eba5eae3fd1b426046b40d166baade4b2c5206e2c5b84b8a08e1d3aea48d00990175264f596bd827d7042fa2ac38db821
+MISC metadata.xml 748 SHA256 42f2eb55b247330bf313c0959ea9448119cc6534164ce60669d279944339c69e SHA512 d59ec4bbbc4b2eb483a0c3a25c367b8935d8986d9071265df52d782e38fc66ec19362283f430421359fa6b783ea60900e599b6d8184a330dbec96bb65b2b39c7 WHIRLPOOL 8afd458876e30f23b857545782449f84953245122b8a15f6022c65084f2b12717b35be30dbbc028ef4f7de79422603fa2eebef990a1fd10ea360604074ca7a85
diff --git a/app-emacs/atomic-chrome/atomic-chrome-2.0.0.ebuild b/app-emacs/atomic-chrome/atomic-chrome-2.0.0.ebuild
new file mode 100644
index 000000000000..7bcf414202fa
--- /dev/null
+++ b/app-emacs/atomic-chrome/atomic-chrome-2.0.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+NEED_EMACS=25
+
+inherit elisp
+
+DESCRIPTION="Edit text area on Chrome with Emacs using Atomic Chrome"
+HOMEPAGE="https://github.com/alpha22jp/atomic-chrome"
+SRC_URI="https://github.com/alpha22jp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-emacs/websocket"
+RDEPEND="${DEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+DOCS="README.md"
diff --git a/app-emacs/atomic-chrome/files/50atomic-chrome-gentoo.el b/app-emacs/atomic-chrome/files/50atomic-chrome-gentoo.el
new file mode 100644
index 000000000000..82777a793c51
--- /dev/null
+++ b/app-emacs/atomic-chrome/files/50atomic-chrome-gentoo.el
@@ -0,0 +1,5 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'atomic-chrome-start-server "atomic-chrome"
+ "Start websocket server for atomic-chrome." t)
+(autoload 'atomic-chrome-stop-server "atomic-chrome"
+ "Stop websocket server for atomic-chrome." t)
diff --git a/app-emacs/atomic-chrome/metadata.xml b/app-emacs/atomic-chrome/metadata.xml
new file mode 100644
index 000000000000..07d473bfadb0
--- /dev/null
+++ b/app-emacs/atomic-chrome/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<longdescription>
+ This is the Emacs version of Atomic Chrome which is an extension
+ for the Google Chrome browser that allows you to edit text areas
+ of the browser in Emacs. The input on Emacs is reflected to the
+ browser instantly and continuously. You can use both the browser
+ and Emacs at the same time. They are updated to the same content
+ bi-directionally.
+
+ Atomic Chrome for Emacs is also compatible with Firefox via the
+ GhostText browser extension.
+</longdescription>
+</pkgmetadata>