summaryrefslogtreecommitdiff
path: root/app-emacs/async
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-07 11:18:59 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-07 11:18:59 +0100
commita2810985afabcc31d3eace5e61d8ea25b852ba17 (patch)
treed254e77a7aeadd875db2dc73532da78094238ffd /app-emacs/async
parenteab5731cdf11d4ae8cdf111461d46fd96c5bdd37 (diff)
gentoo resync : 07.05.2019
Diffstat (limited to 'app-emacs/async')
-rw-r--r--app-emacs/async/Manifest4
-rw-r--r--app-emacs/async/async-1.9.3.ebuild24
-rw-r--r--app-emacs/async/files/50async-gentoo.el2
-rw-r--r--app-emacs/async/metadata.xml12
4 files changed, 42 insertions, 0 deletions
diff --git a/app-emacs/async/Manifest b/app-emacs/async/Manifest
new file mode 100644
index 000000000000..c0caa36fe035
--- /dev/null
+++ b/app-emacs/async/Manifest
@@ -0,0 +1,4 @@
+AUX 50async-gentoo.el 80 BLAKE2B e6b27662c8c0d0e38785c4268fedec8da7e9fd72b75c7ada413fa878624be04808238db88a4508dadf3e1c5f0c6811cf9d779dd3f86171c5d7d3e55604d98870 SHA512 f4517bccd0bcd8658ddc8b1e8241a1f5dd08176f6f6a6174f7c33200d0cd1cfff2b78f32d60538259348fe872057bd394cbdf98dbdc05248ca7c2d0118250498
+DIST emacs-async-1.9.3.tar.gz 14394 BLAKE2B dd6a98e61027dae2fa9ebb8e20f81a2d2debff1e990e57084a747ea815d1e615dc0e4b8fe5fcdc1f562c0f02780951121f4a67b26584f4519290413da05dc1e9 SHA512 ecbbb6614882df8a58a3440a78867e6cd19ae448e2e897b27d6aeaf5e5a648dcedbac64afbfd6240b7e68c533c685060f453051ef9a85d9d4cca6831fbf2c1dd
+EBUILD async-1.9.3.ebuild 540 BLAKE2B b3a54ca20b47c3a0a020d5630bb50377da86f0bd6ea49bf337c3baf89f2bdbb87e6a9ea3240d577ab2feb218c3bbb1ae2762a20138155e68c665544febf90f4b SHA512 bbab62267b9773b89e95b4736e24abd66369104e62242e27188fe27fb177e3d3015f02d39b253223d914308f8bc8d351eca70d80398725d8b319bae07b350d04
+MISC metadata.xml 365 BLAKE2B 4d19cda635f63d214412a7899961f818ad84f7218e8eb352401bee31367ae468b6c759771b94118edfcf7aa7cdd3902433d726dd427474ff087c00c5be6c1052 SHA512 df4c069fa6f9679e639e4d894f985d5297ea322ee48c5058f861e7d706ce14dda9a306ebcff79aada23e12ff2bb22e209f24021efb2dc4f06be43cf66e64a7f0
diff --git a/app-emacs/async/async-1.9.3.ebuild b/app-emacs/async/async-1.9.3.ebuild
new file mode 100644
index 000000000000..c59fc3c4339d
--- /dev/null
+++ b/app-emacs/async/async-1.9.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp
+
+MY_P="emacs-async-${PV}"
+DESCRIPTION="Simple library for asynchronous processing in Emacs"
+HOMEPAGE="https://github.com/jwiegley/emacs-async"
+SRC_URI="https://github.com/jwiegley/emacs-async/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${MY_P}"
+SITEFILE="50${PN}-gentoo.el"
+DOCS="README.md"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}
diff --git a/app-emacs/async/files/50async-gentoo.el b/app-emacs/async/files/50async-gentoo.el
new file mode 100644
index 000000000000..538bd0c8d452
--- /dev/null
+++ b/app-emacs/async/files/50async-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "@SITELISP@/async-autoloads" nil t)
diff --git a/app-emacs/async/metadata.xml b/app-emacs/async/metadata.xml
new file mode 100644
index 000000000000..0b9a819893e6
--- /dev/null
+++ b/app-emacs/async/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<stabilize-allarches/>
+<upstream>
+ <remote-id type="github">jwiegley/emacs-async</remote-id>
+</upstream>
+</pkgmetadata>