summaryrefslogtreecommitdiff
path: root/app-emacs/assess/assess-0.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-29 22:40:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-29 22:40:34 +0100
commita984494e5a73cca4db8adb6b670fbd04c3af955f (patch)
tree42fb126a10dcdf0eb3b706f55c19374398ea43c3 /app-emacs/assess/assess-0.6.ebuild
parent303f772eff7a30f470d9fb207d69b6a1207b8cab (diff)
gentoo auto-resync : 29:07:2023 - 22:40:34
Diffstat (limited to 'app-emacs/assess/assess-0.6.ebuild')
-rw-r--r--app-emacs/assess/assess-0.6.ebuild18
1 files changed, 13 insertions, 5 deletions
diff --git a/app-emacs/assess/assess-0.6.ebuild b/app-emacs/assess/assess-0.6.ebuild
index 6d09c2dc615c..95c83fa6db65 100644
--- a/app-emacs/assess/assess-0.6.ebuild
+++ b/app-emacs/assess/assess-0.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -7,10 +7,17 @@ inherit elisp
DESCRIPTION="Test support functions for Emacs"
HOMEPAGE="https://github.com/phillord/assess/"
-SRC_URI="https://github.com/phillord/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/phillord/${PN}.git"
+else
+ SRC_URI="https://github.com/phillord/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
LICENSE="GPL-3+"
-KEYWORDS="~amd64 ~x86"
SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"
@@ -23,8 +30,9 @@ BDEPEND="
DOCS=( README.md )
-# Remove a test helper accessing the network, luckily unnecessary
-ELISP_REMOVE="test/local-sandbox.el"
+# Remove tests failing with Emacs >=29.
+# Remove a test helper accessing the network, luckily unnecessary.
+ELISP_REMOVE="test/assess-robot-test.el test/local-sandbox.el"
SITEFILE="50${PN}-gentoo.el"
src_test() {