summaryrefslogtreecommitdiff
path: root/app-emacs/assess/assess-0.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /app-emacs/assess/assess-0.6.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'app-emacs/assess/assess-0.6.ebuild')
-rw-r--r--app-emacs/assess/assess-0.6.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-emacs/assess/assess-0.6.ebuild b/app-emacs/assess/assess-0.6.ebuild
new file mode 100644
index 000000000000..6d09c2dc615c
--- /dev/null
+++ b/app-emacs/assess/assess-0.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Test support functions for Emacs"
+HOMEPAGE="https://github.com/phillord/assess/"
+SRC_URI="https://github.com/phillord/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="app-emacs/m-buffer"
+BDEPEND="
+ ${RDEPEND}
+ test? ( app-emacs/load-relative )
+"
+
+DOCS=( README.md )
+
+# Remove a test helper accessing the network, luckily unnecessary
+ELISP_REMOVE="test/local-sandbox.el"
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . -L test \
+ -l assess-discover -f assess-discover-run-and-exit-batch || die
+}