summaryrefslogtreecommitdiff
path: root/app-emacs/apheleia
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-08 21:24:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-08 21:24:43 +0000
commit4cf2f7cc6bbea59e8aec44b9508c759cf8bb4adf (patch)
tree839a94b536a4ef1c81281e42bf4be4a80483f24d /app-emacs/apheleia
parent867ef65cd897014478ed65034b1ac3f139289a77 (diff)
gentoo auto-resync : 08:11:2022 - 21:24:43
Diffstat (limited to 'app-emacs/apheleia')
-rw-r--r--app-emacs/apheleia/Manifest4
-rw-r--r--app-emacs/apheleia/apheleia-3.0.ebuild20
-rw-r--r--app-emacs/apheleia/files/50apheleia-gentoo.el7
-rw-r--r--app-emacs/apheleia/metadata.xml20
4 files changed, 51 insertions, 0 deletions
diff --git a/app-emacs/apheleia/Manifest b/app-emacs/apheleia/Manifest
new file mode 100644
index 000000000000..576bbc238c29
--- /dev/null
+++ b/app-emacs/apheleia/Manifest
@@ -0,0 +1,4 @@
+AUX 50apheleia-gentoo.el 387 BLAKE2B a9cc757f9c846a50dad3a4ba7383e5203dd158a6233cd7d9039e2f8bdbf31dd950577244a87165c7965c96bffd442b883b3a8e3e55be560332eeb749d413f4a6 SHA512 72ca9116df3e5e363977fc8d0b559a80fa055ce4ceb8d85b912f67eb705f5fd278454f692d2979ad371a047ba604a67de8aebb16c26871a59cf108a68e67f8b3
+DIST apheleia-3.0.tar.gz 36988 BLAKE2B 49e9231e1cddd73ff353512ac29e6b1491bc2cad0985a12677743acb1514b827c8462e6b40912367472adf9d0be12150541162d3106e8e510650c3d70b0bf598 SHA512 19304feda4d3570e68184639a3969f2102765836324db9e1de958e63cf49614a62672df83c21420df92671217ee05630e0c0e0d57cd5ff75eba50a080f0dfde9
+EBUILD apheleia-3.0.ebuild 466 BLAKE2B 1ff54b6155620e1768e9aa8325c1a77f61519a0886fe527a6a2fb1c7c58633fe31cf224240f94fb109bd18070d08c18abe2e0ab1fb6a3d5a3619071d84c078ef SHA512 5b6fcebdc72fb903256fc9b033f44613917ca2ef8af5afe2a68361f0f87149a58a664ef177c6c7266f2b607353caefef4ca4c760f55d0f7549fd4563ca1efe3b
+MISC metadata.xml 870 BLAKE2B 9eefb192026bcc6839477e5199ff99071952a22f40c6ed6903cadedc585b4f4e1dd05c0da5fe49eab97160838277a071876fdeba23c78f11c8379f1a8a4c5bd0 SHA512 bcfbda9b31eb9826943119405ca2553fe99578e985d4b4c3397955b14cad7613e7115c69ca6dd4cbc3751574c36d46e1c6409f7482d8406ca7b896ece89f04d1
diff --git a/app-emacs/apheleia/apheleia-3.0.ebuild b/app-emacs/apheleia/apheleia-3.0.ebuild
new file mode 100644
index 000000000000..7ba2f55e8c2c
--- /dev/null
+++ b/app-emacs/apheleia/apheleia-3.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26
+
+inherit elisp
+
+DESCRIPTION="Reformat GNU Emacs buffers stably without moving point"
+HOMEPAGE="https://github.com/radian-software/apheleia/"
+SRC_URI="https://github.com/radian-software/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md CHANGELOG.md )
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/apheleia/files/50apheleia-gentoo.el b/app-emacs/apheleia/files/50apheleia-gentoo.el
new file mode 100644
index 000000000000..2076d504530a
--- /dev/null
+++ b/app-emacs/apheleia/files/50apheleia-gentoo.el
@@ -0,0 +1,7 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'apheleia-format-buffer "apheleia"
+ "Run code formatter asynchronously on current buffer, preserving point." t)
+(autoload 'apheleia-global-mode "apheleia"
+ "Global minor mode for reformatting code on save without moving point." t)
+(autoload 'apheleia-mode "apheleia"
+ "Minor mode for reformatting code on save without moving point." t)
diff --git a/app-emacs/apheleia/metadata.xml b/app-emacs/apheleia/metadata.xml
new file mode 100644
index 000000000000..490f5620cf49
--- /dev/null
+++ b/app-emacs/apheleia/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ Apheleia is an Emacs Lisp package which allows you to reformat a buffer
+ without moving point. This solves the usual problem of running a tool like
+ Prettier or Black on before-save-hook, namely that it resets point to the
+ beginning of the buffer. Apheleia maintains the position of point relative
+ to its surrounding text even if the buffer is modified by the reformatting.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/radian-software/apheleia/issues/</bugs-to>
+ <remote-id type="github">radian-software/apheleia</remote-id>
+ </upstream>
+</pkgmetadata>