summaryrefslogtreecommitdiff
path: root/app-emacs/apel
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-12 12:07:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-12 12:07:46 +0100
commit78f20b3ec2b822f4add309f60998356f403cf879 (patch)
treed64d76eeca683d899db2d5cee075f319502c6ade /app-emacs/apel
parent6766ae9a4205bc53227127a1dd518ea601246afe (diff)
gentoo auto-resync : 12:08:2023 - 12:07:45
Diffstat (limited to 'app-emacs/apel')
-rw-r--r--app-emacs/apel/Manifest4
-rw-r--r--app-emacs/apel/apel-10.8_p20220721.ebuild39
-rw-r--r--app-emacs/apel/metadata.xml3
3 files changed, 45 insertions, 1 deletions
diff --git a/app-emacs/apel/Manifest b/app-emacs/apel/Manifest
index ab9e229b88e3..37b0a28954ea 100644
--- a/app-emacs/apel/Manifest
+++ b/app-emacs/apel/Manifest
@@ -1,3 +1,5 @@
DIST apel-10.8_p20201106.tar.gz 69188 BLAKE2B e0107968349fe73325503a61fbc9ada83d657f2ca66a39ae2ea833543277f536d22371e371e17dc4307380e738491e20ec0b7b52a35207f49e37fa65c66f3ab1 SHA512 fb14570d6d4f2346d386ae0012cfb9149ddf9ade8b4dc75507e6cef848d12ef65f80bd7d1dc26815031aee00461d67d4a86fe29e30d5d542756e725425634c77
+DIST apel-10.8_p20220721.tar.gz 69181 BLAKE2B b7c36d4bec2f1a544cbf2e15c5ceb8968912e63dc7c4d68cf14d3f0a2646d7031c1595f8dd3f1e7622f8816a1c1b934b0987275ca4e05bcc3c770443f5db88ad SHA512 4d384cbc7989e1d1db4e4b735474d610e241ec4f551bcde73fa3a9771d1d1094f489bd5de328a9b5b66468bd64b52b3220a261735a646b4ea8818a29b3837be5
EBUILD apel-10.8_p20201106.ebuild 954 BLAKE2B 50012ee3709907f330343f8d998d8bc632334ed56fcdae0795e1818bb1621593783cc2780e2ddb629e14c518ef4214dd840acd8fc0935ab42d67212a618de34d SHA512 7db689a9dfb7fa0846c660fb04f7efa9e91f83e8d154cd3edfeebff5c9ab401b7649838e162267a01728dd2995264ffa134b37156f342c0369838933118cc3b2
-MISC metadata.xml 283 BLAKE2B 81c49021199f71096079a27f9121390fb8c1285c54b9478583ff2d647277fa106ef12456d7097c4be092fc48b514a1adcf855ca0fac911598232ef9eb7f102c0 SHA512 f32b303760addf5d4db8d18bd10fb677353cdfa4c5e545d47804ef756cf5e5a21f8b8efb631b08f802185913ceb98da820e404e06eb03d01fe9ea85c10d1ac13
+EBUILD apel-10.8_p20220721.ebuild 959 BLAKE2B 85a8cd9dd91b9e231a2df081dd364159e77d1d1fbbff268eb87794cd5b0888a61fd5eb977bb0c7c4a68e53ee7875d415487adbe13dea71afb1ac75c3bc364c4b SHA512 31197e2381bf4f6eccad47b5558a26d7f8635c341f5ede900c4b139b1e9626791a2a4c48e93d44b239398eca8dd790ad075c0de620767333a95d3632921d3dd5
+MISC metadata.xml 361 BLAKE2B 3e4c9a8de61a82c7cd446a5cb14a195fc66eabf8e8736f93c89dba313f414530c46bb0e780228659a482b374341ce8f6e720386d409b6c9cb1fa7fe56f37d5c6 SHA512 c8ca0ac2424e63f4177a6909d5dcfa6d854df28fddea2942c7221c887c83cf28062536d774a627aa99a97ab89ab4f9fd677ddf830fb633078e1b12bdbbd850d1
diff --git a/app-emacs/apel/apel-10.8_p20220721.ebuild b/app-emacs/apel/apel-10.8_p20220721.ebuild
new file mode 100644
index 000000000000..fdb9f15cbca4
--- /dev/null
+++ b/app-emacs/apel/apel-10.8_p20220721.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="A Portable Emacs Library is a library for making portable Emacs Lisp programs"
+HOMEPAGE="https://github.com/wanderlust/apel"
+GITHUB_SHA1="82eb2325bd149dc57b43a9ce9402c6c6183e4052"
+SRC_URI="https://github.com/wanderlust/${PN}/archive/${GITHUB_SHA1}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${GITHUB_SHA1}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+SITEFILE="50apel-gentoo.el"
+
+src_prepare() {
+ elisp_src_prepare
+ cat <<-EOF >>APEL-CFG || die
+ (setq APEL_PREFIX "apel")
+ (setq EMU_PREFIX "apel")
+ EOF
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" \
+ LISPDIR="${ED}/${SITELISP}" \
+ VERSION_SPECIFIC_LISPDIR="${ED}/${SITELISP}" \
+ install
+ elisp-make-site-file "${SITEFILE}"
+ dodoc ChangeLog* README*
+}
diff --git a/app-emacs/apel/metadata.xml b/app-emacs/apel/metadata.xml
index 986088003fe1..1d16a90c781d 100644
--- a/app-emacs/apel/metadata.xml
+++ b/app-emacs/apel/metadata.xml
@@ -6,4 +6,7 @@
<name>Gentoo GNU Emacs project</name>
</maintainer>
<stabilize-allarches/>
+<upstream>
+ <remote-id type="github">wanderlust/apel</remote-id>
+</upstream>
</pkgmetadata>