summaryrefslogtreecommitdiff
path: root/app-emacs/all-the-icons
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /app-emacs/all-the-icons
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'app-emacs/all-the-icons')
-rw-r--r--app-emacs/all-the-icons/Manifest6
-rw-r--r--app-emacs/all-the-icons/all-the-icons-5.0.0.ebuild43
-rw-r--r--app-emacs/all-the-icons/all-the-icons-5.0.0_p20220325.ebuild44
-rw-r--r--app-emacs/all-the-icons/files/50all-the-icons-gentoo.el1
-rw-r--r--app-emacs/all-the-icons/metadata.xml13
5 files changed, 107 insertions, 0 deletions
diff --git a/app-emacs/all-the-icons/Manifest b/app-emacs/all-the-icons/Manifest
new file mode 100644
index 000000000000..48838605efd5
--- /dev/null
+++ b/app-emacs/all-the-icons/Manifest
@@ -0,0 +1,6 @@
+AUX 50all-the-icons-gentoo.el 38 BLAKE2B e96c6cf48d1522d89450e11d339c76210c672377208b56951791b83c6ef22b2c872d313084e199dd5d7b533a99106a87dbc7f15b5ee6126f71bf5f2e84165ffa SHA512 5c00bcabe2d7cc03013dc7a54b2c653940c08098ca5646d7c73624cb1ca04376ae9dcf88a7166b1925c69f0c5d192d90f6bd790fdef8ed8c3b0f9d163c987da5
+DIST all-the-icons-5.0.0.tar.gz 805496 BLAKE2B c5d81d2ff534bb7ab0000c21fb32107f307d96b1bf09b9227be5900e8160b133cfdc7ea4d4b31a982abb55e29bcf35626af91e3bd9ecbfba00b9b5ed85496a7f SHA512 865db191900dbeb207220df8d91220179dfbbb37e983e9e306ba0a4be576055002beb7335de20327736e8be678056699e8385aa37de766fadc11f4688f99471e
+DIST all-the-icons-5.0.0_p20220325.tar.gz 806105 BLAKE2B bc035ee726bf1d2f9839231ddd3bbaaca93b76c30026a3fcef4579f28f7f9677b37fa8b2652e82ae710f23272b56c884cb9454d54d8c2962f20e0fe9cf3c0bdd SHA512 3e45f208b46e7b1b596b6beb41cc11145db49e3e60e7a42593db94000f226e197b30580ba46d490b456f90349e7db2e49027a572b90f32048bcf0e68af9f22bf
+EBUILD all-the-icons-5.0.0.ebuild 1000 BLAKE2B edbb9634122e62a74cc6601465edd5af266705a77f6834afa12fa76c6a42db5636a8d8f26acf46077b60a435111d36a2d7d826e9b1ed2169d8d2043b00b8b58b SHA512 ff270f803578bb075378ee6a9a8bfe7a12d2b2d57855f12273f7d9c222c746e3bf6881ac2c9bf5219721f879886edeed48adab9307b452922f7ad9f6bb69047b
+EBUILD all-the-icons-5.0.0_p20220325.ebuild 1041 BLAKE2B 1bdc607c82776edeb062c0380f954509a910348fff09de1393663a8ccb1d866adb9a326ebe92167e06015ce3d4df9c5675408e9df78608155674524195a0b516 SHA512 29f5d433b13c1c1e7382ec89fd98e4792868003e0718016eebdb60b51f169eb4b9f66ec6d03b895b198af3ad76a61129d8fbc35baa9371b1bdb2092f6a2638c8
+MISC metadata.xml 439 BLAKE2B 29065345d770b5f2725a0a9dfaf2afa77ad082e349b662dca756150c45eefa1b7f022842e5db1efcd8a7d55cde14ddd25f286cb2cc9ce4370fdf9d4a5cf942b3 SHA512 2189e794f2eefda4ac001013c26e91a5631d1cc71aab214b811ef897f94b3c2ea1858b536b18f38211474c87baaf4a2307619744deec577d6e6aa2db1c634458
diff --git a/app-emacs/all-the-icons/all-the-icons-5.0.0.ebuild b/app-emacs/all-the-icons/all-the-icons-5.0.0.ebuild
new file mode 100644
index 000000000000..cb1873d52bb6
--- /dev/null
+++ b/app-emacs/all-the-icons/all-the-icons-5.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.3
+
+inherit elisp readme.gentoo-r1
+
+DESCRIPTION="Various icon fonts propertized for Emacs"
+HOMEPAGE="https://github.com/domtronn/all-the-icons.el/"
+SRC_URI="https://github.com/domtronn/${PN}.el/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}.el-${PV}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( app-emacs/f )"
+
+DOC_CONTENTS="You may need to install the required fonts by executing
+ the \"all-the-icons-install-fonts\" function."
+DOCS=( README.md logo.png )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-compile data/*.el
+}
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} ${BYTECOMPFLAGS} \
+ -L . -L data -L test -l test/all-the-icons-test.el \
+ -f ert-run-tests-batch-and-exit || die "tests failed"
+}
+
+src_install() {
+ elisp_src_install
+ elisp-install ${PN}/data data/*.el{,c}
+}
diff --git a/app-emacs/all-the-icons/all-the-icons-5.0.0_p20220325.ebuild b/app-emacs/all-the-icons/all-the-icons-5.0.0_p20220325.ebuild
new file mode 100644
index 000000000000..cf28205eb9e6
--- /dev/null
+++ b/app-emacs/all-the-icons/all-the-icons-5.0.0_p20220325.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=65c496d3d1d1298345beb9845840067bffb2ffd8
+NEED_EMACS=24.3
+
+inherit elisp readme.gentoo-r1
+
+DESCRIPTION="Various icon fonts propertized for Emacs"
+HOMEPAGE="https://github.com/domtronn/all-the-icons.el/"
+SRC_URI="https://github.com/domtronn/${PN}.el/archive/${H}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}.el-${H}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( app-emacs/f )"
+
+DOC_CONTENTS="You may need to install the required fonts by executing
+ the \"all-the-icons-install-fonts\" function."
+DOCS=( README.md logo.png )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-compile data/*.el
+}
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} ${BYTECOMPFLAGS} \
+ -L . -L data -L test -l test/all-the-icons-test.el \
+ -f ert-run-tests-batch-and-exit || die "tests failed"
+}
+
+src_install() {
+ elisp_src_install
+ elisp-install ${PN}/data data/*.el{,c}
+}
diff --git a/app-emacs/all-the-icons/files/50all-the-icons-gentoo.el b/app-emacs/all-the-icons/files/50all-the-icons-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/all-the-icons/files/50all-the-icons-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/all-the-icons/metadata.xml b/app-emacs/all-the-icons/metadata.xml
new file mode 100644
index 000000000000..05396e7cc8b6
--- /dev/null
+++ b/app-emacs/all-the-icons/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/domtronn/all-the-icons.el/issues/</bugs-to>
+ <remote-id type="github">domtronn/all-the-icons.el</remote-id>
+ </upstream>
+</pkgmetadata>