summaryrefslogtreecommitdiff
path: root/app-editors
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-01 19:24:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-01 19:24:10 +0100
commitb052fbf151106a4f47cac7fdf0ffff983decb773 (patch)
tree5d21279a4eeaf4076caee87654b610a0fe8a4051 /app-editors
parentc3b55a6be7da027d97d8aef00ef88c3011121a42 (diff)
gentoo auto-resync : 01:09:2022 - 19:24:10
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/Manifest.gzbin13938 -> 14100 bytes
-rw-r--r--app-editors/hyx/Manifest4
-rw-r--r--app-editors/hyx/files/hyx-ldflags.patch27
-rw-r--r--app-editors/hyx/hyx-2021.06.09.ebuild27
-rw-r--r--app-editors/hyx/metadata.xml12
-rw-r--r--app-editors/vscodium/Manifest4
-rw-r--r--app-editors/vscodium/vscodium-1.70.1.22229.ebuild2
-rw-r--r--app-editors/vscodium/vscodium-1.70.2.22230.ebuild2
-rw-r--r--app-editors/xemacs/Manifest1
-rw-r--r--app-editors/xemacs/xemacs-21.5.34-r8.ebuild260
10 files changed, 74 insertions, 265 deletions
diff --git a/app-editors/Manifest.gz b/app-editors/Manifest.gz
index 5dad200b6d3a..3573c7e91541 100644
--- a/app-editors/Manifest.gz
+++ b/app-editors/Manifest.gz
Binary files differ
diff --git a/app-editors/hyx/Manifest b/app-editors/hyx/Manifest
new file mode 100644
index 000000000000..01f3390d3726
--- /dev/null
+++ b/app-editors/hyx/Manifest
@@ -0,0 +1,4 @@
+AUX hyx-ldflags.patch 1013 BLAKE2B 829d0597ea4bddcbd0ed289aef1e92f667ffaf88bb57a82491c2ca0baae200cba1dd3d0c244d2e9e74bf82d4bb08e0db3252d9e3c7259e487d3e89c82ef00e62 SHA512 7ad16481d50940755422b473d8e52c03f44a14c4c369fe9c36c46a17180cfc3f4c567392d6f5328ba6491c86dff529b7d5db40ffb1100e84c0738c1e9b694faf
+DIST hyx-2021.06.09.tar.xz 13864 BLAKE2B 2c97364e1ae185e7dd63fdfb452637cb68b8ab0d76d0009ce515d6f0fe709d38b910f86dfa465ac6843c88feb997dfdc3c736e21bb0b4265a39440c054f75251 SHA512 43f990e29ce097f8e2378a4511a3097e2576fd72e16f3b5c81688702487c8715e7189cb4a368e344c5440a90a1c759d2f76e7831ab401fa814f7e5ff7e145bd8
+EBUILD hyx-2021.06.09.ebuild 520 BLAKE2B 6be22257eb4711d4e94c5693130686975f488d911fe5a2886b8c1e8305292a0b0797ee8c726875ed61e72f1e9e20bd7a4ff99f296d8af959b9ff71282faee2e0 SHA512 8a73e784b412d79a9d1d236fbec1c577da376676002592c3d560c98e06c3f0d7450aa469ff51213e8c4e071e28c229ad8cdca9513c2dd7264f6b6f7b33ee309e
+MISC metadata.xml 411 BLAKE2B 065732e0003a64a4d9357f4e4a1165fe2fe8816fef95b006aab0409614e4e2c52e0aec9a2b7df22f22b828d5d0cf583a201f39b2197cb7104afcad49c68b6e64 SHA512 1c8ae48ab439e36b4c5e1bbbb1fec9f8113eafb0fde2a994ee64e9272b2209ec073a86ee15083d640d8cc8aafa4b1d9d289719fe77e0a87424314f02f74f7034
diff --git a/app-editors/hyx/files/hyx-ldflags.patch b/app-editors/hyx/files/hyx-ldflags.patch
new file mode 100644
index 000000000000..714e76a795db
--- /dev/null
+++ b/app-editors/hyx/files/hyx-ldflags.patch
@@ -0,0 +1,27 @@
+diff -Naur hyx-2021.06.09.org/Makefile hyx-2021.06.09/Makefile
+--- hyx-2021.06.09.org/Makefile 2021-06-09 18:09:18.000000000 +0200
++++ hyx-2021.06.09/Makefile 2022-08-31 08:20:27.711819466 +0200
+@@ -1,18 +1,19 @@
+
+ all: CFLAGS ?= -O2 -Wl,-s \
+- -Wl,-z,relro,-z,now -fpic -pie -D_FORTIFY_SOURCE=2 -fstack-protector-all
+-all: CFLAGS += -std=c99 -pedantic -Wall -Wextra -DNDEBUG
++ -std=c99 -pedantic -Wall -Wextra -DNDEBUG
++all: LDFLAGS ?= -Wl,-z,relro,-z,now -fpic -pie -D_FORTIFY_SOURCE=2 -fstack-protector-all
+ all: hyx
+
+ debug: CFLAGS ?= -O0 -g \
+ -fsanitize=undefined \
+- -Wl,-z,relro,-z,now -fpic -pie -fstack-protector-all
+-debug: CFLAGS += -std=c99 -pedantic -Wall -Wextra -Werror
++ -std=c99 -pedantic -Wall -Wextra -Werror
++debug: LDFLAGS ?= -Wl,-z,relro,-z,now -fpic -pie -fstack-protector-all
+ debug: hyx
+
+ hyx: *.h *.c
+ $(CC) \
+ $(CFLAGS) \
++ $(LDFLAGS) \
+ hyx.c common.c blob.c history.c view.c input.c \
+ -o hyx
+
diff --git a/app-editors/hyx/hyx-2021.06.09.ebuild b/app-editors/hyx/hyx-2021.06.09.ebuild
new file mode 100644
index 000000000000..d185af4b0b5f
--- /dev/null
+++ b/app-editors/hyx/hyx-2021.06.09.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A minimalistic console hex editor with vim-like controls"
+HOMEPAGE="https://yx7.cc/code/"
+SRC_URI="https://yx7.cc/code/hyx/${P}.tar.xz"
+
+LICENSE="MIT-with-advertising"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+ # Avoid complaining about not respecting LDFLAGS
+ "${FILESDIR}/${PN}-ldflags.patch"
+)
+
+src_compile() {
+ CC=$(tc-getCC) emake
+}
+
+src_install() {
+ dobin hyx
+}
diff --git a/app-editors/hyx/metadata.xml b/app-editors/hyx/metadata.xml
new file mode 100644
index 000000000000..daba394f5855
--- /dev/null
+++ b/app-editors/hyx/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>mario.haustein@hrz.tu-chemnitz.de</email>
+ <name>Mario Haustein</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-editors/vscodium/Manifest b/app-editors/vscodium/Manifest
index f115336a2a43..24cfc1a9fc7a 100644
--- a/app-editors/vscodium/Manifest
+++ b/app-editors/vscodium/Manifest
@@ -8,6 +8,6 @@ DIST vscodium-1.70.1.22229-arm64.tar.gz 117342125 BLAKE2B c924b7b9af67613d61ae7a
DIST vscodium-1.70.2.22230-amd64.tar.gz 119462089 BLAKE2B 85bbf6638cea72e66b795e4fe33b8fa2815bc05d1feb98d549e6999b09fe4b0f4b1718423b35714e35724c4645a4136df529d7e43a8be83c810ac156b63a52fb SHA512 0830645e671bb9ebdef7c7abba5c3cdf934468621bfe2537ccd10fba64c1278fde381373fe0fc99484dfd9c382b72298695d5d89702414705c29ed270a41a3f4
DIST vscodium-1.70.2.22230-arm.tar.gz 101302938 BLAKE2B c062a33ed58b3d322266ae0ce9825c3aa126f5f8feff4e9c53dc5fc5fcb94b43ec61c0b9cd814f222c74426740734b7570e88c7d54bc11e9bcfd12b0cc761186 SHA512 dea101d8ef45912ee5fd39cb57e90dba9079bc466ddcd8828fcf91ac1d2f792e158d72592a3a657a328e2f4130bfd80e5b084c5457ba32221adee1045f07fdc9
DIST vscodium-1.70.2.22230-arm64.tar.gz 117323455 BLAKE2B 9e2706c5e99f2ed0343ac8b036d519f8adef56c5cd9f8bd219a80cd6d20c49b6d62a4e31d283329daa6147462d6ef526a9f86faaaf017f6a903e7a7a9b392256 SHA512 ed766d2e15e70ae639bb9f42d4877a6f2c0f4984f1a8693c895452b4043dd00a617f5b3739941bd3142332a677cb569383156c7a20d35a072e3177eb5a3457a0
-EBUILD vscodium-1.70.1.22229.ebuild 3015 BLAKE2B 3ed691411f9b21af21d22e20d6ee2c666cf27e2645b0424331d8c85181166acc6e937cbbc0dc3fe6f894d017f1399786f5f49a387fd45ecf6d38b61b62f5f488 SHA512 dfb471155ea94bd9fc842df3ef3a8bd60216d361ad6a5a1ff49b47850696966304b5c93ba48ea1c3a9d2474a91cb2f0c901e439da5a1d8f547aec690084ac1f6
-EBUILD vscodium-1.70.2.22230.ebuild 3015 BLAKE2B 3ed691411f9b21af21d22e20d6ee2c666cf27e2645b0424331d8c85181166acc6e937cbbc0dc3fe6f894d017f1399786f5f49a387fd45ecf6d38b61b62f5f488 SHA512 dfb471155ea94bd9fc842df3ef3a8bd60216d361ad6a5a1ff49b47850696966304b5c93ba48ea1c3a9d2474a91cb2f0c901e439da5a1d8f547aec690084ac1f6
+EBUILD vscodium-1.70.1.22229.ebuild 3017 BLAKE2B c0703683185759b5999ee651fb00e93ee6f180a66294a2ce413d2adb118c4a494627dc6b49b0dfbf9c10f7f8bbb853e43d0be2fe3328b8654c83665b91573f54 SHA512 7679546c57f2a6c300b0df096d7a7345ff8b201b65f8eeae192dca1a7882f758d4d9aa613b0750958ffa3d445036000a434345df52fe4bfe565582ab2d51189a
+EBUILD vscodium-1.70.2.22230.ebuild 3017 BLAKE2B c0703683185759b5999ee651fb00e93ee6f180a66294a2ce413d2adb118c4a494627dc6b49b0dfbf9c10f7f8bbb853e43d0be2fe3328b8654c83665b91573f54 SHA512 7679546c57f2a6c300b0df096d7a7345ff8b201b65f8eeae192dca1a7882f758d4d9aa613b0750958ffa3d445036000a434345df52fe4bfe565582ab2d51189a
MISC metadata.xml 1302 BLAKE2B ff0c1f72c2394f21e13b89831493df562ca15114fa5006262f794d3f2580deaad01d7e01f87481dcc75cc5044c8b4950955dcc3dbecbc8cfc7a6ceafaf078fb6 SHA512 8ec965d8544c2ab31e3c2f2f3c879b084126880603681fef5e5158af1bc1f2f79351b68284f6a101d486893f968594e1537df1eedeacdebffdf51de7a38ccb25
diff --git a/app-editors/vscodium/vscodium-1.70.1.22229.ebuild b/app-editors/vscodium/vscodium-1.70.1.22229.ebuild
index 033c0854f7c0..e3d7747e9b16 100644
--- a/app-editors/vscodium/vscodium-1.70.1.22229.ebuild
+++ b/app-editors/vscodium/vscodium-1.70.1.22229.ebuild
@@ -89,7 +89,7 @@ src_install() {
rm "${S}/resources/app/LICENSE.txt" || die
# Disable update server
- sed -i "/updateUrl/d" ${S}/resources/app/product.json || die
+ sed -i "/updateUrl/d" "${S}"/resources/app/product.json || die
# Install
pax-mark m codium
diff --git a/app-editors/vscodium/vscodium-1.70.2.22230.ebuild b/app-editors/vscodium/vscodium-1.70.2.22230.ebuild
index 033c0854f7c0..e3d7747e9b16 100644
--- a/app-editors/vscodium/vscodium-1.70.2.22230.ebuild
+++ b/app-editors/vscodium/vscodium-1.70.2.22230.ebuild
@@ -89,7 +89,7 @@ src_install() {
rm "${S}/resources/app/LICENSE.txt" || die
# Disable update server
- sed -i "/updateUrl/d" ${S}/resources/app/product.json || die
+ sed -i "/updateUrl/d" "${S}"/resources/app/product.json || die
# Install
pax-mark m codium
diff --git a/app-editors/xemacs/Manifest b/app-editors/xemacs/Manifest
index 202973b683e0..7dc8f0044d2c 100644
--- a/app-editors/xemacs/Manifest
+++ b/app-editors/xemacs/Manifest
@@ -22,6 +22,5 @@ DIST xemacs-21.5.34.tar.gz 15816932 BLAKE2B e3be282717b91308c94d3d4bee74527d0b31
EBUILD xemacs-21.4.24-r5.ebuild 7114 BLAKE2B 051a221c2973c4d54741e89ecd3152cc95b65ac63318099c98c73c16ce5ba43dc940331371ee88c79af6023c7c9ac8a4720d99483e5ce91688d0858a302a5fa7 SHA512 fefe0fb6d1c3f9ff66a50acdbe0e2c9769df01b5447a8e25fd9243733da728d16c9ac5d54539d40c0a0dc83cdc5c3e949d661c7c9b6c9aabe63cbbf78ff8f287
EBUILD xemacs-21.4.24-r7.ebuild 7142 BLAKE2B 3a8a98f947d1a177f631521ad394e0d5efcb5c53108a4c912a599aa72a5684261ba45472460c6e5cfc4bc10f4c041409bbefc840cdef3630082a3e344daabe5d SHA512 d7154cbf4cb769d3eca13a76bc423225fb2a383c59c172e72ea9b032db68a09d9bef9f5780dbcacacaa191ec2c6da017679a6e4d7daf4883bd4722d6cdfc1296
EBUILD xemacs-21.5.34-r10.ebuild 7399 BLAKE2B a8afa73fc7ad48aa5140daf1af6e66502928771e8a4d1c5f989823b3d4614dc3e28c8b6ef57424d40822b6ddf6fa8032fd934cfef1595080d48cd43dfebd0320 SHA512 faea36d2b00eb13b075c49f390061209858a95a4343a135c0afff2a29eb87d162130bfbfb734ec8d35da9a18277f81433d0fd829880455c05b521548f2f64a89
-EBUILD xemacs-21.5.34-r8.ebuild 7339 BLAKE2B be0b1d94b9ab0e113c14d9563b82a4feb2c9fd7601597269efa608df7eba950b03dc6f5502c5b439962eac2fedd953285f4a45d7f212e5e34147a7530b66e4a8 SHA512 e44fcec4cf5eee02f3800c153f35295454f0d8c3f10cda3d30245518e7199f997908333a1d7f9f37ca79dd2264bd397b06cfac89e6be7f6ab0113beff7ae824f
EBUILD xemacs-21.5.9999.ebuild 7227 BLAKE2B 7f5a194f23a7cd06029ad061d493e829fed6ef4f088a5711125b14fc5d103d909bd2681c88ebb5b73773ef68e6e1675e00dd2b943df8f11cfc0c2ea70726a964 SHA512 ca7b3ff6b186fdbae86ee7011d4918590daaf5ff29a8d6e492a241fece2342f3c3dee18e1d1a52c8913fe885ded056b3060bacc20f753f01d230c59c58848e3c
MISC metadata.xml 683 BLAKE2B 060e4f7830a96404813a550debecf83c2de3993183d41638362ed01a3a6240bdd33a83c0db5e31a2f2e821046fb1c15199688271c27611689aac1bdf02bcde14 SHA512 176625d3c972766aaecd10125e69b4cdcbedff958b842b2ac2b6a39d728ec868b3311ef13f6854122063810c5125f48d73cd1e68083de5ddf3ef85f7f2b09cdc
diff --git a/app-editors/xemacs/xemacs-21.5.34-r8.ebuild b/app-editors/xemacs/xemacs-21.5.34-r8.ebuild
deleted file mode 100644
index 61aff25cd403..000000000000
--- a/app-editors/xemacs/xemacs-21.5.34-r8.ebuild
+++ /dev/null
@@ -1,260 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# Note: xemacs currently does not work with position independent code
-# so the build forces the use of the -no-pie option
-
-EAPI=7
-
-inherit autotools flag-o-matic xdg-utils desktop
-
-DESCRIPTION="highly customizable open source text editor and application development system"
-HOMEPAGE="https://www.xemacs.org/"
-SRC_URI="http://ftp.xemacs.org/xemacs-21.5/${P}.tar.gz
- http://www.malfunction.de/afterstep/files/NeXT_XEmacs.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ppc ~ppc64 -riscv ~sparc ~x86"
-IUSE="alsa debug eolconv gif gpm pop postgres ldap xface nas dnd X jpeg tiff png mule motif freewnn xft xim athena neXt Xaw3d gdbm berkdb"
-
-X_DEPEND="x11-libs/libXt x11-libs/libXmu x11-libs/libXext x11-misc/xbitmaps"
-
-RDEPEND="
- berkdb? ( >=sys-libs/db-4:= !!<sys-libs/db-4 )
- gdbm? ( >=sys-libs/gdbm-1.8.3:=[berkdb(+)] )
- >=sys-libs/zlib-1.1.4
- >=dev-libs/openssl-0.9.6:0=
- >=media-libs/audiofile-0.2.3
- gpm? ( >=sys-libs/gpm-1.19.6 )
- postgres? ( dev-db/postgresql:= )
- ldap? ( net-nds/openldap:= )
- alsa? ( media-libs/alsa-lib )
- nas? ( media-libs/nas )
- X? ( $X_DEPEND !Xaw3d? ( !neXt? ( x11-libs/libXaw ) ) )
- dnd? ( x11-libs/dnd )
- motif? ( >=x11-libs/motif-2.3:0[xft=] )
- athena? ( x11-libs/libXaw )
- Xaw3d? ( x11-libs/libXaw3d )
- xft? ( media-libs/freetype:2 x11-libs/libXft x11-libs/libXrender >=media-libs/fontconfig-2.5.0 )
- neXt? ( x11-libs/neXtaw )
- xface? ( media-libs/compface )
- tiff? ( media-libs/tiff:0 )
- png? ( >=media-libs/libpng-1.2:0 )
- jpeg? ( media-libs/libjpeg-turbo:0= )
- freewnn? ( app-i18n/freewnn )
- >=sys-libs/ncurses-5.2:=
- >=app-eselect/eselect-emacs-1.15"
-
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-PDEPEND="app-xemacs/xemacs-base
- mule? ( app-xemacs/mule-base )"
-
-src_unpack() {
- default_src_unpack
-
- use neXt && unpack NeXT_XEmacs.tar.gz
-}
-
-src_prepare() {
- use neXt && cp "${WORKDIR}"/NeXT.XEmacs/xemacs-icons/* "${S}"/etc/toolbar/
- find "${S}"/lisp -name '*.elc' -exec rm {} \; || die
- eapply "${FILESDIR}/${P}-ncurses-tinfo.patch"
- eapply "${FILESDIR}/${P}-gcc5.patch"
- eapply "${FILESDIR}/${P}-glibc-macro.patch"
- eapply "${FILESDIR}/${P}-as-needed.patch"
- eapply "${FILESDIR}/${P}-configure-libc-version.patch"
- eapply "${FILESDIR}/${P}-ar.patch"
- eapply "${FILESDIR}/${P}-strsignal.patch"
- eapply "${FILESDIR}/${P}-process-test-qa.patch"
-
- eapply_user
-
- # Some binaries and man pages are installed under suffixed names
- # to avoid collions with their GNU Emacs counterparts (see below).
- # Fix internal filename references.
- sed -i -e 's/exec gnuclient/&-xemacs/' lib-src/gnudoit || die
- sed -i -e '/^\.so/s/etags/&-xemacs/' etc/ctags.1 || die
- sed -i -e '/^\.so/s/gnuserv/&-xemacs/' etc/gnu{client,doit,attach}.1 || die
-}
-
-src_configure() {
- local myconf=""
-
- # bug #639642
- test-flags -no-pie >/dev/null && append-flags -no-pie
- filter-flags -pie
-
- if use X; then
-
- myconf="${myconf} --with-widgets=athena"
- myconf="${myconf} --with-dialogs=athena"
- myconf="${myconf} --with-menubars=lucid"
- myconf="${myconf} --with-scrollbars=lucid"
- if use motif ; then
- myconf="--with-widgets=motif"
- myconf="${myconf} --with-dialogs=motif"
- myconf="${myconf} --with-scrollbars=motif"
- myconf="${myconf} --with-menubars=lucid"
- fi
- if use athena or use Xaw3d ; then
- myconf="--with-scrollbars=athena"
- fi
-
- if use Xaw3d; then
- myconf="${myconf} --with-athena=3d"
- elif use neXt; then
- myconf="${myconf} --with-athena=next"
- else
- myconf="${myconf} --with-athena=xaw"
- fi
-
- use dnd && myconf="${myconf} --with-dragndrop --with-offix"
-
- myconf="${myconf} $(use_with tiff )"
- myconf="${myconf} $(use_with png )"
- myconf="${myconf} $(use_with jpeg )"
- myconf="${myconf} $(use_with xface )"
-
- use xft && myconf="${myconf} --with-xft=emacs,tabs,menubars,gauges" ||
- myconf="${myconf} --with-xft=no"
-
- else
- myconf="${myconf}
- --without-x
- --without-xpm
- --without-dragndrop
- --with-xft=no
- --with-gif=no"
- fi
-
- if use mule ; then
- myconf="${myconf} --with-mule"
-
- if use xim ; then
- if use motif ; then
- myconf="${myconf} --with-xim=motif"
- else
- myconf="${myconf} --with-xim=xlib"
- fi
- else
- myconf="${myconf} --with-xim=no"
- fi
-
- myconf="${myconf} $(use_with freewnn wnn )"
- fi
-
- # This determines the type of sounds we are playing
- local soundconf="native"
-
- # This determines how these sounds should be played
- use nas && soundconf="${soundconf},nas"
- use alsa && soundconf="${soundconf},alsa"
-
- myconf="${myconf} --with-sound=${soundconf}"
-
- if use gdbm || use berkdb ; then
- use gdbm && mydb="gdbm"
- use berkdb && mydb="${mydb},berkdb"
-
- myconf="${myconf} --with-database=${mydb}"
- else
- myconf="${myconf} --without-database"
- fi
-
- use debug && myconf="${myconf} --with-debug" ||
- myconf="${myconf} --with-optimization"
-
- econf ${myconf} \
- $(use_with gif ) \
- $(use_with gpm ) \
- $(use_with postgres postgresql ) \
- $(use_with ldap ) \
- $(use_with eolconv file-coding ) \
- $(use_with pop ) \
- --prefix=/usr \
- --without-canna \
- --with-ncurses \
- --with-msw=no \
- --with-mail-locking=flock \
- --with-site-lisp=yes \
- --with-site-modules=yes \
- --with-newgc \
- --with-system-malloc \
- --enable-option-checking=no \
- --with-last-packages=/usr/lib/xemacs
-}
-
-src_compile() {
- emake EMACSLOADPATH="${S}"/lisp
-}
-
-src_install() {
- emake prefix="${ED}"/usr \
- mandir="${ED}"/usr/share/man/man1 \
- infodir="${ED}"/usr/share/info \
- libdir="${ED}"/usr/$(get_libdir) \
- datadir="${ED}"/usr/share \
- install
-
- # Rename some applications installed in bin so that it is clear
- # which application installed them and so that conflicting
- # packages (emacs) can't clobber the actual applications.
- # Addresses bug #62991.
- for i in b2m ctags etags gnuclient gnudoit gnuattach; do
- mv "${ED}"/usr/bin/${i} "${ED}"/usr/bin/${i}-xemacs || die "mv ${i} failed"
- done
-
- # rename man pages
- for i in ctags etags gnuserv gnuclient gnudoit gnuattach; do
- mv "${ED}"/usr/share/man/man1/${i}{,-xemacs}.1 || die "mv ${i}.1 failed"
- done
-
- # install base packages directories
- dodir /usr/lib/xemacs/xemacs-packages/
- dodir /usr/lib/xemacs/site-packages/
- dodir /usr/lib/xemacs/site-modules/
- dodir /usr/lib/xemacs/site-lisp/
-
- if use mule;
- then
- dodir /usr/lib/xemacs/mule-packages
- fi
-
- # remove extraneous info files
- cd "${ED}"/usr/share/info
- rm -f dir info.info texinfo* termcap* standards*
-
- cd "${S}"
- dodoc CHANGES-* ChangeLog INSTALL Installation PROBLEMS README*
-
- newicon "${S}"/etc/${PN}-icon.xpm ${PN}.xpm
-
- domenu "${FILESDIR}"/${PN}.desktop
-}
-
-pkg_postinst() {
- eselect emacs update ifunset
- eselect gnuclient update ifunset
- xdg_desktop_database_update
-
- einfo "If you are upgrading from XEmacs 21.4 you should note the following"
- einfo "incompatibilities:"
- einfo "- Mule-UCS is no longer supported due to proper UTF-8 support in XEmacs 21.5"
- einfo "- The X resource class has changed from Emacs to XEmacs,"
- einfo " settings in your .Xdefaults file should be updated accordingly."
-
- if use xft;
- then
- einfo "You have enabled Xft font support. Xft requires font names to be provided"
- einfo "in a different way, so you may need to adjust your .Xdefaults accordingly."
- fi
-}
-
-pkg_postrm() {
- eselect emacs update ifunset
- eselect gnuclient update ifunset
- xdg_desktop_database_update
-}