summaryrefslogtreecommitdiff
path: root/app-editors
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-22 04:04:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-22 04:04:46 +0100
commita15e8dc7444560123d7d4be1bccb19afd5b611d0 (patch)
tree6e26ee0323c09494a66d0f78c4b81e305bb0d096 /app-editors
parent3dc4de6331223493015f198dc61854af604da86c (diff)
gentoo auto-resync : 22:10:2024 - 04:04:46
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/Manifest.gzbin14143 -> 14133 bytes
-rw-r--r--app-editors/jedit/Manifest2
-rw-r--r--app-editors/jedit/jedit-5.7.0.ebuild136
-rw-r--r--app-editors/mousepad/Manifest2
-rw-r--r--app-editors/mousepad/mousepad-0.6.3.ebuild63
5 files changed, 203 insertions, 0 deletions
diff --git a/app-editors/Manifest.gz b/app-editors/Manifest.gz
index 9e7f9437be94..02fc0cb6e070 100644
--- a/app-editors/Manifest.gz
+++ b/app-editors/Manifest.gz
Binary files differ
diff --git a/app-editors/jedit/Manifest b/app-editors/jedit/Manifest
index f5af5267bf44..25366828d0ac 100644
--- a/app-editors/jedit/Manifest
+++ b/app-editors/jedit/Manifest
@@ -1,4 +1,6 @@
AUX jedit-5.6.0-skip-failing-test.patch 1183 BLAKE2B 0822a2a339b161cd6e66487b4506f7a0467eddae70da60d4e01897d171bd38c5959e5f0e26bf06b44970963743eb6aa2699dbcf381662dd8a290f27a84301fc4 SHA512 5fc6f859ddae3996e022d14b34cadf145a2b736aebeb2982346c2c43674817b8fee298291a318036a831e19b61c97f49ca013aa0afb7d83587e0975f6ff1bd6c
DIST jedit5.6.0source.tar.bz2 2572329 BLAKE2B d9815feef6fb03cb4a15e7101383944776ca593884de6965aaa3e74a411f8915d0542ab62be8e4551e04dd410c1da4ebedfb8a2c2869d33eb205100d6bd84352 SHA512 89e65998ea49b5b3da4f1daad001d7cf763e196e7110b604e99e3fad038ca126cf108a471ee611ef76b5491b91d618f47cdc24b270cabccb6a80858a37720af7
+DIST jedit5.7.0source.tar.bz2 2633539 BLAKE2B f8f0ee0b8c568ab64b9812049601c6692f60346bf8f70217fd82f27daedcdfdc95f8157adeca38ba36bd7c9e3d7a29bed2506f951e3e0b0ade1cd9a53a89e669 SHA512 6f5ab4b7f4fe467400686ac9100c462b8c40912036e0a5735ec5dbece569b0eb36f8ac1d9a0d93065baafc48da4e0a00b7440c31584ca1835f164b31b2400625
EBUILD jedit-5.6.0-r1.ebuild 3353 BLAKE2B b9136a0d5cc57abf302edb07c4b5db9bea16c634ca80a92550b6a2c970fb4e7464bb8eb58ee7c38b39a8d8620c2b2d2f84fe96973e06665f5ad5aa2229ea6374 SHA512 359555e68ac11662c034a65a98da3efbaf52b2a03097fb500ad897f9037ed140625259b12bf51fcd671721029107c28c3231e266538d45f46cd3c0ef80f823e2
+EBUILD jedit-5.7.0.ebuild 3392 BLAKE2B 519d794b8b3461d75e258a9b4d26f1f4449e94ab66960158f8ae947caada01b4739f75d8649140f72dfdeeb6d81a1275cf608322bb33e5d0ae117de87bf1fba8 SHA512 9bdd300b7c4e8300e2338a134993cef8cd63de2bd8152add18950ab6a0bb4166ca2e1191c9a9c818c4b579f5ed1d6673cb442fec5c7ecf3bce0c68e3d441d040
MISC metadata.xml 312 BLAKE2B 32456a81e027512746733dea293a638db960ecebb97e045e82bef5630ac064d59ee5b880ade0513d15619c49c52686b9b2e5b69c7e270c578a506465a40d5db3 SHA512 90c844a5041ab91cacc279bc0a404d42c188311bd71cd643d52dc8f586e4fca101d09236407e6a3701ef18816d5f01ad2194f5446d47c6670aaa1a33edada63b
diff --git a/app-editors/jedit/jedit-5.7.0.ebuild b/app-editors/jedit/jedit-5.7.0.ebuild
new file mode 100644
index 000000000000..98656ecd09d4
--- /dev/null
+++ b/app-editors/jedit/jedit-5.7.0.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source test"
+JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit desktop java-pkg-2 java-pkg-simple xdg-utils
+
+DESCRIPTION="Programmer's editor written in Java"
+HOMEPAGE="https://www.jedit.org"
+SRC_URI="https://downloads.sourceforge.net/project/jedit/jedit/${PV}/jedit${PV}source.tar.bz2"
+S="${WORKDIR}/jEdit"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+BDEPEND="
+ app-text/docbook-xsl-stylesheets:0
+ dev-libs/libxslt:0
+"
+
+CP_DEPEND="dev-java/jsr305:0"
+
+DEPEND="
+ ${CP_DEPEND}
+ >=virtual/jdk-11:*
+ test? (
+ dev-java/hamcrest:0
+ dev-java/junit:5
+ dev-java/mockito:2
+ )
+"
+
+RDEPEND="
+ ${CP_DEPEND}
+ >=virtual/jre-11:*
+"
+
+PATCHES=( "${FILESDIR}/jedit-5.6.0-skip-failing-test.patch" )
+
+JAVA_MAIN_CLASS="org.gjt.sp.jedit.jEdit"
+JAVA_RESOURCE_DIRS="resources"
+JAVA_SRC_DIR="src"
+JAVA_TEST_GENTOO_CLASSPATH="
+ hamcrest
+ junit-4
+ junit-5
+ mockito-2
+"
+JAVA_TEST_SRC_DIR="test"
+JEDIT_HOME="/usr/share/${PN}/lib"
+
+src_prepare() {
+ default #780585
+ java-pkg-2_src_prepare
+ mkdir -v src resources || die
+ find org doclet -type f -name '*.java' \
+ | xargs cp --parent -t "${JAVA_SRC_DIR}" || die
+ find org -type f \
+ ! -name '*.java' \
+ ! -name 'package.html' \
+ ! -name 'README.html' \
+ ! -name 'jedit.manifest' \
+ ! -name 'Reflect.last' \
+ ! -name 'bsh.jj*' \
+ ! -name '*.scripted' \
+ | xargs cp --parent -t "${JAVA_RESOURCE_DIRS}" || die
+
+ einfo "Creating the docs"
+ mv doc/{FAQ,whatsnew} . || die
+ mkdir doc/{FAQ,whatsnew} || die
+ # build.xml 734-804
+ xsltproc \
+ -xinclude \
+ -o doc/FAQ/ \
+ doc/jedithtml.xsl \
+ FAQ/faq.xml || die
+ xsltproc \
+ -o doc/whatsnew/ \
+ doc/jedithtml.xsl \
+ whatsnew/news.xml || die
+
+ einfo "Creating users-guide"
+ ln -s /usr/share/sgml/docbook/ . || die
+ # This is the part which does not work with xmlto. So we use xsltproc.
+ # TODO:
+ # Try "XIncludes with Xalan and Xerces" according to
+ # http://www.sagehill.net/docbookxsl/Xinclude.html#d0e40343
+ xsltproc \
+ -xinclude \
+ -o doc/users-guide/users-guide.html \
+ docbook/xsl-stylesheets/html/docbook.xsl \
+ doc/jedithtml.xsl \
+ doc/users-guide/users-guide.xml || die
+ # Cleanup. The xml files were processed and need not get installed.
+ rm doc/users-guide/*.xml || die
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ # The application wants all this stuff in /usr/share/jedit/lib/
+ # Using java-pkg_dolauncher with --pwd cannot solve it.
+ # If we change the location the application fails to start:
+ # "System keymap folder do not exist, your installation is broken."
+ cp -R jars doc keymaps macros modes properties startup \
+ "${D}${JEDIT_HOME}" || die
+
+ make_desktop_entry "${PN}" jEdit \
+ "${JEDIT_HOME}/doc/${PN}.png" \
+ "Development;Utility;TextEditor"
+
+ # keep the plugin directory
+ keepdir "${JEDIT_HOME}/jars"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ elog "The system directory for jEdit plugins is"
+ elog "${JEDIT_HOME}/jars"
+ elog "If you get plugin related errors on startup, first try updating them."
+}
+
+pkg_postrm() {
+ if [[ -z ${REPLACED_BY_VERSION} ]]; then
+ xdg_desktop_database_update
+ elog "jEdit plugins installed into /usr/share/jedit/jars"
+ elog "(after installation of jEdit itself) haven't been"
+ elog "removed. To get rid of jEdit completely, you may"
+ elog "want to run"
+ elog ""
+ elog " rm -r ${JEDIT_HOME}"
+ fi
+}
diff --git a/app-editors/mousepad/Manifest b/app-editors/mousepad/Manifest
index 21fec814146b..0b7df5fa778d 100644
--- a/app-editors/mousepad/Manifest
+++ b/app-editors/mousepad/Manifest
@@ -1,3 +1,5 @@
DIST mousepad-0.6.2.tar.bz2 1402314 BLAKE2B c783ec58317ca3c0eaa0023ade3043f4aa4f020a12c0258fe0cf1e2303aa07dfbc67b9aa0178ca9282da98754103fda6c90ba034fa4057dd855b400c0d371085 SHA512 086f60f6f405290ed76366f4c5195e9c8f9c5058d1892200a73e48d6378428efe47f2038e3eddb81186e22dd87d57580559a556b1b22f202b6f056c7f90b64ea
+DIST mousepad-0.6.3.tar.bz2 1428583 BLAKE2B 73a0eb0cfecaa88c6d3508034561206ff1a24139bbdea4cb677ec79de30a59386cf7beb7fd540d31c0a3ec4804ba2001b13470baf0bbec19dc4cf1cc315479ee SHA512 a47e9c0d5b039444ee455e80d0ab4642d5c29d6e5632ec4fccfcef061b4bf40a1709ea73b092b02e915e1796d1593ede68e59b9fe373e127302d34f82c9beae3
EBUILD mousepad-0.6.2.ebuild 1260 BLAKE2B 63cd9db299c6a28506cf4bab78caace6efed665a7429d7a963364947dcec2c2e08d6e531360f4a859e179e137c0c29466864056cbe78204133bedc4928ae8125 SHA512 615adcfad923c131c3bec885a44d4b808b24f9dd24c99d13f5bd9110fb4ef44d7a3c258a2b2dd36d8b18fec6993ad8184a52fae82f4bb1691c9c607b29b70ca0
+EBUILD mousepad-0.6.3.ebuild 1266 BLAKE2B 692be2075715cc67eb39c60d313a20e8cc2b40da1d27eeabe2002d00358b01afed9752bf3f0a55b84e9c50636c72f777568b15f418b6d0e43e6aaefaeeafedb6 SHA512 3402e9da0211c1e2b29b5c7f3ab0faac0e38240503e53cf5694d53589d44b491727a59c354c21284eba4dd546ca6578a6a1a93f8fd1cd6b4953097e8b4c8aab2
MISC metadata.xml 318 BLAKE2B 53e8d0080a2643b6d5191012a6c86316d926678a85190371ce498705fc142f83d1a325a935a75f8f29c19c878a677ba96a35d5e8702a23c4f1e7ec210dbeef3e SHA512 89a0b309c4a205b97627be6c0d3fb1a280d9c4dfd2107c09854ef6a912e38e0dc2da39e0768d5103b81b72bf84eed7b1014084c52ff9482f4acc13e8d1a3def3
diff --git a/app-editors/mousepad/mousepad-0.6.3.ebuild b/app-editors/mousepad/mousepad-0.6.3.ebuild
new file mode 100644
index 000000000000..9ee8b38d6546
--- /dev/null
+++ b/app-editors/mousepad/mousepad-0.6.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2-utils xdg-utils
+
+DESCRIPTION="GTK+-based editor for the Xfce Desktop Environment"
+HOMEPAGE="
+ https://docs.xfce.org/apps/mousepad/start
+ https://gitlab.xfce.org/apps/mousepad/
+"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="policykit spell +shortcuts"
+
+DEPEND="
+ >=dev-libs/glib-2.56.2
+ >=x11-libs/gtk+-3.22:3
+ >=x11-libs/gtksourceview-4.0.0:4
+ policykit? ( sys-auth/polkit )
+ spell? ( app-text/gspell )
+ shortcuts? ( >=xfce-base/libxfce4ui-4.17.5:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ --enable-gtksourceview4
+ $(use_enable policykit polkit)
+ $(use_enable spell plugin-gspell)
+ $(use_enable shortcuts plugin-shortcuts)
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}