summaryrefslogtreecommitdiff
path: root/app-editors
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-26 00:31:47 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-26 00:31:47 +0000
commit8d35656b4a4e3a2ad6f87abb36b9fc3987d95a53 (patch)
tree464a1d53f3b0ad7cc1432e5b298a7ff78458527f /app-editors
parent85e7fcfe5631986ad1144ea54fc179d8658571d3 (diff)
gentoo auto-resync : 26:03:2025 - 00:31:47
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/Manifest.gzbin13936 -> 13938 bytes
-rw-r--r--app-editors/mousepad/Manifest2
-rw-r--r--app-editors/mousepad/mousepad-0.6.4.ebuild56
-rw-r--r--app-editors/retext/Manifest6
-rw-r--r--app-editors/retext/retext-8.0.2-r1.ebuild (renamed from app-editors/retext/retext-8.0.2.ebuild)3
-rw-r--r--app-editors/retext/retext-8.1.0.ebuild70
-rw-r--r--app-editors/retext/retext-9999.ebuild5
-rw-r--r--app-editors/texworks/Manifest7
-rw-r--r--app-editors/texworks/files/texworks-0.6.10-cmake_lua_version.patch13
-rw-r--r--app-editors/texworks/files/texworks-0.6.5-cmake_lua_version.patch11
-rw-r--r--app-editors/texworks/files/texworks-0.6.8-optional-qtscript.patch25
-rw-r--r--app-editors/texworks/texworks-0.6.10.ebuild (renamed from app-editors/texworks/texworks-0.6.8.ebuild)39
12 files changed, 169 insertions, 68 deletions
diff --git a/app-editors/Manifest.gz b/app-editors/Manifest.gz
index 68aeab759eba..78f4e814de88 100644
--- a/app-editors/Manifest.gz
+++ b/app-editors/Manifest.gz
Binary files differ
diff --git a/app-editors/mousepad/Manifest b/app-editors/mousepad/Manifest
index 4ca6498e0e46..de94f874afb3 100644
--- a/app-editors/mousepad/Manifest
+++ b/app-editors/mousepad/Manifest
@@ -1,3 +1,5 @@
DIST mousepad-0.6.3.tar.bz2 1428583 BLAKE2B 73a0eb0cfecaa88c6d3508034561206ff1a24139bbdea4cb677ec79de30a59386cf7beb7fd540d31c0a3ec4804ba2001b13470baf0bbec19dc4cf1cc315479ee SHA512 a47e9c0d5b039444ee455e80d0ab4642d5c29d6e5632ec4fccfcef061b4bf40a1709ea73b092b02e915e1796d1593ede68e59b9fe373e127302d34f82c9beae3
+DIST mousepad-0.6.4.tar.xz 461356 BLAKE2B 1c1c8d4faebc31655186008592321a53606d880b483543ded47994b802d6e4d94e63ae12066d3f1d0649869d5fd52da2a44682d811bc9cc74c100308e38a82df SHA512 3b118a881d89502f74224ddb45121e7e0b3f771ed4f609f4567c9bbaf04757b31de8c02cbbebcb22d69c7e588f53a3c0b88c145aace3061b9a08c7ce5ae6352c
EBUILD mousepad-0.6.3.ebuild 1260 BLAKE2B 63cd9db299c6a28506cf4bab78caace6efed665a7429d7a963364947dcec2c2e08d6e531360f4a859e179e137c0c29466864056cbe78204133bedc4928ae8125 SHA512 615adcfad923c131c3bec885a44d4b808b24f9dd24c99d13f5bd9110fb4ef44d7a3c258a2b2dd36d8b18fec6993ad8184a52fae82f4bb1691c9c607b29b70ca0
+EBUILD mousepad-0.6.4.ebuild 1199 BLAKE2B d3ce9c61cb897ab75097c312234773e7e9d64640d9c412d76ead99b674f6e85ee1d7734025dd83323c880f785106e46aec1e8def96f1c67c09b5c35eb525ce4d SHA512 a4a777a18792d87e2ee89a6612a1ba5ddd860fad9ca0b89c6e87bead77eb6faf771b3f3be51f8166d2836c7231104e5b115a9912c938f8ae24a57987b93ade72
MISC metadata.xml 318 BLAKE2B 53e8d0080a2643b6d5191012a6c86316d926678a85190371ce498705fc142f83d1a325a935a75f8f29c19c878a677ba96a35d5e8702a23c4f1e7ec210dbeef3e SHA512 89a0b309c4a205b97627be6c0d3fb1a280d9c4dfd2107c09854ef6a912e38e0dc2da39e0768d5103b81b72bf84eed7b1014084c52ff9482f4acc13e8d1a3def3
diff --git a/app-editors/mousepad/mousepad-0.6.4.ebuild b/app-editors/mousepad/mousepad-0.6.4.ebuild
new file mode 100644
index 000000000000..667064df03a7
--- /dev/null
+++ b/app-editors/mousepad/mousepad-0.6.4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2-utils meson xdg-utils
+
+DESCRIPTION="GTK+-based editor for the Xfce Desktop Environment"
+HOMEPAGE="
+ https://docs.xfce.org/apps/mousepad/start
+ https://gitlab.xfce.org/apps/mousepad/
+"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="policykit spell +shortcuts"
+
+DEPEND="
+ >=dev-libs/glib-2.56.2
+ >=x11-libs/gtk+-3.22.0:3
+ >=x11-libs/gtksourceview-4.0.0:4
+ policykit? ( >=sys-auth/polkit-0.102 )
+ spell? ( >=app-text/gspell-1.6.0 )
+ shortcuts? ( >=xfce-base/libxfce4ui-4.17.5:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dgtksourceview4=enabled
+ $(meson_feature policykit polkit)
+ $(meson_feature spell gspell-plugin)
+ $(meson_feature shortcuts shortcuts-plugin)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
diff --git a/app-editors/retext/Manifest b/app-editors/retext/Manifest
index 8c6bfc4cb53c..d297a4abc3ef 100644
--- a/app-editors/retext/Manifest
+++ b/app-editors/retext/Manifest
@@ -1,4 +1,6 @@
DIST ReText-8.0.2.tar.gz 546236 BLAKE2B 3ef28366e5884234d77b2155c3f01d7881206383aa19ccb010255eb40ea14aa2ab298fe212d2b4d0e7d65246075b426c93a8ae518b8fb5f0887f1694064e309a SHA512 c7b543d91290c007c820751f39c009c1e5fb86eb59590d0c13610c9c7f13b6023ffee3d6aebc4665addacbefad0d17937a29e8201d08457cc1641a6d5c0019b0
-EBUILD retext-8.0.2.ebuild 1635 BLAKE2B e71831b212176a0506096f670e02d97d2ff9de75a5499421872594fe661a4e9512b791d242443860a7f4e971c84d2b7c76e91778f6c910accc684d059e27990f SHA512 69b06c0712b58aa0267ef67f8e2a341329447be1c89ae4f96fae1c7c91d566d717b53a4063b39f77fc83667fdc372e48840979a532f6a816aa99aec0c1b89577
-EBUILD retext-9999.ebuild 1624 BLAKE2B 8fa44eb057243b8c671c40a18d54f2712723fcdb3c3380f492cb7851efa59d202f0af1879ea648fc08ce8a30dff1a63699b3f8b13315c2f8ce081f6f9b462202 SHA512 43f3b78c29f86d6c7ceb827df2f577ad3ce46d93a5347430931eab12603a94331feece8467a49e70b8812afb37f3cde272c30f65b64a03273ef65a51f67d6652
+DIST retext-8.1.0.tar.gz 569692 BLAKE2B 0481414eddb40c158ad9e68d4ec6d43a702a458ee43ee5441477d3dcf29f1df7fdb120b7538af4c7e47bef095e8cb685633369e44f66b6c797caefbf81673a68 SHA512 d4bdb39608b9cd74773255a95c940060b79fe578b045d00b1224d49a94f45e4ffcf8163fc3e9778b92509b7fe425a59d444054814dc2c5f70998dc865b7c7f8d
+EBUILD retext-8.0.2-r1.ebuild 1687 BLAKE2B 29ed3437a1866d4e269fed1ebc61f42c7484bfc324f6ea368ed6b20d225f7a5aec03d93e9c5337ea970034e9bf5e202cfeb26e9e0a8bfe6149c57a4d5885ee2c SHA512 819682a0d8fe966cc74bbf376c867c4bcbb6bae58679e46cde8bb2ab63d4086626b8d7dcb2858be27a3acd4dda098aa9cb740fbc9c002d875df7e7fcf25e97ef
+EBUILD retext-8.1.0.ebuild 1688 BLAKE2B cd3feeb47ab796b0fcb7f0d366dd0cc3688d703d2983dbb54fbae321909afe714b089a93ee5baa23729c7c086b70d729f8c7b9f6bfe5a25f27afa5900baaa025 SHA512 1ed0a09f17614548514d52e25acedabcc30eadd2688f1394facc48e08b878ee619818ebb7c9d51a488ae29afbfab00fbf9f8a8b6604ccedfa8ea03c3da83271a
+EBUILD retext-9999.ebuild 1676 BLAKE2B 6d822488049310755224246169e6f5e5c829da9b1b85230958867bea96a23df2e10c16c23e90934b08f77576b5fb931c000006e3ace4e494c4797bbce21729d8 SHA512 5e2973a9ff83d69f661e77a2cf152bd66adfef8f8ecdc3b2f08e97a2997549e615952332a1ab6c568f807b8c5f9c2cc21710be03a397003adf779617cbd083af
MISC metadata.xml 535 BLAKE2B 94fbf92941c956601e9ec037a78919fcbddb572baa20f74c0daae31e438e44d214b57926cfa6d31eb176b8be72d2078e44686bada4a4794e130956c7d91b5865 SHA512 5ed97d1ed19c618b1246375d02860f96ce7f58aa759c467ae69e35d6b003cdac44f5c59f166ae6970e9a082e783550381b34540ad1ba03d661a3f3fde7d26dec
diff --git a/app-editors/retext/retext-8.0.2.ebuild b/app-editors/retext/retext-8.0.2-r1.ebuild
index 64610d093a31..6a627d297556 100644
--- a/app-editors/retext/retext-8.0.2.ebuild
+++ b/app-editors/retext/retext-8.0.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -33,6 +33,7 @@ RDEPEND="
>=dev-python/markups-3.1.1[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]
dev-python/pyqt6[dbus,gui,printsupport,widgets,${PYTHON_USEDEP}]
+ dev-python/python-markdown-math[${PYTHON_USEDEP}]
')
"
# qmake6 from qtbase is used to find lrelease
diff --git a/app-editors/retext/retext-8.1.0.ebuild b/app-editors/retext/retext-8.1.0.ebuild
new file mode 100644
index 000000000000..5356445353f7
--- /dev/null
+++ b/app-editors/retext/retext-8.1.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517="setuptools"
+DISTUTILS_SINGLE_IMPL=1
+PYPI_NO_NORMALIZE=1
+PYPI_PN="retext"
+
+inherit desktop distutils-r1 optfeature virtualx xdg
+
+DESCRIPTION="Simple editor for Markdown and reStructuredText"
+HOMEPAGE="https://github.com/retext-project/retext https://github.com/retext-project/retext/wiki"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/retext-project/retext.git"
+else
+ inherit pypi
+ KEYWORDS="~amd64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ >=dev-python/markups-4.0.0[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pyqt6[dbus,gui,printsupport,widgets,${PYTHON_USEDEP}]
+ dev-python/python-markdown-math[${PYTHON_USEDEP}]
+ ')
+"
+# qmake6 from qtbase is used to find lrelease
+BDEPEND="
+ dev-qt/qtbase:6
+ dev-qt/qttools:6[linguist]
+ test? (
+ ${RDEPEND}
+ $(python_gen_cond_dep '
+ dev-python/pyqt6[testlib,${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+distutils_enable_tests unittest
+
+src_test() {
+ QT_QPA_PLATFORM=minimal virtx distutils-r1_src_test
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ domenu data/me.mitya57.ReText.desktop
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "a local copy of the MathJax JavaScript library" dev-libs/mathjax
+ optfeature "encoding detection" dev-python/chardet
+ optfeature "dictionary support" dev-python/pyenchant
+ optfeature "JavaScript support in preview" dev-python/pyqt6-webengine
+}
diff --git a/app-editors/retext/retext-9999.ebuild b/app-editors/retext/retext-9999.ebuild
index 97456098e4e9..9e884f22405b 100644
--- a/app-editors/retext/retext-9999.ebuild
+++ b/app-editors/retext/retext-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -30,9 +30,10 @@ RDEPEND="
$(python_gen_cond_dep '
dev-python/docutils[${PYTHON_USEDEP}]
dev-python/markdown[${PYTHON_USEDEP}]
- >=dev-python/markups-3.1.1[${PYTHON_USEDEP}]
+ >=dev-python/markups-4.0.0[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]
dev-python/pyqt6[dbus,gui,printsupport,widgets,${PYTHON_USEDEP}]
+ dev-python/python-markdown-math[${PYTHON_USEDEP}]
')
"
# qmake6 from qtbase is used to find lrelease
diff --git a/app-editors/texworks/Manifest b/app-editors/texworks/Manifest
index a5f2fce2cad4..c3982c5c03ac 100644
--- a/app-editors/texworks/Manifest
+++ b/app-editors/texworks/Manifest
@@ -1,5 +1,4 @@
-AUX texworks-0.6.5-cmake_lua_version.patch 219 BLAKE2B c09494099363fa26e4110c23b0e1c06caf44cb0040578bfa33457741fdc8fe4698a2f4000a6dc6da4cd19dca6039c251cd1b875a27dc41abfea03b5cb79c341a SHA512 66ccbbcf313596c674833b36f222c8aa8bde541dfd58a706814aef3eaeec50247bec954a4f7137dfda31df9cd7b15163200592acb8433ed252d961ebf2b9ea32
-AUX texworks-0.6.8-optional-qtscript.patch 1038 BLAKE2B 43f130632a1ea3d815e28b427eacfcfac5967233238d7b2ef271b9288f3c4f9d8492679edfd3a50a585303d02d26ced97ed36c56610223af7bf273ab3212d548 SHA512 badc300f48886c596155f10638c9929ab4093ee63d1efdba760674cef8fbe0c5a91164adca843e7f2957dc05a89d37bad440d527034cf4ea709238aa1a68cef1
-DIST texworks-0.6.8.tar.gz 12486607 BLAKE2B a7de78adc0746c57b721a400a704d3912574933604e01124a99f5a60ba377ba66ce8d57f5f0a87e336de715d981146db6b8ae61a78c744b385c698fcdad2f7fe SHA512 23164f9ab2f611a705b533f4c435891f1279d1e0e0de2d7f947864f8919a6513cb696881dc1dcf93345471599f113d264ced57cbd2dceae343b9dde46ee80482
-EBUILD texworks-0.6.8.ebuild 1806 BLAKE2B 2005ab974b145f91e42d9c1d2386b78ce9fbe7f926c15533f383664d031775ff26cacc0ee694820c4e8a45bafc458b9f24fa38068ec476d6544831bab3a67481 SHA512 1c0e0a2d964c89a61d12e52cf09266d3b76e9775c5e64ecbc168a4ac999bf774cea4d10a8b355ef05b5afcf2dd17ab0c79e3fb6dae1d2a1b40c6036817bc06ca
+AUX texworks-0.6.10-cmake_lua_version.patch 315 BLAKE2B d5f644b53fa2e99b6ebcce762c732f225d830edac77c34f2a6736890ce9a4c0ac2d98282d8011452fe8371f39ba52e4ea76d7cc9237ceb8908f206cccb9f3984 SHA512 75c4344dca24f0ce35711cd871b932fcf1d6527bd78d60c8151f2cb980d642a028c4829188a7f6c23a07849dc55a7b09f694973d659dcfcd871dcac3af570f14
+DIST texworks-0.6.10.tar.gz 11479436 BLAKE2B a6b251068c42d3ff68dfb3e5c69348abc984ace1fa9c25b3b815d22f4294931a67697ebb7abb708709be7333aee90495fdf854dea0b6625963ba35902b6aa7e0 SHA512 3f8ec187b8d6dd5f62c84cb93ac6b8d9369a8b53525518c47504fba0d1353af90d02a4b68eb38e8f623dce2f2cceae33b20917be7793f0e058864ccea7a2f8b6
+EBUILD texworks-0.6.10.ebuild 1687 BLAKE2B 4b73307511fa13e2e7d0481ee0d15db2a9486c008f9fceab86f3d84e825d97975bae076ce5a3cb2d1334dab2ba864885bd8ca8e3b6a97ae69fbaa7cc7bc5d4fe SHA512 7303ed23e05eb48b40bd74776bea49ac61c06d0e27c83d38121d64d7a335cc7d4105d746e759696bdf97ca2cf26043d5b317b1de96e412acfd6ad8ff5056d90a
MISC metadata.xml 250 BLAKE2B d266280ebce0c2bec87a6bcbf96a5224fec494d29b9fecadb21727558fc06ffc3c7455ecc8d43207b112ce4ebd508497d72bc87fd51f22a2240ed71929ac7ff3 SHA512 e3d6e04858fd59423da72e2d8a7f73b71a8bc743918364272f18d736e318c639e4f2029a4a87797518720cac3e0f5e9639157a12ce6d6d15b4d072a548bbad98
diff --git a/app-editors/texworks/files/texworks-0.6.10-cmake_lua_version.patch b/app-editors/texworks/files/texworks-0.6.10-cmake_lua_version.patch
new file mode 100644
index 000000000000..8fbfae4b5e0c
--- /dev/null
+++ b/app-editors/texworks/files/texworks-0.6.10-cmake_lua_version.patch
@@ -0,0 +1,13 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 9682c39..43ddca5 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -321,7 +321,7 @@ SET(TeXworks_LIBS
+ # -------------------------------
+
+ IF ( WITH_LUA )
+- find_package(TwxLua)
++ find_package(Lua ${LUA_VERSION} EXACT REQUIRED)
+ ENDIF()
+
+ IF ( WITH_PYTHON )
diff --git a/app-editors/texworks/files/texworks-0.6.5-cmake_lua_version.patch b/app-editors/texworks/files/texworks-0.6.5-cmake_lua_version.patch
deleted file mode 100644
index 630443d5f119..000000000000
--- a/app-editors/texworks/files/texworks-0.6.5-cmake_lua_version.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -297,7 +297,7 @@
- # -------------------------------
-
- IF ( WITH_LUA )
-- FIND_PACKAGE(Lua)
-+ FIND_PACKAGE(Lua ${LUA_VERSION} EXACT REQUIRED)
- ENDIF()
-
- IF ( WITH_PYTHON )
diff --git a/app-editors/texworks/files/texworks-0.6.8-optional-qtscript.patch b/app-editors/texworks/files/texworks-0.6.8-optional-qtscript.patch
deleted file mode 100644
index 460c4f4f7e2d..000000000000
--- a/app-editors/texworks/files/texworks-0.6.8-optional-qtscript.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-It doesn't work like that.
-
---- a/CMakeLists.txt 2023-02-18 11:42:11.000000000 +0100
-+++ b/CMakeLists.txt 2023-10-21 20:00:29.144638825 +0200
-@@ -281,9 +281,11 @@
- set(QT_VERSION_PATCH "${Qt6_VERSION_PATCH}")
- else ()
- # Check for Qt5
-- find_package(Qt5 REQUIRED COMPONENTS Core Widgets Gui UiTools Concurrent Xml LinguistTools Qml OPTIONAL_COMPONENTS Script ScriptTools)
-+ find_package(Qt5 REQUIRED COMPONENTS Core Widgets Gui UiTools Concurrent Xml LinguistTools Qml)
- set(QT_LIBRARIES Qt5::Core Qt5::Widgets Qt5::Gui Qt5::UiTools Qt5::Concurrent Qt5::Xml Qt5::Qml)
-
-+ find_package(Qt5Script)
-+ find_package(Qt5ScriptTools)
- if (Qt5Script_FOUND AND Qt5ScriptTools_FOUND)
- list(APPEND QT_LIBRARIES Qt5::ScriptTools Qt5::Script)
- set(WITH_QTSCRIPT ON)
-@@ -311,7 +313,6 @@
- set(QT_VERSION_MAJOR "${Qt5_VERSION_MAJOR}")
- set(QT_VERSION_MINOR "${Qt5_VERSION_MINOR}")
- set(QT_VERSION_PATCH "${Qt5_VERSION_PATCH}")
-- set(WITH_QTSCRIPT ON)
- endif ()
-
- # Expose the major version number of Qt to the preprocessor. This is necessary
diff --git a/app-editors/texworks/texworks-0.6.8.ebuild b/app-editors/texworks/texworks-0.6.10.ebuild
index 65ac3d6842d0..2ebc16b7962b 100644
--- a/app-editors/texworks/texworks-0.6.8.ebuild
+++ b/app-editors/texworks/texworks-0.6.10.ebuild
@@ -1,21 +1,21 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-LUA_COMPAT=( lua5-{1..3} )
-PYTHON_COMPAT=( python3_{9..12} )
+LUA_COMPAT=( lua5-{1..4} )
+PYTHON_COMPAT=( python3_{10..13} )
CMAKE_REMOVE_MODULES_LIST=( FindLua )
inherit lua-single python-single-r1 cmake xdg
DESCRIPTION="Simple interface for working with TeX documents"
HOMEPAGE="https://tug.org/texworks/"
SRC_URI="https://github.com/TeXworks/texworks/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}"/${PN}-release-${PV}
+S="${WORKDIR}/${PN}-release-${PV}"
-LICENSE="GPL-2"
+LICENSE="GPL-2+ MIT"
SLOT="0"
-KEYWORDS="amd64 ~riscv x86"
+KEYWORDS="~amd64 ~riscv ~x86"
IUSE="lua python test"
RESTRICT="!test? ( test )"
@@ -26,30 +26,23 @@ REQUIRED_USE="
RDEPEND="
app-text/hunspell:=
- app-text/poppler[qt5]
- dev-qt/designer:5
- dev-qt/qtcore:5
- dev-qt/qtconcurrent:5
- dev-qt/qtdeclarative:5
- dev-qt/qtdbus:5
- dev-qt/qtdeclarative:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
+ app-text/poppler[qt6]
+ dev-qt/qt5compat:6
+ dev-qt/qtbase:6[concurrent,dbus,gui,widgets,xml]
+ dev-qt/qtdeclarative:6
+ dev-qt/qttools:6[widgets]
sys-libs/zlib
lua? ( ${LUA_DEPS} )
python? ( ${PYTHON_DEPS} )
"
-DEPEND="${RDEPEND}
- test? ( dev-qt/qttest:5 )
-"
+DEPEND="${RDEPEND}"
BDEPEND="
- dev-qt/linguist-tools:5
+ dev-qt/qttools:6[linguist]
virtual/pkgconfig
"
PATCHES=(
- "${FILESDIR}"/${PN}-0.6.5-cmake_lua_version.patch
- "${FILESDIR}"/${P}-optional-qtscript.patch
+ "${FILESDIR}"/${PN}-0.6.10-cmake_lua_version.patch
)
pkg_setup() {
@@ -61,8 +54,6 @@ pkg_setup() {
src_configure() {
local mycmakeargs=(
-Wno-dev
- -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Script=ON
- -DCMAKE_DISABLE_FIND_PACKAGE_Qt5ScriptTools=ON
-DPREFER_BUNDLED_SYNCTEX=ON
-DWITH_LUA=$(usex lua)
-DWITH_PYTHON=$(usex python)
@@ -71,6 +62,8 @@ src_configure() {
-DTeXworks_DOCS_DIR="/share/doc/${PF}"
-DQTPDF_VIEWER=ON
-DBUILD_SHARED_PLUGINS=ON
+ -DQT_DEFAULT_MAJOR_VERSION=6
+ -DTW_BUILD_ID="Gentoo official package"
)
use lua && mycmakeargs+=( -DLUA_VERSION="$(lua_get_version)" )