summaryrefslogtreecommitdiff
path: root/app-editors
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-04-04 01:34:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2025-04-04 01:34:29 +0100
commit74dcbf5a63cafe2678e2a397e1002dd691425200 (patch)
tree5e08b1abdce069a7da83f1ca4cbe2ae4af56b161 /app-editors
parent476528d7a16cfe2435b30ebd74783eea6925db5f (diff)
gentoo auto-resync : 04:04:2025 - 01:34:28
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/Manifest.gzbin13935 -> 13939 bytes
-rw-r--r--app-editors/nano/Manifest2
-rw-r--r--app-editors/nano/nano-8.4.ebuild105
3 files changed, 107 insertions, 0 deletions
diff --git a/app-editors/Manifest.gz b/app-editors/Manifest.gz
index 73dfd6bfebda..41c8758d6061 100644
--- a/app-editors/Manifest.gz
+++ b/app-editors/Manifest.gz
Binary files differ
diff --git a/app-editors/nano/Manifest b/app-editors/nano/Manifest
index bbc489ce2b37..c7a6c20a6645 100644
--- a/app-editors/nano/Manifest
+++ b/app-editors/nano/Manifest
@@ -1,5 +1,7 @@
AUX gentoo.nanorc-r1 5197 BLAKE2B c862a068f09266f5961d052725c84223a1c63e542b55ea54e0dc43625a4237a13b991bcb512f3611b13904827124719b6a055c4f8b1f8da0e104c452207df554 SHA512 538206380c2f1a118d7c24d34d1a4282e1ba14bf12145d7e9eab2120e052b3e67213e7a229dc0f8a1b185ff2796939874c7b76819380bddd0660bab4f675029d
DIST nano-8.3.tar.xz 1681216 BLAKE2B 39c400483f79f11da0f959fed769462b65007f9235cb76d38e71d0a63919b659dc553d44f5d13dd13db801ec361fd7a3ad68b68bfa456ac6c169c861e80c6067 SHA512 9f57bb16a30240fdfc8fc31f5a55f681b80dd72de66fa143ef36c59ab696cc672d8fa054f5a4a547324db3deb2fe2f777cd7c1c023b571e2bb36c86a783ff1d6
+DIST nano-8.4.tar.xz 1691256 BLAKE2B 2e5dbe6982ef9d284c6e018abad593bf383f27c85047241bafaa098948b73897c0a81b63aa453385ac93afc1c398936464d5a1fb024d00936ad383c5e5e4403f SHA512 1b8258e341a8722114b24af9d4676fbd8a91dc3639786a81bcd192a7b4fbca87581ab8ebe49493dfb3599ae90b59f4df8ae2a4ee0c0c7ccec9a49b563c82f44a
EBUILD nano-8.3-r1.ebuild 2457 BLAKE2B 62b5d64d291771e021a18f309a75885720ffb42a27a99f85f9859f56456c4df0b9e3e383978ee226323d37064a9d511b01fcb6ec3d23355dc71c415e8bccf2a0 SHA512 fedc647cd39bf5b6f4c6eded457cd14588efadbdeec9457fcca51e36d5a7c6bbca47f7572ab6cc13191c2f1c5def6a5ecec43cd9c664b836476dfffb5838a924
+EBUILD nano-8.4.ebuild 2465 BLAKE2B ba7bcde6ffa5ab4b97ef89500084cf1079b509a736387318b0e807c0dc9137d6cd63360e2265904fb56d599b0fb3fbd6f3a8932ff6de086c8c71094014a1c806 SHA512 e587a3dcc56236d61c1f065b637d6c7d9496b0db8b2d2a56eeb8b040e6f24185fa80726798c80dee52fb6f45b1614460f4842b5fb60a39d9f914e9f9753c9f01
EBUILD nano-9999.ebuild 2465 BLAKE2B b87c97e7c12209670f803dd882e581a1cfbc2fe5cfd4c59f746dd49ca60c9a0ff1d0c9628f83c7c45561ea49a8383e7ff21723cb290b6f3a93d610a107e20bbf SHA512 67a951d28c563a7701f347d65b66c3f39f73f45de38201143575edd69edf87a34f4e5adf65081c2986aa489cd086630297e077d9c1935a2dbcc9f3ffc83c5509
MISC metadata.xml 1580 BLAKE2B 5977013d57a99580adaf6df69a926972f430ceaec8f19f5d6ea060c5b5d066b9ac3e2fd1ca59def8266f39143b35340c6571651c90e5ef7050ec93cb58d588e3 SHA512 1533be592588e8f33c67072d14432cee0267f23d5a67626b21aa6ea8027fdce754fcd7c731645d5af7033c128b5b09af7140e15d8d5dc4e357ffa73a0428a865
diff --git a/app-editors/nano/nano-8.4.ebuild b/app-editors/nano/nano-8.4.ebuild
new file mode 100644
index 000000000000..0bc01680eb56
--- /dev/null
+++ b/app-editors/nano/nano-8.4.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://git.savannah.gnu.org/git/nano.git"
+ inherit autotools git-r3
+else
+ MY_P="${PN}-${PV/_}"
+ SRC_URI="https://www.nano-editor.org/dist/v${PV:0:1}/${MY_P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+fi
+
+DESCRIPTION="GNU GPL'd Pico clone with more functionality"
+HOMEPAGE="https://www.nano-editor.org/ https://wiki.gentoo.org/wiki/Nano/Guide"
+
+LICENSE="GPL-3+ LGPL-2.1+ || ( GPL-3+ FDL-1.2+ )"
+SLOT="0"
+IUSE="debug justify magic minimal ncurses nls +spell unicode"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.9-r1:=[unicode(+)?]
+ magic? ( sys-apps/file )
+ nls? ( virtual/libintl )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig
+"
+
+REQUIRED_USE="
+ magic? ( !minimal )
+"
+
+# gnulib FPs
+QA_CONFIG_IMPL_DECL_SKIP=( unreachable MIN static_assert )
+
+src_prepare() {
+ default
+
+ if [[ ${PV} == 9999 ]] ; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ local myconfargs=(
+ --bindir="${EPREFIX}"/bin
+ --htmldir=/trash
+ $(use_enable !minimal color)
+ $(use_enable !minimal multibuffer)
+ $(use_enable !minimal nanorc)
+ $(use_enable magic libmagic)
+ $(use_enable spell speller)
+ $(use_enable justify)
+ $(use_enable debug)
+ $(use_enable nls)
+ $(use_enable unicode utf8)
+ $(use_enable minimal tiny)
+ )
+
+ econf "${myconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ # Don't use "${ED}" here or things break (#654534)
+ rm -r "${D}"/trash || die
+
+ dodoc doc/sample.nanorc
+ docinto html
+ dodoc doc/faq.html
+ insinto /etc
+ newins doc/sample.nanorc nanorc
+
+ if ! use minimal ; then
+ # Enable colorization by default.
+ sed -i \
+ -e '/^# include /s:# *::' \
+ "${ED}"/etc/nanorc || die
+
+ # Since nano-5.0 these are no longer being "enabled" by default
+ # (bug #736848)
+ local rcdir="/usr/share/nano"
+ mv "${ED}"${rcdir}/extra/* "${ED}"/${rcdir}/ || die
+ rmdir "${ED}"${rcdir}/extra || die
+
+ insinto "${rcdir}"
+ newins "${FILESDIR}/gentoo.nanorc-r1" gentoo.nanorc
+ fi
+}
+
+pkg_postrm() {
+ [[ -n ${REPLACED_BY_VERSION} ]] && return
+
+ local e
+ e=$(unset EDITOR; . "${EROOT}"/etc/profile &>/dev/null; echo "${EDITOR}")
+ if [[ ${e##*/} == nano ]]; then
+ ewarn "The EDITOR variable is still set to ${e}."
+ ewarn "You can update it with \"eselect editor\"."
+ fi
+}