summaryrefslogtreecommitdiff
path: root/app-editors
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-01 01:09:37 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-01 01:09:37 +0100
commit290844d409ace33d948956aec3c542ea6f4a7b13 (patch)
treea1849e2730c9848c11d12aa322070e4e87edb729 /app-editors
parent31459e63971ac3b08706bba949851d93c45043c3 (diff)
gentoo auto-resync : 01:10:2022 - 01:09:37
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/Manifest.gzbin14088 -> 14087 bytes
-rw-r--r--app-editors/pluma/Manifest2
-rw-r--r--app-editors/pluma/pluma-1.26.0.ebuild79
3 files changed, 81 insertions, 0 deletions
diff --git a/app-editors/Manifest.gz b/app-editors/Manifest.gz
index d75d66ed66bb..ce5c52f53b6c 100644
--- a/app-editors/Manifest.gz
+++ b/app-editors/Manifest.gz
Binary files differ
diff --git a/app-editors/pluma/Manifest b/app-editors/pluma/Manifest
index 382d93ab2371..1e22cf58ff64 100644
--- a/app-editors/pluma/Manifest
+++ b/app-editors/pluma/Manifest
@@ -1,3 +1,5 @@
DIST pluma-1.24.2.tar.xz 3745160 BLAKE2B ed855b19f1ab80cb6ef9bc175eea3c2af386b1e45123bc0e3ad93d1964efb4822fe1b3d7490308357fcff96557bb6189f081a467f41a6907e76a1961de8f23d3 SHA512 588640744f8a0bec08d0c51c0309380a57cb6319c98124885e30d05e7dd8488ba7bd5acec1bf21fb0d6832626ae8925b24cd241202265af1a631a91313cdad2b
+DIST pluma-1.26.0.tar.xz 3765056 BLAKE2B 4a3107df7c4ba906d405b5ef3ea6dd9ca0e372a7b00224213fc8a60d1dc26663d1363aa7f0569b0242407f5b5d850386308fae9192c4a33f577295bb55ef5a16 SHA512 a6c0cee7110f4863e44af51b19bb528f0f3570eab8db98038152bf142eedde97ac13b896deff7051b941a0f43c6fe14e316a97eba40fe5d4854d76038450245f
EBUILD pluma-1.24.2.ebuild 1812 BLAKE2B a89aaf8cbc4c30f23469818719e0e11b3fd244c06345829a30aaf158bd91a765cdad65818c1fa96e63a652bb4d7bfd4fb3dcd2d0ee645be8486ed7061aaa9189 SHA512 da059b578bc39e8c2f02b523766f47e84407f9615dfffdf72ba34358d6dbcef0a2028ac1f86a6d0dfebacabda22b3e56cec8afb12808b235ae902481a9737b2f
+EBUILD pluma-1.26.0.ebuild 1858 BLAKE2B 33aeeaed650c5051c45cec94f1340704df980b632031ef4bb33dd3139c0196f276018b5a885b8da170554eef27bf3ce103191a6f15f6f883f093fb10c51b7229 SHA512 ee121a31fd019a9397425a388f0368d56192384182d45ac57696067cebf45dd128f47225c2780607527f7e5cd70169ca72e950b246c416400abe79f8e2270fa6
MISC metadata.xml 335 BLAKE2B 5a43dc64c90fc154ee0cb55c1eba79a20c612836229ee87e1594436db64d3ba5d877897ecfe4e2e1b52b75a8a3c336fe5338b203e9d134d14b531de4ca2c3eb5 SHA512 8a113126ce89a38ce4ec7468a7c45b162572ceb034911624ed9c5227dae4dedf33ffdfae0ace99ed18848b1e30b722e05b0715fe845b4ad0b6998e4d87476548
diff --git a/app-editors/pluma/pluma-1.26.0.ebuild b/app-editors/pluma/pluma-1.26.0.ebuild
new file mode 100644
index 000000000000..cae48f8c333e
--- /dev/null
+++ b/app-editors/pluma/pluma-1.26.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MATE_LA_PUNT="yes"
+PYTHON_COMPAT=( python3_{8..11} )
+inherit mate python-single-r1 virtualx
+
+DESCRIPTION="Pluma text editor for the MATE desktop"
+
+LICENSE="FDL-1.1+ GPL-2+ LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+IUSE="+introspection spell test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ dev-libs/atk
+ >=dev-libs/glib-2.50:2
+ >=dev-libs/libpeas-1.2.0[gtk]
+ >=dev-libs/libxml2-2.5:2
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ >=x11-libs/gtksourceview-4.0.2:4
+ x11-libs/libICE
+ x11-libs/libX11
+ >=x11-libs/libSM-1.0
+ x11-libs/pango
+ introspection? ( >=dev-libs/gobject-introspection-0.9.3:= )
+ spell? (
+ >=app-text/enchant-1.6:=
+ >=app-text/iso-codes-0.35
+ )
+ !!app-editors/mate-text-editor
+"
+RDEPEND="${COMMON_DEPEND}
+ ${PYTHON_DEPS}
+ >=mate-base/mate-desktop-1.9[introspection?]
+ virtual/libintl
+"
+DEPEND="${COMMON_DEPEND}
+ ~app-text/docbook-xml-dtd-4.1.2
+ app-text/yelp-tools
+ dev-util/glib-utils
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=sys-devel/libtool-2.2.6:2
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+MATE_FORCE_AUTORECONF=true
+
+src_prepare() {
+ # Test require gvfs sftp fs mounted and schema's installed. Skip this one.
+ # https://github.com/mate-desktop/mate-text-editor/issues/33
+ sed -e '/+= document-saver/d' -i tests/Makefile.am || die
+
+ mate_src_prepare
+}
+
+src_configure() {
+ mate_src_configure \
+ $(use_enable introspection) \
+ $(use_enable spell) \
+ $(use_enable test tests)
+}
+
+src_test() {
+ # FIXME: This should be handled at eclass level.
+ "${EPREFIX}/${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
+
+ unset DBUS_SESSION_BUS_ADDRESS
+ local -x GSETTINGS_SCHEMA_DIR="${S}/data"
+ virtx emake check
+}