summaryrefslogtreecommitdiff
path: root/app-editors/zile/zile-2.4.15.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /app-editors/zile/zile-2.4.15.ebuild
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'app-editors/zile/zile-2.4.15.ebuild')
-rw-r--r--app-editors/zile/zile-2.4.15.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-editors/zile/zile-2.4.15.ebuild b/app-editors/zile/zile-2.4.15.ebuild
new file mode 100644
index 000000000000..07c97a015ba0
--- /dev/null
+++ b/app-editors/zile/zile-2.4.15.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Zile is a small Emacs clone"
+HOMEPAGE="https://www.gnu.org/software/zile/"
+SRC_URI="mirror://gnu/zile/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="acl"
+
+RDEPEND=">=dev-libs/boehm-gc-7.2:=
+ sys-libs/ncurses:0=
+ acl? ( virtual/acl )"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="dev-lang/perl
+ sys-apps/help2man
+ virtual/pkgconfig"
+
+# AUTHORS, FAQ, and NEWS are installed by the build system
+DOCS="README THANKS"
+
+QA_AM_MAINTAINER_MODE=".*help2man.*" #450278
+
+src_configure() {
+ econf \
+ $(use_enable acl) \
+ CURSES_LIB="$("$(tc-getPKG_CONFIG)" --libs ncurses)"
+}
+
+src_test() {
+ if tput cup 0 0 >/dev/null || tput cuu1 >/dev/null; then
+ # We have a sane terminal that can move the cursor
+ emake check
+ else
+ ewarn "Terminal type \"${TERM}\" is too stupid to run zile"
+ ewarn "Running the tests with unset TERM instead"
+ ( unset TERM; emake check )
+ fi
+}