summaryrefslogtreecommitdiff
path: root/app-editors/yudit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-15 01:59:31 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-15 01:59:31 +0000
commit7b744169f910185aacfd39dbd71d58b58a2e1d2f (patch)
tree1a81b82134de57caaca49c598db383ff87721640 /app-editors/yudit
parent330454de22a51b01089472bf131acd28ea0c64ec (diff)
gentoo auto-resync : 15:02:2023 - 01:59:31
Diffstat (limited to 'app-editors/yudit')
-rw-r--r--app-editors/yudit/Manifest2
-rw-r--r--app-editors/yudit/yudit-3.1.0.ebuild27
2 files changed, 29 insertions, 0 deletions
diff --git a/app-editors/yudit/Manifest b/app-editors/yudit/Manifest
index 2f784cccba38..1436a273bab6 100644
--- a/app-editors/yudit/Manifest
+++ b/app-editors/yudit/Manifest
@@ -1,3 +1,5 @@
DIST yudit-2.9.6.tar.gz 2797142 BLAKE2B 76fb8e0ade65c84389db71b4100e458f5b70aebba27eea4b604bfcee08974060dcd2bab2d86586b5ba729d8d5090c943e825dfe58d71c609f0ca2f2e0c3900c9 SHA512 a9a0b6f6c44451cf2fefc4fc0bb1bbd9ffccd17c4c622dc35b08113245b3bb9f3ca949f3e7b9d2aa919ebf3840295c5e63c0297576e74a5f2d1fb99cfc97c46b
+DIST yudit-3.1.0.tar.gz 4317815 BLAKE2B fdcec8402bd87f800b0e2712f74d5d546d7ba0733b36fec720e46ef0c5efc0be340ec8db7ffe101c5596d054cc10e1364bf2d5a70f25b234e57165b5116edd80 SHA512 07b89cdea29971fe49a7e61e2919261d6a39a6420c2587fad160a78885513460cb210b63dbfc1320f993d38e56e4104f77911530b9b7da210bfb7390e37ed352
EBUILD yudit-2.9.6.ebuild 612 BLAKE2B 9fc03d9e79eb473ba93311f1f1ee0b06d89fcb660824a6208f91336843a155699915932b76ddf23cbfed1416728b15656abcb5a8559e577df7ed607535f58a9f SHA512 b75ab3cf367289057aa900abf457404076a1d42e094c9cda26adf7404e43ba22b09e7d074b4f09acbfba3ff34ccf57ceb84878b1b0aeaeef61a1160c7b693aed
+EBUILD yudit-3.1.0.ebuild 611 BLAKE2B c1d47b4b6b56f72947b3127494453316cbd503bae9dd7ffd833d286c5f80f6fbcc2f18835689598a71c4b07e1a9e829c990035eb52ecf8be63388aaa047d02fb SHA512 0dc0cdbae8e043a7ee1d7ef3f54bc84a61b5dd5c76e3428c876d07093ca6c6a99d1ddbf40441e7489b81434128733b825e07f7bb1de9df9c84f102fad33859ae
MISC metadata.xml 168 BLAKE2B 2e0e000b4c3b6ca04c12903fdbe278415c05a822623c52e9aa95cbbf3d50bcb1246b7edbda7d2f6b559af8950c6374e6e0a69b76319964cfe686bf50b0604a57 SHA512 4dcf45d1809e8390a2d8155c8ebfe0dd610203e392aeab0ccd8a10f42cc8532a4925eff32b35e7a6c35598a4efd288229034ec0732299dbd8cfa0acff705fed3
diff --git a/app-editors/yudit/yudit-3.1.0.ebuild b/app-editors/yudit/yudit-3.1.0.ebuild
new file mode 100644
index 000000000000..242bbde3de65
--- /dev/null
+++ b/app-editors/yudit/yudit-3.1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Free (Y)unicode text editor for all unices"
+HOMEPAGE="https://www.yudit.org/"
+SRC_URI="https://yudit.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/gettext"
+
+src_prepare() {
+ default
+ # Don't strip binaries, let portage do that.
+ sed -i "/^INSTALL_PROGRAM/s: -s::" Makefile.conf.in || die "sed failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc {BUGS,CHANGELOG,NEWS,TODO}.TXT
+}