summaryrefslogtreecommitdiff
path: root/app-editors/xemacs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /app-editors/xemacs
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'app-editors/xemacs')
-rw-r--r--app-editors/xemacs/Manifest1
-rw-r--r--app-editors/xemacs/xemacs-21.5.9999.ebuild260
2 files changed, 261 insertions, 0 deletions
diff --git a/app-editors/xemacs/Manifest b/app-editors/xemacs/Manifest
index c1431b02ab20..0cb1ec5551d1 100644
--- a/app-editors/xemacs/Manifest
+++ b/app-editors/xemacs/Manifest
@@ -19,4 +19,5 @@ DIST xemacs-21.5.34.tar.gz 15816932 BLAKE2B e3be282717b91308c94d3d4bee74527d0b31
EBUILD xemacs-21.4.24-r3.ebuild 7093 BLAKE2B b110be14467c17919c72baeff5339dcc1d135f883047cf699e781b4302a0b37a6f6dfa0175de4a66e64fc0d457531ad85a20d83ca8e01d6660dcb0a5a83565ba SHA512 5f01488f2bc7155de34d0c8e7fde30f51584abbe45ad3f2d482b442df26305f8765c0940255e607bc09f9b914facaeb554e0d969bb72e2891fae944cb08c5f9c
EBUILD xemacs-21.5.34-r6.ebuild 7320 BLAKE2B 7899c64b324d0ee03e39c4bc0e99ff376716fb9dd26a229a902392a8cbe7864c2a2069bb1d852e1bf551d7fde1e0d5dcecb62e1fea667bfc644ea4f77b6e996b SHA512 83fba83ef8fa82697a181f9c8934132e03e9452bb891112a91ddc0f720a9649942c9c2c7ea1c0151c48de8d342d85f83039f69faf685973d0112acb1cc224173
EBUILD xemacs-21.5.34-r7.ebuild 7293 BLAKE2B 2d8ca8d8e740acd1ac2428a0ef6bf6f4ff4d0b7721269ac97134a998363f9785defa80ec557a1cc92d1bac30cfc8d66f8dd8a565e601883a45004ab4c8d5b889 SHA512 ac10ecd3e0ac78df8f57bdff5b32a5b9186699d03f3bc92f2333a8b757f17c8d216ed1eed38b2ec7d397906ecfb5153f25f7a3502f8bc33f3078109b350b283c
+EBUILD xemacs-21.5.9999.ebuild 7278 BLAKE2B 24b150d959a6b637fe236e8556eaed90751a9d7026e23547040dac3314f9f2eb1b2c924c01f011746c712b2e8c154fc429d9d785fd475c0dbe18875be2688800 SHA512 d59515764b97797552c7210e863dd4e5c052ff0cd10d34e64882bc2c034d7a4425e1efeb3de0d5ff5c0aed801a58d4203cb3c3f38d4ab519cdbbaa2480ff4fc0
MISC metadata.xml 683 BLAKE2B 060e4f7830a96404813a550debecf83c2de3993183d41638362ed01a3a6240bdd33a83c0db5e31a2f2e821046fb1c15199688271c27611689aac1bdf02bcde14 SHA512 176625d3c972766aaecd10125e69b4cdcbedff958b842b2ac2b6a39d728ec868b3311ef13f6854122063810c5125f48d73cd1e68083de5ddf3ef85f7f2b09cdc
diff --git a/app-editors/xemacs/xemacs-21.5.9999.ebuild b/app-editors/xemacs/xemacs-21.5.9999.ebuild
new file mode 100644
index 000000000000..10c8d43ee877
--- /dev/null
+++ b/app-editors/xemacs/xemacs-21.5.9999.ebuild
@@ -0,0 +1,260 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Note: xemacs currently does not work with position independent code
+# so the build forces the use of the -no-pie option
+
+EAPI=7
+
+inherit flag-o-matic xdg-utils desktop
+
+DESCRIPTION="highly customizable open source text editor and application development system"
+HOMEPAGE="http://www.xemacs.org/"
+SRC_URI="http://www.malfunction.de/afterstep/files/NeXT_XEmacs.tar.gz"
+
+inherit mercurial
+EHG_REPO_URI="https://foss.heptapod.net/xemacs/xemacs"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="alsa debug eolconv gif gpm pop postgres ldap xface nas dnd X jpeg tiff png mule motif freewnn xft xim athena neXt Xaw3d gdbm berkdb"
+
+X_DEPEND="x11-libs/libXt x11-libs/libXmu x11-libs/libXext x11-misc/xbitmaps"
+
+RDEPEND="
+ berkdb? ( >=sys-libs/db-4:= !!<sys-libs/db-4 )
+ gdbm? ( >=sys-libs/gdbm-1.8.3[berkdb(+)] )
+ >=sys-libs/zlib-1.1.4
+ >=dev-libs/openssl-0.9.6:0
+ >=media-libs/audiofile-0.2.3
+ gpm? ( >=sys-libs/gpm-1.19.6 )
+ postgres? ( dev-db/postgresql:= )
+ ldap? ( net-nds/openldap )
+ alsa? ( media-libs/alsa-lib )
+ nas? ( media-libs/nas )
+ X? ( $X_DEPEND !Xaw3d? ( !neXt? ( x11-libs/libXaw ) ) )
+ dnd? ( x11-libs/dnd )
+ motif? ( >=x11-libs/motif-2.3:0[xft=] )
+ athena? ( x11-libs/libXaw )
+ Xaw3d? ( x11-libs/libXaw3d[unicode] )
+ xft? ( media-libs/freetype:2 x11-libs/libXft x11-libs/libXrender >=media-libs/fontconfig-2.5.0 )
+ neXt? ( x11-libs/neXtaw )
+ xface? ( media-libs/compface )
+ tiff? ( media-libs/tiff:0 )
+ png? ( >=media-libs/libpng-1.2:0 )
+ jpeg? ( virtual/jpeg:0 )
+ freewnn? ( app-i18n/freewnn )
+ >=sys-libs/ncurses-5.2:=
+ >=app-eselect/eselect-emacs-1.15"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PDEPEND="app-xemacs/xemacs-base
+ mule? ( app-xemacs/mule-base )"
+
+src_unpack() {
+ mercurial_src_unpack
+
+ use neXt && unpack NeXT_XEmacs.tar.gz
+}
+
+src_prepare() {
+ use neXt && cp "${WORKDIR}"/NeXT.XEmacs/xemacs-icons/* "${S}"/etc/toolbar/
+ find "${S}"/lisp -name '*.elc' -exec rm {} \; || die
+ # eapply "${FILESDIR}/${P}-ncurses-tinfo.patch"
+ # eapply "${FILESDIR}/${P}-gcc5.patch"
+ # eapply "${FILESDIR}/${P}-glibc-macro.patch"
+ # eapply "${FILESDIR}/${P}-as-needed.patch"
+ # eapply "${FILESDIR}/${P}-configure-libc-version.patch"
+ # eapply "${FILESDIR}/${P}-ar.patch"
+ # eapply "${FILESDIR}/${P}-strsignal.patch"
+ # eapply "${FILESDIR}/${P}-process-test-qa.patch"
+
+ eapply_user
+
+ # Some binaries and man pages are installed under suffixed names
+ # to avoid collions with their GNU Emacs counterparts (see below).
+ # Fix internal filename references.
+ sed -i -e 's/exec gnuclient/&-xemacs/' lib-src/gnudoit || die
+ sed -i -e '/^\.so/s/etags/&-xemacs/' etc/ctags.1 || die
+ sed -i -e '/^\.so/s/gnuserv/&-xemacs/' etc/gnu{client,doit,attach}.1 || die
+}
+
+src_configure() {
+ local myconf=""
+
+ # bug #639642
+ test-flags -no-pie >/dev/null && append-flags -no-pie
+ filter-flags -pie
+
+ if use X; then
+
+ myconf="${myconf} --with-widgets=athena"
+ myconf="${myconf} --with-dialogs=athena"
+ myconf="${myconf} --with-menubars=lucid"
+ myconf="${myconf} --with-scrollbars=lucid"
+ if use motif ; then
+ myconf="--with-widgets=motif"
+ myconf="${myconf} --with-dialogs=motif"
+ myconf="${myconf} --with-scrollbars=motif"
+ myconf="${myconf} --with-menubars=lucid"
+ fi
+ if use athena or use Xaw3d ; then
+ myconf="--with-scrollbars=athena"
+ fi
+
+ if use Xaw3d; then
+ myconf="${myconf} --with-athena=3d"
+ elif use neXt; then
+ myconf="${myconf} --with-athena=next"
+ else
+ myconf="${myconf} --with-athena=xaw"
+ fi
+
+ use dnd && myconf="${myconf} --with-dragndrop --with-offix"
+
+ myconf="${myconf} $(use_with tiff )"
+ myconf="${myconf} $(use_with png )"
+ myconf="${myconf} $(use_with jpeg )"
+ myconf="${myconf} $(use_with xface )"
+
+ use xft && myconf="${myconf} --with-xft=emacs,tabs,menubars,gauges" ||
+ myconf="${myconf} --with-xft=no"
+
+ else
+ myconf="${myconf}
+ --without-x
+ --without-xpm
+ --without-dragndrop
+ --with-xft=no
+ --with-gif=no"
+ fi
+
+ if use mule ; then
+ myconf="${myconf} --with-mule"
+
+ if use xim ; then
+ if use motif ; then
+ myconf="${myconf} --with-xim=motif"
+ else
+ myconf="${myconf} --with-xim=xlib"
+ fi
+ else
+ myconf="${myconf} --with-xim=no"
+ fi
+
+ myconf="${myconf} $(use_with freewnn wnn )"
+ fi
+
+ # This determines the type of sounds we are playing
+ local soundconf="native"
+
+ # This determines how these sounds should be played
+ use nas && soundconf="${soundconf},nas"
+ use alsa && soundconf="${soundconf},alsa"
+
+ myconf="${myconf} --with-sound=${soundconf}"
+
+ if use gdbm || use berkdb ; then
+ use gdbm && mydb="gdbm"
+ use berkdb && mydb="${mydb},berkdb"
+
+ myconf="${myconf} --with-database=${mydb}"
+ else
+ myconf="${myconf} --without-database"
+ fi
+
+ use debug && myconf="${myconf} --with-debug" ||
+ myconf="${myconf} --with-optimization"
+
+ econf ${myconf} \
+ $(use_with gif ) \
+ $(use_with gpm ) \
+ $(use_with postgres postgresql ) \
+ $(use_with ldap ) \
+ $(use_with eolconv file-coding ) \
+ $(use_with pop ) \
+ --prefix=/usr \
+ --without-canna \
+ --with-ncurses \
+ --with-msw=no \
+ --with-mail-locking=flock \
+ --with-site-lisp=yes \
+ --with-site-modules=yes \
+ --with-system-malloc \
+ --enable-option-checking=no \
+ --with-last-packages=/usr/lib/xemacs
+}
+
+src_compile() {
+ emake EMACSLOADPATH="${S}"/lisp
+}
+
+src_install() {
+ emake prefix="${ED}"/usr \
+ mandir="${ED}"/usr/share/man/man1 \
+ infodir="${ED}"/usr/share/info \
+ libdir="${ED}"/usr/$(get_libdir) \
+ datadir="${ED}"/usr/share \
+ install
+
+ # Rename some applications installed in bin so that it is clear
+ # which application installed them and so that conflicting
+ # packages (emacs) can't clobber the actual applications.
+ # Addresses bug #62991.
+ for i in b2m ctags etags gnuclient gnudoit gnuattach; do
+ mv "${ED}"/usr/bin/${i} "${ED}"/usr/bin/${i}-xemacs || die "mv ${i} failed"
+ done
+
+ # rename man pages
+ for i in ctags etags gnuserv gnuclient gnudoit gnuattach; do
+ mv "${ED}"/usr/share/man/man1/${i}{,-xemacs}.1 || die "mv ${i}.1 failed"
+ done
+
+ # install base packages directories
+ dodir /usr/lib/xemacs/xemacs-packages/
+ dodir /usr/lib/xemacs/site-packages/
+ dodir /usr/lib/xemacs/site-modules/
+ dodir /usr/lib/xemacs/site-lisp/
+
+ if use mule;
+ then
+ dodir /usr/lib/xemacs/mule-packages
+ fi
+
+ # remove extraneous info files
+ cd "${ED}"/usr/share/info
+ rm -f dir info.info texinfo* termcap* standards*
+
+ cd "${S}"
+ dodoc CHANGES-* ChangeLog INSTALL Installation PROBLEMS README*
+
+ newicon "${S}"/etc/${PN}-icon.xpm ${PN}.xpm
+
+ domenu "${FILESDIR}"/${PN}.desktop
+}
+
+pkg_postinst() {
+ eselect emacs update ifunset
+ eselect gnuclient update ifunset
+ xdg_desktop_database_update
+
+ einfo "If you are upgrading from XEmacs 21.4 you should note the following"
+ einfo "incompatibilities:"
+ einfo "- Mule-UCS is no longer supported due to proper UTF-8 support in XEmacs 21.5"
+ einfo "- The X resource class has changed from Emacs to XEmacs,"
+ einfo " settings in your .Xdefaults file should be updated accordingly."
+
+ if use xft;
+ then
+ einfo "You have enabled Xft font support. Xft requires font names to be provided"
+ einfo "in a different way, so you may need to adjust your .Xdefaults accordingly."
+ fi
+}
+
+pkg_postrm() {
+ eselect emacs update ifunset
+ eselect gnuclient update ifunset
+ xdg_desktop_database_update
+}