summaryrefslogtreecommitdiff
path: root/app-editors/wily
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-22 10:09:44 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-22 10:09:44 +0000
commit09351e78166b5e864197c4456ebae3f89dd0bed9 (patch)
tree41a96399f56ed3aa399006871bfce4430db84aa2 /app-editors/wily
parentc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (diff)
gentoo resync : 22.01.2019
Diffstat (limited to 'app-editors/wily')
-rw-r--r--app-editors/wily/Manifest3
-rw-r--r--app-editors/wily/wily-1.0-r1.ebuild6
-rw-r--r--app-editors/wily/wily-1.0-r2.ebuild41
3 files changed, 46 insertions, 4 deletions
diff --git a/app-editors/wily/Manifest b/app-editors/wily/Manifest
index 7787ee90c940..9c09cb1f8f31 100644
--- a/app-editors/wily/Manifest
+++ b/app-editors/wily/Manifest
@@ -1,3 +1,4 @@
DIST wily-9libs.tar.gz 125247 BLAKE2B 94f93d081c90f6543bb26d17f8fe053135be2df983a2280fdd15243c5e448f5f3265666692e0635156217b0e759e0d6f3bbc123cb857f1d7880ee3ee4f913a37 SHA512 3c06ef1d9c6e77a00037570f8b8bdbcdfc7648f691675db679ba83ac0ce092762a4020b0483acd325aa57810e9a386800a94c5e6e2b5002a963b4751a4d30a5b
-EBUILD wily-1.0-r1.ebuild 836 BLAKE2B 6717232ddcf0cd6bc64d92e6818fe357bf314070be79ac475961e8020c8177b21b758497fe2e22de1ce3fb5402e5948e4198f260f23677c5b59a2b0f5ac5d260 SHA512 b3d14f3578e8916f0a8fc5e89cbaf9c9ba9187fb73395de796bfd7f52ea524b3d63f6a4e721dd988f928488981c3b8dde7a5f1759257ea984fa71d18367edf67
+EBUILD wily-1.0-r1.ebuild 809 BLAKE2B d78d084be0cda1dfa32453974846d2721ab700ed6b476e440d8f0d2b3a5401b2d8a2c084666db0267f7517dd10e6bac8c36506967844fd914948a9532d1607a0 SHA512 fb05e0ad34abf3b1a0a7a6949016da6ec0da8e8f52a2947bedc282f5499a70ba4b44e5dd5fe3ffb57941522035d40281aa7889246cb186278e9b48f4d9fc5336
+EBUILD wily-1.0-r2.ebuild 690 BLAKE2B 6fcb5dd31dc24b7e98c561b0c4aeaa82b9ab9c4ac52086605544188ca5229512ac1d25f0ad7742f510d651d09a94581dbc167b32ec1a5541e9e82cf07d6e0028 SHA512 57c61443e2ba44a649a384eaf240d6443fd40732515182cd33300476356a738edb36e091d13e025b9854d56f1f86c5357b0a496da2da715b2fb0383ad687c5d7
MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/app-editors/wily/wily-1.0-r1.ebuild b/app-editors/wily/wily-1.0-r1.ebuild
index f9093824c539..cb3089155b19 100644
--- a/app-editors/wily/wily-1.0-r1.ebuild
+++ b/app-editors/wily/wily-1.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=0
@@ -8,8 +8,8 @@ inherit toolchain-funcs
MY_P="${P/1.0/9libs}"
DESCRIPTION="An emulation of ACME, Plan9's hybrid window system, shell and editor"
-HOMEPAGE="http://www.netlib.org/research/9libs/"
-SRC_URI="ftp://www.netlib.org/research/9libs/${MY_P}.tar.gz"
+HOMEPAGE="https://www.netlib.org/research/9libs/"
+SRC_URI="${HOMEPAGE}${MY_P}.tar.gz"
LICENSE="Artistic"
SLOT="0"
diff --git a/app-editors/wily/wily-1.0-r2.ebuild b/app-editors/wily/wily-1.0-r2.ebuild
new file mode 100644
index 000000000000..0266f79b98e6
--- /dev/null
+++ b/app-editors/wily/wily-1.0-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit multilib toolchain-funcs
+
+MY_P="${P/1.0/9libs}"
+
+DESCRIPTION="An emulation of ACME, Plan9's hybrid window system, shell and editor"
+HOMEPAGE="https://www.netlib.org/research/9libs/"
+SRC_URI="${HOMEPAGE}${MY_P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="
+ dev-libs/9libs[X]
+"
+RDEPEND="
+ ${DEPEND}
+"
+DOCS=(
+ README
+)
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ tc-export CC
+
+ mhw_cv_mod_9libs_lib_path=/usr/$(get_libdir) \
+ mhw_cv_mod_9libs_inc_path=/usr/include/9libs \
+ econf
+}
+
+src_install() {
+ default
+
+ insinto /usr/share/${PN}
+ doins "${S}"/misc/*
+}