summaryrefslogtreecommitdiff
path: root/app-editors/retext
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /app-editors/retext
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'app-editors/retext')
-rw-r--r--app-editors/retext/Manifest4
-rw-r--r--app-editors/retext/retext-7.2.0-r1.ebuild70
-rw-r--r--app-editors/retext/retext-9999.ebuild20
3 files changed, 84 insertions, 10 deletions
diff --git a/app-editors/retext/Manifest b/app-editors/retext/Manifest
index f51b7b84c651..dd6373eca8d4 100644
--- a/app-editors/retext/Manifest
+++ b/app-editors/retext/Manifest
@@ -1,4 +1,6 @@
DIST ReText-7.1.0.tar.gz 484989 BLAKE2B 74f07218cba1d76d011e5347c65ec03ef84da29119c177f35cca206cb269ae4755fdb85448562a378d2ab610930d23b4eccb62a39807409c6e80a68102be2034 SHA512 92333f31f7a57440d642246ed30156384285bb44640a0d6e7654e82749681893eaef3cb16e41fa2d7b618aa59f1ea8cb07d431736b00f35cb9130d7294e3d105
+DIST ReText-7.2.0.tar.gz 516895 BLAKE2B e35cfa59b248135be4454359516c36f94e927cb13d60669cffde6b8b70eb5049e2083e6bd50ea1f602f7454025271599a92e34d4bc95920cb17271882f8f6d31 SHA512 ed1cb0088fcd3f1cba96bb07137766c6ae8177e8c9a91f22334ef2f949b58792e03f0b5022d9ef71bfb611b7969c651b4c7920f48ed8e1ad07caff2f69c85a35
EBUILD retext-7.1.0.ebuild 1817 BLAKE2B 6035dcc2cc18d8058ab116873db58b1a97c65df58a813dae6136b59e1335c3addb198220669d7ea9bfe0274f427a1fbc146f4ff78f49ec61afb58852a340af04 SHA512 0221e5f05f50d2cf16dd625ab06e9421eefdfc889af1ab45cde6500031d8b695cc8585704f29dc3ba7c40cc55c6d54e9e7b3d685c2fdb2d257bed92c926c87fa
-EBUILD retext-9999.ebuild 1819 BLAKE2B 9c152888905c1a661ac3d733a86bbbc70fe6cd4e242be81d6be6c9e0f7850aa4b273a8641c5c1b536acb3c55502e418d97cdc5d9781177525cf230ab40bdd615 SHA512 fe8a0991975ccf2db9305373d5168319f5828a06c2804dd29704e3473eba3c7a3fb606da212bea5e1d3f2fc20f11b65b885dab8dc050bcdd69a2bcf0fa6cf6d0
+EBUILD retext-7.2.0-r1.ebuild 1966 BLAKE2B 88148cf5fd35d5f1f319b387d5fe34c9f57d0b36f12951b517d9f73a8d0b28c3ec1629e838750046d0fb66c75b46b6f61c6c7d8267cbcaa9e18ed434d114eee0 SHA512 5c79c14f6b5160cfc760f658d30e25ffd3e98bb035faa8100054531a6e554ff33e6ed2adcb62c69c3d05256f1d00af41ef8f4e374012a5c90b64666c834bb336
+EBUILD retext-9999.ebuild 1966 BLAKE2B 88148cf5fd35d5f1f319b387d5fe34c9f57d0b36f12951b517d9f73a8d0b28c3ec1629e838750046d0fb66c75b46b6f61c6c7d8267cbcaa9e18ed434d114eee0 SHA512 5c79c14f6b5160cfc760f658d30e25ffd3e98bb035faa8100054531a6e554ff33e6ed2adcb62c69c3d05256f1d00af41ef8f4e374012a5c90b64666c834bb336
MISC metadata.xml 496 BLAKE2B ad4453602e60bdaf37553cd2fe8c9ea8abc163a86fded505e69bfa06f40d503b0cc58651068a4c52a6ffd0c8368f855512ec83aefff4a64a696e1b042a129e6a SHA512 0e182c5ddf9ac27dd9b6eb70c9a3ebdf711552e4e00db2d66696bdd992dc7824f51c86acb60f044342534b230c9884d45c55177d05f7ea92be81297994b7f559
diff --git a/app-editors/retext/retext-7.2.0-r1.ebuild b/app-editors/retext/retext-7.2.0-r1.ebuild
new file mode 100644
index 000000000000..4da9da3b40b9
--- /dev/null
+++ b/app-editors/retext/retext-7.2.0-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Please don't add pypy support before testing if it's actually supported. The
+# old compat matrix is no longer accessible as of 2021-02-13 but stated back
+# in 2020-07-05 that PyQt5 was explicitly not supported.
+PYTHON_COMPAT=( python3_{8,9} )
+
+inherit distutils-r1 optfeature virtualx xdg-utils
+
+MY_PN="ReText"
+MY_P="${MY_PN}-${PV/_/~}"
+
+DESCRIPTION="Simple editor for Markdown and reStructuredText"
+HOMEPAGE="https://github.com/retext-project/retext https://github.com/retext-project/retext/wiki"
+
+if [[ ${PV} == *9999 ]]
+ then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/retext-project/retext.git"
+ else
+ SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/markups[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/python-markdown-math[${PYTHON_USEDEP}]
+ dev-python/PyQt5[dbus,gui,printsupport,widgets,${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="test? ( dev-python/PyQt5[testlib,${PYTHON_USEDEP}] )"
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+
+ optfeature "dictionary support" dev-python/pyenchant
+ # See https://bugs.gentoo.org/772197.
+ optfeature "rendering with webengine" dev-python/PyQtWebEngine
+
+ einfo "Starting with retext-7.0.4 the markdown-math plugin is installed."
+ einfo "Note that you can use different math delimiters, e.g. \(...\) for inline math."
+ einfo "For more details take a look at:"
+ einfo "https://github.com/mitya57/python-markdown-math#math-delimiters"
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
diff --git a/app-editors/retext/retext-9999.ebuild b/app-editors/retext/retext-9999.ebuild
index 33902ed3198e..4da9da3b40b9 100644
--- a/app-editors/retext/retext-9999.ebuild
+++ b/app-editors/retext/retext-9999.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-# no pypy{,3} support as PyQt5 does not support it at 2020-07-05 (towelday)
-# https://bitbucket.org/pypy/compatibility/wiki/Home#!gui-library-bindings
-PYTHON_COMPAT=( python3_{7,8,9} )
+# Please don't add pypy support before testing if it's actually supported. The
+# old compat matrix is no longer accessible as of 2021-02-13 but stated back
+# in 2020-07-05 that PyQt5 was explicitly not supported.
+PYTHON_COMPAT=( python3_{8,9} )
inherit distutils-r1 optfeature virtualx xdg-utils
-DISTUTILS_USE_SETUPTOOLS=rdepend
MY_PN="ReText"
MY_P="${MY_PN}-${PV/_/~}"
@@ -23,7 +23,7 @@ if [[ ${PV} == *9999 ]]
else
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
KEYWORDS="~amd64 ~x86"
- S="${WORKDIR}"/${MY_P}
+ S="${WORKDIR}/${MY_P}"
fi
LICENSE="GPL-2+"
@@ -37,10 +37,10 @@ RDEPEND="
dev-python/markups[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]
dev-python/python-markdown-math[${PYTHON_USEDEP}]
- dev-python/PyQt5[gui,network,printsupport,widgets,${PYTHON_USEDEP}]
- dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
+ dev-python/PyQt5[dbus,gui,printsupport,widgets,${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}"
+BDEPEND="test? ( dev-python/PyQt5[testlib,${PYTHON_USEDEP}] )"
src_test() {
virtx distutils-r1_src_test
@@ -55,11 +55,13 @@ pkg_postinst() {
xdg_icon_cache_update
optfeature "dictionary support" dev-python/pyenchant
+ # See https://bugs.gentoo.org/772197.
+ optfeature "rendering with webengine" dev-python/PyQtWebEngine
einfo "Starting with retext-7.0.4 the markdown-math plugin is installed."
einfo "Note that you can use different math delimiters, e.g. \(...\) for inline math."
einfo "For more details take a look at:"
- einfo "https://github.com/mitya57/python-markdown-math#math-delimiters"
+ einfo "https://github.com/mitya57/python-markdown-math#math-delimiters"
}
pkg_postrm() {