summaryrefslogtreecommitdiff
path: root/app-editors/retext
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /app-editors/retext
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'app-editors/retext')
-rw-r--r--app-editors/retext/Manifest4
-rw-r--r--app-editors/retext/retext-7.1.0.ebuild68
-rw-r--r--app-editors/retext/retext-9999.ebuild22
3 files changed, 79 insertions, 15 deletions
diff --git a/app-editors/retext/Manifest b/app-editors/retext/Manifest
index 773e57e4db73..d0f0ef660ed6 100644
--- a/app-editors/retext/Manifest
+++ b/app-editors/retext/Manifest
@@ -1,4 +1,6 @@
DIST ReText-7.0.4.tar.gz 402934 BLAKE2B bae66a5fb8e81192d692d1a239706e2feee6ee940685cffdf3498880b2c9bd67cc85c6150e372a383e4bad13da210426fff95c06b2861b58020c2c6d298cf5d2 SHA512 cb12666b15414f4bf83f3b07c94d3bcba13dd3e6c3832c66520bfe8caafeeb87cc083a1e74530d98d6e00a00363add55fdf873e6de385e637876454130deebb3
+DIST ReText-7.1.0.tar.gz 484989 BLAKE2B 74f07218cba1d76d011e5347c65ec03ef84da29119c177f35cca206cb269ae4755fdb85448562a378d2ab610930d23b4eccb62a39807409c6e80a68102be2034 SHA512 92333f31f7a57440d642246ed30156384285bb44640a0d6e7654e82749681893eaef3cb16e41fa2d7b618aa59f1ea8cb07d431736b00f35cb9130d7294e3d105
EBUILD retext-7.0.4-r1.ebuild 1846 BLAKE2B 3b30b9b5b486551f5ac7b1da324843ef7fbe6e0a8d2df3d787b52dc72b1e1a18e755c3cfe29e5b057d0fe4294c7da81263fe831fa44c80346d3f7094a6bc86cf SHA512 a8839bc8c0a3ca39649b6af774f8a65e496e21cd866059e67b7caf18403d6b247a3f917ade610ec074e00857e5374e05173f3e23a336859bc23a0731e5f1987a
-EBUILD retext-9999.ebuild 1848 BLAKE2B 4a75d45db8f9b49a6d51c65948977f3131f5cc835eb98a38bf348f116e1097a25e7afcbeaa38d63a1fbcefdb06ca46f0f11cfe87d666a82a1643d61e7f760f34 SHA512 a362639fbecd506f815f01fc39d299f99810b3d1c7b66017e89c20b4ebbf868fc8a8583b16cb17fceb84006180e2d214bccb13e74532332e563e1057c6513e4f
+EBUILD retext-7.1.0.ebuild 1815 BLAKE2B 6e11140eb671436bbe5c429fbff1b8979e77935abffcacaf48e2fff7f334ec0c1448d71b32a1daeb271de31ddd88759513ed3a92896da775a1ad49f9f114625a SHA512 7eb528818d824fda30c86fef2760c1ab90310805cffa5bb4e5b3ca68b4bd80b9a504eaeb88ef2d54018be9d41866b90df44cc33cf0b3a6c1d29a672315baeddc
+EBUILD retext-9999.ebuild 1808 BLAKE2B c4c846679a9a6dee6388122fabcabab56309bc0f03a9d7cf9959c4f09758ae201dda44a2c8f0eb73139d2c26aeb265879016760c39fba444b1be94e751f6528a SHA512 e0a004901fd67abfb52e988d081016b91b4f0baa2a1e8c4116f90e3afe8bc1ea65ec63a4e0d026df162b0ddbf3a63032564b27890d4f6ab252b2e463484e67fc
MISC metadata.xml 496 BLAKE2B ad4453602e60bdaf37553cd2fe8c9ea8abc163a86fded505e69bfa06f40d503b0cc58651068a4c52a6ffd0c8368f855512ec83aefff4a64a696e1b042a129e6a SHA512 0e182c5ddf9ac27dd9b6eb70c9a3ebdf711552e4e00db2d66696bdd992dc7824f51c86acb60f044342534b230c9884d45c55177d05f7ea92be81297994b7f559
diff --git a/app-editors/retext/retext-7.1.0.ebuild b/app-editors/retext/retext-7.1.0.ebuild
new file mode 100644
index 000000000000..482db4845ce4
--- /dev/null
+++ b/app-editors/retext/retext-7.1.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# no pypy{,3} support as PyQt5 does not support it at 2020-07-05 (towelday)
+# https://bitbucket.org/pypy/compatibility/wiki/Home#!gui-library-bindings
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1 eutils virtualx xdg-utils
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+MY_PN="ReText"
+MY_P="${MY_PN}-${PV/_/~}"
+
+DESCRIPTION="Simple editor for Markdown and reStructuredText"
+HOMEPAGE="https://github.com/retext-project/retext https://github.com/retext-project/retext/wiki"
+
+if [[ ${PV} == *9999 ]]
+ then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/retext-project/retext.git"
+ else
+ SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}"/${MY_P}
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/markups[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/python-markdown-math[${PYTHON_USEDEP}]
+ dev-python/PyQt5[gui,network,printsupport,widgets,${PYTHON_USEDEP}]
+ dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+
+ optfeature "dictionary support" dev-python/pyenchant
+
+ einfo "Starting with retext-7.0.4 the markdown-math plugin is installed."
+ einfo "Note that you can use different math delimiters, e.g. \(...\) for inline math."
+ einfo "For more details take a look at:"
+ einfo "https://github.com/mitya57/python-markdown-math#math-delimiters"
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
diff --git a/app-editors/retext/retext-9999.ebuild b/app-editors/retext/retext-9999.ebuild
index 44d48af58513..72e36651206d 100644
--- a/app-editors/retext/retext-9999.ebuild
+++ b/app-editors/retext/retext-9999.ebuild
@@ -3,11 +3,12 @@
EAPI=7
-# no pypy{,3} support as PyQt5 does not support it at 2019-05-15
+# no pypy{,3} support as PyQt5 does not support it at 2020-07-05 (towelday)
# https://bitbucket.org/pypy/compatibility/wiki/Home#!gui-library-bindings
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit distutils-r1 virtualx xdg-utils
+DISTUTILS_USE_SETUPTOOLS=rdepend
MY_PN="ReText"
MY_P="${MY_PN}-${PV/_/~}"
@@ -27,7 +28,7 @@ fi
LICENSE="GPL-2+"
SLOT="0"
-IUSE="+spell"
+RESTRICT="!test? ( test )"
RDEPEND="
dev-python/chardet[${PYTHON_USEDEP}]
@@ -37,18 +38,9 @@ RDEPEND="
dev-python/pygments[${PYTHON_USEDEP}]
dev-python/python-markdown-math[${PYTHON_USEDEP}]
dev-python/PyQt5[gui,network,printsupport,widgets,${PYTHON_USEDEP}]
- || (
- dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
- <dev-python/PyQt5-5.12[webengine]
- )
- spell? ( dev-python/pyenchant[${PYTHON_USEDEP}] )
-"
-DEPEND="
- ${RDEPEND}
-"
-BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
"
+DEPEND="${RDEPEND}"
src_test() {
virtx distutils-r1_src_test
@@ -62,6 +54,8 @@ pkg_postinst() {
xdg_desktop_database_update
xdg_icon_cache_update
+ optfeature "dictionary support" dev-python/pyenchant
+
einfo "Starting with retext-7.0.4 the markdown-math plugin is installed."
einfo "Note that you can use different math delimiters, e.g. \(...\) for inline math."
einfo "For more details take a look at:"